locked
os upgrade RRS feed

  • Question

  • test environment

    Hello - I have a 2016 server with 2016 CU10 exchange

    couple days ago I upgraded the OS from 2016 to 2019 and now I can't get the Exchange Transport Service to start. Clients can connect but there is no mail flow.

    its in a starting or stopping status.

    Can you help?


    • Edited by jamicon Thursday, February 7, 2019 1:46 PM
    Thursday, February 7, 2019 1:22 PM

Answers

  • Hello , 

    In place OS upgrade is not recommended by Microsoft on the server where exchange application was installed on it .Hence i would suggest you to rebuild the server with the same OS , same name , install the prerequisites and then recover your exchange application by using the recovery switch and It will bring back the required things from active directory for the exchange application to work. 

    Since this is a test environment So i believe you don't have to restore any data once the exchange server is recovered .


    Thanks & Regards S.Nithyanandham

    • Marked as answer by jamicon Thursday, February 7, 2019 3:29 PM
    Thursday, February 7, 2019 2:43 PM

All replies

  • Hello , 

    As per my knowledge In Place upgrades for OS is not supported when exchange application is installed on it .


    Thanks & Regards S.Nithyanandham

    Thursday, February 7, 2019 1:29 PM
  • I read that too but I have done it and this was a test environment, I now know not to do it in Prod.

    However, anything I can do at this point to get mail flow again?

    Thursday, February 7, 2019 1:48 PM
  • Hello , 

    In place OS upgrade is not recommended by Microsoft on the server where exchange application was installed on it .Hence i would suggest you to rebuild the server with the same OS , same name , install the prerequisites and then recover your exchange application by using the recovery switch and It will bring back the required things from active directory for the exchange application to work. 

    Since this is a test environment So i believe you don't have to restore any data once the exchange server is recovered .


    Thanks & Regards S.Nithyanandham

    • Marked as answer by jamicon Thursday, February 7, 2019 3:29 PM
    Thursday, February 7, 2019 2:43 PM