locked
Sharepoint 2007 SSP Search DB too Large RRS feed

  • Question

  • I am running a Sharepoint 2007 server with an SQL 2005 backend. I have 2 WFE and an SQL Server.

    I have been trying to reduce the size of the SSP Search DB. Currently the .mdf is about 270GB.

    I have a maintenance plan in place that backs up the DB, truncates the logs, and shrinks the DB.

    When I attempt to Reset the crawled content, I get an error page, and nothing is removed from the DB.

    SHort of recreating the SSP, how can I fix this?

    Friday, February 18, 2011 12:33 AM

Answers

  • Hi,

    Thanks to share your post.

    For the issue, do you mean that the “operation has time out” error happened when you reset the crawled content? If yes, this should be a web service error; my suggestion is to set the SendTimeOut and ReceiveTimeOut property in the web.config.

    And the followed references should also give you a hand:

    http://www.pcreview.co.uk/forums/system-net-webexception-operation-has-timed-out-again-t2898704.html.

    Hope this could help you!

    Leo

    • Marked as answer by Emir Liu Monday, March 7, 2011 7:20 AM
    Monday, February 28, 2011 8:54 AM
  • Perform the followig steps to fix the search offline issue and then try to reset the index.

    1. Stop and start search services on index server and other servers running the query role
    2. Restart the search servcie via central administration under Operations --> Services on server
    3. Go to service.msc and restart the Office Search Service manually
    4. Make sure that the search service account has correct rights to SQL

    Thanks,
    Dip


    Dip
    http://dzeee.net/sharepoint
    • Marked as answer by Emir Liu Monday, March 7, 2011 7:20 AM
    Wednesday, March 2, 2011 2:53 AM

All replies

  • What is the error you get when resetting the index? Once this gets fixed I think the search database would be cleared.

    Thanks,
    Dip


    Dip
    http://dzeee.net/sharepoint
    Sunday, February 20, 2011 3:39 PM
  • The follwoing pops in the application log about the time Search Administration returns the error web page. BTW the Search Administration web page is just a generic error page and does not give a code or clue what is wrong, other than a time out.

    Event: 6482

    Source: Office Sharepoint Server

    Category: Office Server Shared services.

    Application Server Administration job failed for service instance Microsoft.Office.Server.Search.Administration.SearchServiceInstance (fa7b54d1-c05f-4910-b4ce-702366d992cd).

    Reason: The operation has timed out

    Techinal Support Details:
    System.Net.WebException: The operation has timed out
       at Microsoft.Office.Server.Search.Administration.SearchApi.RunOnServer[T](CodeToRun`1 remoteCode, CodeToRun`1 localCode, Boolean useCurrentSecurityContext, Int32 versionIn)
       at Microsoft.Office.Server.Search.Administration.SearchApi..ctor(WellKnownSearchCatalogs catalog, SearchSharedApplication application)
       at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.Synchronize()
       at Microsoft.Office.Server.Administration.ApplicationServerJob.ProvisionLocalSharedServiceInstances(Boolean isAdministrationServiceJob)

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Monday, February 21, 2011 4:51 PM
  • Hi,

    Thanks to share your post.

    For the issue, do you mean that the “operation has time out” error happened when you reset the crawled content? If yes, this should be a web service error; my suggestion is to set the SendTimeOut and ReceiveTimeOut property in the web.config.

    And the followed references should also give you a hand:

    http://www.pcreview.co.uk/forums/system-net-webexception-operation-has-timed-out-again-t2898704.html.

    Hope this could help you!

    Leo

    • Marked as answer by Emir Liu Monday, March 7, 2011 7:20 AM
    Monday, February 28, 2011 8:54 AM
  • I am by no means a master of IIS/Webservers, so please bare with me.

    I checked the web.config in both the Sharepoint site VD and the SSP VD and neither had the timeout comment.

    I checked the web.config file in c:\program files\common files\microsoft shared\web server extensions\12\template\admin and made changes to the time out and had no effect

    I made changes to the web.config file in the .net directory, and it had no effect.

    I made the changes to timeout in web.config file at c:\program files\common files\microsoft shared\web server extensions\12\template\layouts and it had no effect

    The web page that is erroring is http://<server>:<port>/ssp/admin/_layouts/searchreset/aspx

    it says Error

    The search service is currently offline. Visit the services on Server page in SharePoint Central Administration to verify whether the service is enabled. This might be because an indexer move is in progress.

    Unfortunately the service is running.

    Tuesday, March 1, 2011 11:59 PM
  • Perform the followig steps to fix the search offline issue and then try to reset the index.

    1. Stop and start search services on index server and other servers running the query role
    2. Restart the search servcie via central administration under Operations --> Services on server
    3. Go to service.msc and restart the Office Search Service manually
    4. Make sure that the search service account has correct rights to SQL

    Thanks,
    Dip


    Dip
    http://dzeee.net/sharepoint
    • Marked as answer by Emir Liu Monday, March 7, 2011 7:20 AM
    Wednesday, March 2, 2011 2:53 AM