none
POST inputs size limitations in R server RRS feed

  • Question

  • Hi all,
    i'm new to the group, but i didn't see anything relevant to the following topic in past discussions.
    When using job submit API call i get 413 (Request Entity Too Large)
    Indeed, i have an r encoded input which is a bit large (cannot see the size, but less than 1 Mbyte), but i need to ask you:
    1. is there a way to make the server receiver larger posts?
    2. is there a way to zip the encoded part of the post?
    3. i need to upload data to deployr in another way?
    Thanks in advance for your support
    Marco
    Saturday, April 23, 2016 5:45 PM

All replies

  • It is possible you may be hitting the maximum POST size limit permitted by Tomcat per it's default configuration:


    maxPostSize 
    The maximum size in bytes of the POST which will be handled by the container FORM URL parameter parsing. The limit can be disabled by setting this attribute to a value less than zero. If not specified, this attribute is set to 2097152 (2 megabytes).


    Does the size of your encoded input exceed 2 megabytes? If so, you will need to shutdown your DeployR server (stopAll) and change the default configuration in the Tomcat server.xml file for you installation. Per the note shown above, setting a value of -1 for the maxPostSize property on your Connector should allow arbitrarily large HTTP POSTs to DeployR.

    The updated Connector in your server.xml file should look something like this  (assuming you are running DeployR 7.4):

    <Connector port="7400"
                       protocol="org.apache.coyote.http11.Http11NioProtocol"
                       compression="1024"
                       compressableMimeType="text/html,text/xml,..."
                       connectionTimeout="20000"
                       maxPostSize="-1"
                       redirectPort="7401" />

    Monday, April 25, 2016 10:05 PM