none
64bit capture wont load/display on 32bit machine RRS feed

  • Question

  • Hey People,

    I've captured about 1.6Gigs of SSAS Cube sync (over HTTPS) on my win2008R2 x64 box, but can't seem to open it on my win7 x86 PC.

    I'm running the same version (though x64 and x86 as appropriate) of NetMon (3.4.2350.0) and have all the same versions of the parsers installed:

    NetworkMonitor Parsers - 03.04.2774.0001
    NetworkMonitor Parsers for Lync - 03.04.2611.0001
    NetworkMonitor Parsers for Office - 03.04.2654.0001
    NetworkMonitor Parsers for SQLServer - 03.04.2774.0001

    But when I open the .cap file on my PC, the capture tab just comes up empty of any data.

    I can open it quite happily on other win2008R2 x64 machines, but not my win7 x86 PC.

    Is this a 64bit vs 32bit binary format issue? I'd have thought the .cap files would have been independant of this.

    Any ideas?

    Thanks
    Craig

    Tuesday, December 11, 2012 3:48 AM

Answers

  • Thanks Michael,

    OK, this just got spooky....

    Even a small cap file wont display.

    However, when I open a new cap file, if I click in the Network Conversations window, the frames magically appear!

    I guess it's todo with no conversation being selected on load and the .cap file doesn't store (or NetMon doesn't pull out of the cap file) the conversations.

    Such a noobe fail, though I've never noticed this before and I've been using NetMon for years.

    Just tried some of my old x86 based cap files and they show the same thing.

    Must be a display bug in the current version of NetMon.

    Thanks
    Craig

    • Marked as answer by Craig Humphrey Thursday, December 13, 2012 4:08 AM
    Thursday, December 13, 2012 4:08 AM

All replies

  • Hi Craig,

    There shouldn't be any compatibility issues, so this is a bit odd.  If you save off just a few frames from your trace to a new file, does the x86 PC load that?

    Thanks,


    Michael Hawker | Program Manager | Network Monitor

    Wednesday, December 12, 2012 7:52 PM
    Moderator
  • Thanks Michael,

    OK, this just got spooky....

    Even a small cap file wont display.

    However, when I open a new cap file, if I click in the Network Conversations window, the frames magically appear!

    I guess it's todo with no conversation being selected on load and the .cap file doesn't store (or NetMon doesn't pull out of the cap file) the conversations.

    Such a noobe fail, though I've never noticed this before and I've been using NetMon for years.

    Just tried some of my old x86 based cap files and they show the same thing.

    Must be a display bug in the current version of NetMon.

    Thanks
    Craig

    • Marked as answer by Craig Humphrey Thursday, December 13, 2012 4:08 AM
    Thursday, December 13, 2012 4:08 AM
  • Glad you figured it out Craig.

    We did have a mix of x64 and x86 machines while working on Network Monitor, so I'm thinking there's some other factor at play, but for now it may just remain a mystery.

    We'd have to investigate further, but we're not working on Network Monitor anymore (outside of some parser updates). Hopefully you've started checking out its replacement: Message Analyzer with our Beta on Connect.  We'd love to hear any of your thoughts on it.

    Thanks for the report though,


    Michael Hawker | Program Manager | Network Monitor

    Thursday, December 13, 2012 8:51 PM
    Moderator