none
GPO Setting (HKCU) Internet Explorer -> Add-on list not working‎ anymore?! RRS feed

  • Question

  • We have group a policy setup for IE (v. 11.0.18 - KB3038314) for Windows 7 at our company.

    The domain policy is set to disable Shockwave Flash Object. Since an update of IE this does not seem to work anymore …..

    Does anyone have the same or a similar problem?

    Not work:
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Ext\CLSID]

    "​{D27CDB6E-AE6D-11CF-96B8-444553540000}"="0"


    • Edited by laxe.de Thursday, May 7, 2015 11:16 AM
    Thursday, May 7, 2015 11:05 AM

Answers

  • Hi,

    I didn't consider your CLSID incorrect. I just consider you want to disable the Shockwave Flash Object.

    So your issue is to enable it instead of disable it, right?

    If yes, in above reference I provided, it says,

    0 - The add-on is disabled, and users cannot manage the add-on from the user interface.

    1 - The add-on is enabled, and users cannot manage the add-on from the user interface.

    2 - The add-on is enabled, and users can manage the add-on from the user interface.

    Therefore, if you want to reactive it, just change value to "1" or "2".

    And remember to run "gpupdate /force" to enforce this configuration.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, May 13, 2015 8:38 AM
    Moderator

All replies

  • Hi,

    do you have an example public url where this is occurring? Using the Developer tool's DOM Explorer to examine the CLSID attribute value of the <object> tag. Please post back with the address/and/or CLSID and codebase attribute values.

    Macromedia was sold to Adobe a few years ago and the clsid was changed. There are actually 4 CLSID's for 'flash' that are used in the wild. Normally registry entries exist for the 3 different GUIDS which handle interoperability....  Possibly you have run a registry cleaner that has removed the redundant GUIDs or some other reason (Start>Control Panel>Flash... if you are blocking flash then there is no reason to have it installed... perhaps a user has installed it and the kill bits in GPO have been altered).

    {D27CDB6E-AE6D-11CF-96B8-444553540000}
    {166B1BCA-3F9C-11CF-8075-444553540000}
    {2A202491-F00D-11cf-87CC-0020AFEECF20}
    {233C1507-6A77-46A4-9443-F871F945D258}

    A GUID lookup can be found at http://mikolajapp.appspot.com


    Rob^_^

    Thursday, May 7, 2015 11:54 PM
  • Hi,

    The value 0 means disabled. It means your group policy applied fine.

    More information, please read this article:

    How to Disable Internet Explorer (IE) Add-Ons through Group Policy

    http://social.technet.microsoft.com/wiki/contents/articles/11406.how-to-disable-internet-explorer-ie-add-ons-through-group-policy.aspx


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, May 8, 2015 7:35 AM
    Moderator
  • The CLSID is absolute correct (see above). This has worked flawlessly for a year.

    Test URL: https://www.adobe.com/de/software/flash/about/

    Friday, May 8, 2015 10:52 AM
  • Hi, thanks for the link...

    GPEdit>Administrative Templates>Windows Components>Internet Explorer>Administrator approved controls>Shockwave Flash

    Designates Shockwave flash as an administrator approved control.

    If you enable this policy, this control can be run in security zones in which you specify that administrator-approved controls can be run.

    If you disable this policy or do not configure it, this control will not be designated as administrator-approved.

    To specify how administrator-approved controls are handled for each security zone, carry out the following steps:
    1. In Group Policy, click User Configuration, click Internet Explorer Maintenance, and then click Security.
    2. Double-click Security Zones and Content Ratings, click Import the Current Security Zones Settings, and then click Modify Settings.
    3. Select the content zone in which you want to manage ActiveX controls, and then click Custom Level.
    4. In the Run ActiveX Controls and Plug-ins area, click Administrator Approved.

    Regards.


    Rob^_^

    Saturday, May 9, 2015 12:51 AM
  • Hi, thanks @IECustomizer for the reply. I followed your instruction, but it didn´t work out, partly. I was able to activate the blocking of shockwave by modifying the security zones as described, but I can´t reactivate it by the group policy element “Add-on List”, like I used to do.

    P.S.: Internet Explorer maintenance no longer exists since the version IE10.
    • Edited by laxe.de Monday, May 11, 2015 11:43 AM
    Monday, May 11, 2015 9:56 AM
  • Hi,

    I didn't consider your CLSID incorrect. I just consider you want to disable the Shockwave Flash Object.

    So your issue is to enable it instead of disable it, right?

    If yes, in above reference I provided, it says,

    0 - The add-on is disabled, and users cannot manage the add-on from the user interface.

    1 - The add-on is enabled, and users cannot manage the add-on from the user interface.

    2 - The add-on is enabled, and users can manage the add-on from the user interface.

    Therefore, if you want to reactive it, just change value to "1" or "2".

    And remember to run "gpupdate /force" to enforce this configuration.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, May 13, 2015 8:38 AM
    Moderator