locked
Wsus "The remote name could not be resolved" How do I amend the remote name? RRS feed

  • Question

  • Hi All, I'm losing my mind a little here.

    Our primary site also doubles as our SUP and we're having issues with synchronisation, for a pretty obvious reason....

    I can see within WSUSCtrl.log that there is a typo, causing connection issues:

    System.Net.WebException: The remote name could not be resolved: '[wrong server address I need t change]'~~   at Microsoft.UpdateServices.Administration.AdminProxy.CreateUpdateServer(Object[] args)~~   at Microsoft.SystemsManagementServer.WSUS.WSUSServer.ConnectToWSUSServer(String ServerName, Boolean UseSSL, Int32 PortNumber)

    I just want to know the location that I can correct this cock up within SCCM (or WSUS?). If anyone has any insight, you would be making my week.

    Thanks in advance and seasons greetings etc.

    Ben

    Tuesday, December 19, 2017 9:17 AM

Answers

  • Hi There,

    So it was a registry entry all along. No idea how (who...) or why,  as the cert was correct and in place. I had all sorts of issues, which you'd logically expect once I put all the pieces together:

    - No communication to local WSUS

    - No distribution to DP's, with "cannot decrypt" message

    - SCEP being a pain as an offshoot.

    I searched for the incorrect spelling of the FQDN within the registry, which led me to the following:

    computer\hkey_local_machine\software\microsoft\update services\server\setup

    I amended the servercertificatename key to represent the correct spelling.

    I can sleep now, right?

    • Marked as answer by Benjo84 Wednesday, December 20, 2017 9:22 AM
    Wednesday, December 20, 2017 9:22 AM

All replies

  • > "Our primary site also doubles as our SUP"

    I'm assuming that you mean you primary site *server* as a primary site is not a single system but a logical construct within ConfigMgr that can span many servers.

    Is WSUS properly installed and functioning on the site server as well?

    I don't know of anyway for this to be incorrect ion the first place (assuming supported operations have been performed). Removing the SUP role and reinstalling should fix it though.


    Jason | https://home.configmgrftw.com | @jasonsandys

    Tuesday, December 19, 2017 2:15 PM
  • Is the server correct in the Registry, no other GPO change WSUS Settings?

    http://www.sccm-tools.com http://sms-hints-tricks.blogspot.com

    Tuesday, December 19, 2017 4:39 PM
  • Hi,

    Have you checked WCM.log and wsyncmgr.log? See https://docs.microsoft.com/en-us/sccm/core/plan-design/hierarchy/log-files#BKMK_SUPLog

    For Troubleshooting Software Updates Synchronization Failures, reference https://technet.microsoft.com/en-us/library/bb735874.aspx?f=255&MSPPError=-2147217396

    Best Regards,

    Lorry


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, December 20, 2017 5:18 AM
  • Hi There,

    So it was a registry entry all along. No idea how (who...) or why,  as the cert was correct and in place. I had all sorts of issues, which you'd logically expect once I put all the pieces together:

    - No communication to local WSUS

    - No distribution to DP's, with "cannot decrypt" message

    - SCEP being a pain as an offshoot.

    I searched for the incorrect spelling of the FQDN within the registry, which led me to the following:

    computer\hkey_local_machine\software\microsoft\update services\server\setup

    I amended the servercertificatename key to represent the correct spelling.

    I can sleep now, right?

    • Marked as answer by Benjo84 Wednesday, December 20, 2017 9:22 AM
    Wednesday, December 20, 2017 9:22 AM
  • That sounds like the server was renamed at some point and WSUS was installed prior to the server rename. That has nothing to do with your DPs though and calls into question the entire installation IMO.

    Jason | https://home.configmgrftw.com | @jasonsandys

    Wednesday, December 20, 2017 8:30 PM
  • In this situation, the most likely cause is that the WsusPool Application Pool in IIS is in a stopped state

    --Open IIS>Server>Application Pool>WSUS Pool then Start it.

    -- Private Memory Limit (KB) for the Application Pool is set to the default value of 1843200 KB, increase the Private Memory Limit to 4GB (4000000 KB) and restart the "application pool"

    Thanks.

    Thursday, December 21, 2017 6:11 AM
  • In this situation, the most likely cause is that the WsusPool Application Pool in IIS is in a stopped state

    --Open IIS>Server>Application Pool>WSUS Pool then Start it.

    -- Private Memory Limit (KB) for the Application Pool is set to the default value of 1843200 KB, increase the Private Memory Limit to 4GB (4000000 KB) and restart the "application pool"

    Thanks.


    Huh? That has nothing to do with the issue reported -- not even close.

    Jason | https://home.configmgrftw.com | @jasonsandys

    Friday, December 22, 2017 5:56 PM
  • I know this thread is many years old, but the easily way to solve this is to re run WSUSUTIL CONFIGURESSL  <properserverFQDNwithoutyourtypo>

    I ran into this today.

    It will update the key and set the configuration properly. 
    Tuesday, March 24, 2020 4:48 AM