locked
Too many prompts for authentication credentials. RRS feed

  • Question

  • Work sessions for users attempting to utilize the SharePoint web interface and Office documents shared through SharePoint are too frustrating for users.

    Web Access via IE9: For any given session the initial login to the SharePoint website results in an authentication challenge. Checking the "Remember my credentials" checkbox in the authentication dialog does not prevent the challenge the next time the user tries to access the site in a subsequent session.

    Editing documents with Word: When Word documents are opened for edit via the SharePoint website yet another "Windows Security" dialog is presented. This again requires the user to enter their password. Again, the "Remember my credentials" checkbox does not prevent this dialog from appearing when subsequent documents are opened from SharePoint.

    SharePoint Lists in Outlook: When an Outlook instance is opened that includes SharePoint Lists the "Windows Security" dialog is presented again. This is particularly frustrating since the authentication for the SharePoint server is identical to the authentication for the Exchange server that Outlook does successfully reuse without prompting. As with IE9 and Word, the checkbox "Remember my credentials" does not affect the behavior. The next time Outlook is opened another "Windows Security" dialog will be presented.

    The Windows Valut in Windows 7 lists a number of "Windows Credentials." Included in the list is the address of the SharePoint web interface. They report a Modified date of Today. This will update each day even though the password is unchanged.

    These constant prompts for the password are preventing adoption of the SharePoint services by users. They are hesitant to use the SharePoint services because they are tired of having to enter thier password multiple times each work session.

    It seems that the "Windows Vault" is not working correctly with SharePoint 3.0. The "Windows Vault" appears to be designed specifically for storing the credentials however those credentials are then not being used whenever IE9 or Office programs need to authenticate with SharePoint 3.0

    Please let me know if this is a known defect in "Windows Vault" or "SharePoint 3.0" and if any work-arounds are available.

    Test System: Microsoft Windows 7 Professional Service Pack 1 x64, Microsoft Internet Explorer 9 x32, Microsoft Office 2010 Professional Plus x32, Microsoft Windows SharePoint Services 3.0. The Windows 7 client is not a member of a domain. A domain account is used for Microsoft Windows SharePoint Services 3.0 authentication.



    • Moved by Mike Walsh FIN Friday, July 29, 2011 5:04 AM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Thursday, July 28, 2011 6:13 PM

Answers

  • Hi,

     

    please try to add the site to Local Intranet.

     

    You can find it by going to Internet Options>Security>Sites(selecting Local intranet)

     

    Hope this helps.

    • Marked as answer by User 01 Friday, July 29, 2011 3:58 PM
    Friday, July 29, 2011 12:08 PM

All replies

  • Hi,

     

    please try to add the site to Local Intranet.

     

    You can find it by going to Internet Options>Security>Sites(selecting Local intranet)

     

    Hope this helps.

    • Marked as answer by User 01 Friday, July 29, 2011 3:58 PM
    Friday, July 29, 2011 12:08 PM
  • Thanks for the reply Wayne Fan. Adding the HTTP URL for the SharePoint site to the list of Local intranet sites in Internet Explorer resolved the issue. I retested with IE9, Word, and Outlook. None of them prompted for authentication credentials after the URL was added to the list of Local intranet sites. I presume that this is related to the Internet Explorer "Security Settings -> User Authentication -> Logon -> Automatic logon only in Intranet zone" setting.

    This change is now producing the desired behavior. I'll just have to find the best way to ensure that all of the users make this change on their machines in our environment. Thanks.

    Friday, July 29, 2011 4:08 PM