locked
Run as administrator opens track.azurerms.com RRS feed

  • Question

  • Hello,

    We've deployed the RMS Sharing App to client computers (windows 10, domain joined); setup.exe /s, through SCCM.

    RMS Sharing app seems to work as intended.

    However, whenever a regular user attempts to run as administrator on pretty much anything, clicking OK on the prompt explaining that this is restricted by their administrator, webbrowser Edge opens https://track.azurerms.com/#/landing?q=Command%20Prompt.lnk&sourceUrl=%2F%3Fq%3DCommand%2520Prompt.lnk. The end of the URL landing?q=... depends on what you tried to run as administrator. 

    What i've tried:

    Uninstalling Azure RMS sharing App stops the problem. But now we're all paranoid about our documents.

    Identified that RMS Sharing app installs registry values and data in HKLM\Software\Classes\AllFileSystemObjects\shell\Microsoft.RMSSharing.ProtectWithRMS. If I delete this entire key the problem is removed, but so is the context menu for RMS sharing. I guess some people would mind if I go with this 'solution'.


    Has anyone had a similar problem?

    Friday, June 10, 2016 9:25 AM

All replies

  • This is VERY strange. Can you reproduce this on a non-domain joined with a manual install of the sharing app then logging on a non-admin local user?
    Friday, June 10, 2016 11:29 PM
  • Hello,

    Sorry for late response.

    I've tried to reproduce the issue on a flat windows 10 machine. Issue does not occur when i do this.

    Another test we have conducted is to remove a domian joined computer from the OU that gives the client the "group policy for clients". This makes the issue go away. Additionaly - if i join the domain on the flat Windows 10 client and give it the Group Policy, it suddenly recieves the issue.


    Wednesday, June 22, 2016 7:14 AM