none
Printers not removing when removed from group policy.

    Question

  • Hello,

    2012 R2 Native Active Directory - cluster servers with Hyper-V and standard Microsoft Group Policy Management.

    I have a print server that has 10 printers deployed using group policy. If I remove a printer from group policy using the print server, it shows removed from the print server, and it is removed from the group policy.

    However, if I run GPRESULT from the Remote Desktop Session Host (RDSH). It still shows the removed printer and creates the missing printer on the RDSH server. I deleted the entire policy but now it show the GUID of the missing policy in GPRESULT and continues to create the printers. I deleted the GUID folder from \\domain.local\sysvol\domain.local\policies\(GUID) but the GPRESULT remain with the printers and the printers are still created.

    Even with only the default domain policy (No Printers in this policy) applied the printers are still created. I've disassociated the server and rejoined. Same result.

    Does anyone know how to remove this printer(s).

    Wednesday, June 24, 2015 7:21 PM

Answers

  • Here's what did it for me.

    In the registry go to:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\Client Side Rendering Print Provider\Servers

    Look at the keys. I had Server1, Server2, Server3. I only needed the printers from Server1 so I removed the other keys.

    I think a search through the registry is also needed to remove other instances of these printers.

    Always backup the registry before removing anything....

    Anyhow it worked for me.

    Robert

    Wednesday, June 24, 2015 10:21 PM