none
Windows 7 Pro Virtual machine IP doesn't refresh

    Question

  • Hey,

    I have Win7 pro machines running in VMM and even if I change their IP address in the machine, the IP address shown in VMM doesn't change. I can RDP into the machines with the new IP so it's perfectly working. All other machines I've created work as supposed when their IPs are changed.

    Is this a know problem and is there a solution?

    Thanks,

    Joonas

    Thursday, May 03, 2018 9:40 AM

Answers

  • Alright, a solution:

    I was doing this on remote connection. Windows 7 had roughly 130 updates available after installing.

    1. Run the updates and restart
    2. Run any additional available important updates (basically if any of the previous fail)
    3. Log out of the RDP connection
    4. Connect into the machine with console on VMM and log in as local admin
    5. Use "shutdown and update"

    After this the IP addresses in VMM are correct.

    Possibly running the updates through the console connection might allow you to shutdown and update earlier which might help but the key seems to be the updates anyway.

    Friday, May 04, 2018 12:24 PM

All replies

  • Hello Joonas,

    After you changed the IP address for the VM, please perform the 'Refresh' to the VM by right clicking the VM, and choose 'Refresh'.

    If you view this VM in Hyper-V Manager, does the IP address display correctly?

    In addition, what's the OS running on the host, and what's the version of the VMM server?

    Best regards,

    Andy Liu


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, May 04, 2018 2:30 AM
  • The refresh action doesn't have any effect. It works on Windows servers and Win10 machines though.

    The VMM version is 4.0.2139.0, the machine running the VMM is Windows Server 2016.

    Hyper-V manager doesn't show any IP for the machines that have the wrong IP visible in VMM.

    Turns out some of the IPs on Win7 machines are showing correctly but I suspect those may have been correct in the beginning. When creating a new Win7 virtual machine in VMM and adding it into the VM network it automatically generates the IP when creating the machine and it doesn't seem to take in account existing computers. For example the range we are creating the new machines is .31-100 and the newest machine is .55 and creating a new machine gave it IP xxx.xxx.xxx.53 even if the address is already occupied and there is a machine running. 

    Thanks for your answer anyway!

    Friday, May 04, 2018 6:59 AM
  • Hi Joonas,

    Do you get the correct IP addresses when running the following command?

    Get-SCVirtualMachine -VMMServer "VMMServer" | Format-List -property Name, IPV4Address, IPv6Address

    Kind regards,
    Leon


    Please remember to mark the replies as answers if they help.

    Friday, May 04, 2018 7:16 AM
  • Hi Joonas,

    Do you get the correct IP addresses when running the following command?

    Get-SCVirtualMachine -VMMServer "VMMServer" | Format-List -property Name, IPV4Address, IPv6Address

    Kind regards,
    Leon


    Please remember to mark the replies as answers if they help.

    Unfortunately I'm unable to run the Powershell commands, there seems to be something wrong with the VMM config as immediately when opening powershell, I get the error on Get-SCVMMServer.. Looks like following: 

    Get-SCVMMServer : The type or name syntax of the registry key value IndigoTcpPort under Software\Microsoft\Microsoft Sy
    stem Center Virtual Machine Manager Administrator Console\Settings is incorrect.
    Ensure that the type of value name is correct; the name is not empty, contains only valid characters and is less than 2
    55 characters.
    At line:1 char:406
    + ... ell - Virtual Machine Manager';$vmmserver_VAR=Get-SCVMMServer devmgmv ...
    +                                                   ~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [], CarmineException
        + FullyQualifiedErrorId : Microsoft.VirtualManager.Utils.CarmineException

    I found this some days ago as I was intending to speed up creating the machines through a script but didn't spend more time on looking at it back then. Interesting if this error is anyhow related but only affects the Windows 7 machines though.

    After a ton of refreshing and restarting the machines through VMM, Hyper-V manager and Failover Cluster manager, one of the Windows 7 workstations now has the right IP visible but I have been unable to reproduce it.

    Thanks for your help!

    - Joonas

    Friday, May 04, 2018 7:56 AM
  • Alright, a solution:

    I was doing this on remote connection. Windows 7 had roughly 130 updates available after installing.

    1. Run the updates and restart
    2. Run any additional available important updates (basically if any of the previous fail)
    3. Log out of the RDP connection
    4. Connect into the machine with console on VMM and log in as local admin
    5. Use "shutdown and update"

    After this the IP addresses in VMM are correct.

    Possibly running the updates through the console connection might allow you to shutdown and update earlier which might help but the key seems to be the updates anyway.

    Friday, May 04, 2018 12:24 PM