none
Windows Store App does not work over VPN RRS feed

  • Question

  • My windows store app works fine if I use it directly. But if I  login to my system using VPN connection (I use Cisco VPN Client to connect to VPN), then the same app does not work. The app uses internet connection. This does not work in VPN. Is it a problem in Windows 8 or is it just my apps problem? Do I need to do any configuration changes in app manifest file?
    Wednesday, February 13, 2013 8:18 AM

Answers

  • Hi,

    Could you tell me which VPN software did you use, the Cisco client, the Windows 7 built-in or other client software?

    Try to right click your VPN connection---properties---Networking---IPv4 or IPv6---Properties---Advanced---IP settings---Use default gateway on remote network

    Hope that helps.

    Regards,

    Leo   Huang


    Leo Huang
    TechNet Community Support

    Friday, February 15, 2013 6:01 AM
    Moderator

All replies

  • I have observed this also, and many others if you do a search on the internet.

    Apparently when the VPN is conected the "local" connection shows up as being "Limited". It looks that some apps are reading this statuses and assuming the PC is offline.

    Interesting is that some other apps ignore this and continue to work fine.

    I have tried to configure a proxy, so when the VPN is up it would "foul" the app, but with not success.

    This is a bug on the apps when using VPN.

    Wednesday, February 13, 2013 8:45 AM
  • Hi,

    Could you tell me which VPN software did you use, the Cisco client, the Windows 7 built-in or other client software?

    Try to right click your VPN connection---properties---Networking---IPv4 or IPv6---Properties---Advanced---IP settings---Use default gateway on remote network

    Hope that helps.

    Regards,

    Leo   Huang


    Leo Huang
    TechNet Community Support

    Friday, February 15, 2013 6:01 AM
    Moderator
  • Hello Leo,

    This is a common problem among different VPN clients (I'm using Check Point Mobile). So I do think that this issue has nothing to do with VPN client that you are using.

    There  is a huge amount of people complaining about this, please search windows 8 modern UI issues with VPN, and you will find out this.

    I'm wondering if Microsoft is going to take a look into this, or just ignore Win8 users that have to use VPNs.

    Regards,

    Oswaldo

    Friday, February 22, 2013 3:49 AM
  • This is a known issue. Fix for this issue is available at  http://support.microsoft.com/kb/2797356

    Please install the fix, Let us know if it works for you.

    • Proposed as answer by M. Israr Khan Friday, February 22, 2013 8:10 PM
    Friday, February 22, 2013 8:09 PM
  • This hotfix resolved the issue of the internet connection itself showing "Limited", but none of my windows apps have access to the Internet yet.  Desktop apps like Firefox and Chrome work perfectly on the VPN, but apps like USA Today can't update.

    We use a Watchguard appliance in our organization and the software client for VPN access over SSL works well.  My metro apps have no problem accessing content now while connected to the Watchguard VPN.  The native VPN connection in Windows still doesn't allow metro apps to connect, but desktop apps work fine.

    • Edited by Adam Winter Wednesday, March 6, 2013 6:11 PM Updated info.
    Wednesday, March 6, 2013 4:27 PM
  • Adam, do you use some sort of authenticated proxy when connected to VPN?
    Wednesday, March 6, 2013 7:38 PM
  • I also experience this problem. My network uses Cisco VPN, and a http proxy for connection (without authentic)
    Wednesday, April 3, 2013 10:32 PM
  • MistChen, please install the update, and see if it works.

    In case it solves your problem,  mark my post as answer, so that others can benefit from it too.

    Friday, April 5, 2013 6:02 PM
  • Mr. Israr,

    I am using Cisco VPN 5.0.07 version. When I am connected to VPN, my Lync Windows App or to that matter no app connects to the Internet. I went through above post, tried it, but I cannot find what is mentioned, like I can't find IPv4 setting as Use default gateway on remote network.

    Also, when I tried to install the above mentioned Hotfix, I got a message that this Hotfix is not eligible for this system.

    FYI.. I am using Window 8.1 x64 Intel Core i5 machine.

    Please help me resolve this issue.

    Thanks,

    Mubashir

    Friday, January 9, 2015 10:31 AM
  • Seems to also be an issue in Win10. Using Juniper Pulse VPN client.

    Everything else works fine, but the store just gives "Error code 0x80072EFD". Which I can't even copy/paste. C'mon MS.


    Michael Brown, 360 Replays Ltd. (don't forget that 'Mark As Answer' button!)

    Wednesday, January 13, 2016 12:47 AM
  • I am also having a similar issue to the one posted just above.  When using the Juniper Pulse VPN Client (running on a Windows 10 machine), our Windows 8.1 client application cannot make the connection to the host unless we have Fiddler running (and acting as a proxy).  Using a browser to test the connection to the host over the Juniper Pulse VPN connection is also successful.  If possible, we would be very appreciative if Microsoft can provide a solution so that our Windows 8.1 application will successfully connect using this (or any) 3rd party VPN connection.
    Tuesday, December 6, 2016 6:57 PM
  • It's the same issue with Win 10 and F5 edge client VPN. Doing a split-tunneling solves the issue so maybe split-exclude could work if we knew the IP-address for app store repositories.
    Sunday, December 11, 2016 12:44 AM
  • Please address this Microsoft. VPN are even more critical now since our privacy is being further sold out by the recent rollback of FCC consumer protections.

    Monday, March 27, 2017 2:43 PM
  • Hello,

    I run windows 10 on x86, and I run Microsoft SSTP tunnel. I can confirm, than when I use SSTP and connect to App Store I receive error

    The error code is 0x8000FFFF, in case you need it. CV: CFLD/IPF4Umt3MZi

    When I disconnect tunnel, then I can access... But this is really big issue, because it's not only App Store not working, but also all Apps (like Facebook Messenger, or Skype installed from app store are not working to).

    Very strange, in Microsoft SSTP Tunnel skype from App store not working, but Skype downloaded and installed works fine...

    Need to fix IT, or where I can find information how to fix IT

    ED

    Tuesday, May 2, 2017 6:26 AM
  • I got this working over the VPN if other people are having the issue with a VPN over Forced Tunnel .

    You need to set these settings VIA GP / Or Local policy for testing

    Open up gpedit on your local device

    Computer Configuration/Administrator Templates/Network/Network Isolation

    Enable Subnet Definitions are authoritative

    Private Network ranges for Apps Enable

    Then add your internal network subnet range IE 10.0.0.0/8

    Restart your device and hopefully your windows store is working

    Neil

    • Proposed as answer by Boyuan.Yuan Monday, November 27, 2017 10:16 PM
    Monday, July 17, 2017 9:50 AM
  • This appears to still be an issue with Windows 10, but Neil's suggestion worked for me. We have Windows 10 and a Cisco Meraki MX firewall. Everything in the office works fine (192.168.x.x) but when a remote user connects to VPN (172.31.x.x) the Windows Store, Edge extensions, and Edge "Ask Cortana" do not work. These settings resolved the issue.
    Friday, February 2, 2018 4:32 PM
  • This did not work for me.  I still cannot use Microsoft Weather or Microsoft News when connected via VPN.
    Friday, April 19, 2019 4:07 PM