none
project server 2010: error event of severity critical occured 30 times and was suppressed -> cannot start queue: projectQ (timesheetq) after update RRS feed

  • Question

  • Hi,

    I have updated project server 2010 with the February CU. After that, project server stopped working.

    When I run the sharepoint configuration wizard, it complets successfully but asks to run the farm configuration wizard. When I run the farm configuration wizard, it times out after more than an hour. All sharepoint sites funtion properly. However, everything related to project server does not work. When I open a pwa site, I get:

    Error
    Project Web App cannot connect to Project Server. For more information, contact your system administrator.
    Troubleshoot issues with Microsoft SharePoint Foundation.
    Correlation ID: cbbf4194-71c0-4407-80e1-2cb1c81568af

    When I check for errors in the ULS, I get 3 alarming messages:

    1- There is a compatibility range mismatch between the Web server and database "ProjectServer_Published_PROJ_IT", and connections to the data have been blocked to due to this incompatibility. This can happen when a content database has not been upgraded to be within the compatibility range of the Web server, or if the database has been upgraded to a higher level than the web server. The Web server and the database must be upgraded to the same version and build level to return to compatibility range.

    2- Event 7626 (Project Server) of severity 'Critical' occurred 30 more time(s) and was suppressed in the event log

    3- Event 7626 is the following: Cannot start queue. SSP: 7d4cb30a-3c63-4375-b4e4-cef6281bda25  SiteUID: 2467c392-a8fc-46fd-9ddf-42b31b377716 Url:  Queue: ProjectQ / TimeSheetQ

    When I go to Review database status, I get "Database is too old and upgrade is required" for the project server databases and I get "Database is in compatibility range and upgrade is recommended" for the content databases.

    When I go to Manage Patch Status, it shows that the update is installed!

    When I go to Upgrade Status, it says Failed about 7 times with all being "This upgrade session has been stopped. Possible causes include the process being terminated abruptly or the OS has rebooted. Please restart the upgrade again" except for the most recent Failed being "Look for possible causes for upgrade issues by searching [ERROR] and [WARNING] strings in the upgrade log file. Refer to "http://go.microsoft.com/fwlink/?LinkId=157732" for more information about how to recover from upgrade failures."

    Finally, when I open the upgrade log file, all errors appear to be:
    [OWSTIMER] [SPUpgradeSession] [ERROR] [3/28/2012 2:54:39 PM]: Exception: Cannot open database "ProjectServer_Published" requested by the login. The login failed.
    Login failed for user 'DARBEIRUT\DB-EPM$'.
    [OWSTIMER] [SPUpgradeSession] [ERROR] [3/28/2012 2:54:39 PM]:    at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection)
       at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
       at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)
       at System.Data.SqlClient.SqlInternalConnectionTds.CompleteLogin(Boolean enlistOK)
       at System.Data.SqlClient.SqlInternalConnectionTds.AttemptOneLogin(ServerInfo serverInfo, String newPassword, Boolean ignoreSniOpenTimeout, Int64 timerExpire, SqlConnection owningObject)
       at System.Data.SqlClient.SqlInternalConnectionTds.LoginNoFailover(String host, String newPassword, Boolean redirectedUserInstance, SqlConnection owningObject, SqlConnectionString connectionOptions, Int64 timerStart)
       at System.Data.SqlClient.SqlInternalConnectionTds.OpenLoginEnlist(SqlConnection owningObject, SqlConnectionString connectionOptions, String newPassword, Boolean redirectedUserInstance)
       at System.Data.SqlClient.SqlInternalConnectionTds..ctor(DbConnectionPoolIdentity identity, SqlConnectionString connectionOptions, Object providerInfo, String newPassword, SqlConnection owningObject, Boolean redirectedUserInstance)
       at System.Data.SqlClient.SqlConnectionFactory.CreateConnection(DbConnectionOptions options, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningConnection)
       at System.Data.ProviderBase.DbConnectionFactory.CreatePooledConnection(DbConnection owningConnection, DbConnectionPool pool, DbConnectionOptions options)
       at System.Data.ProviderBase.DbConnectionPool.CreateObject(DbConnection owningObject)
       at System.Data.ProviderBase.DbConnectionPool.UserCreateRequest(DbConnection owningObject)
       at System.Data.ProviderBase.DbConnectionPool.GetConnection(DbConnection owningObject)
       at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
       at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
       at System.Data.SqlClient.SqlConnection.Open()
       at Microsoft.SharePoint.Utilities.SqlSession.OpenConnection()
       at Microsoft.SharePoint.Utilities.SqlSession.ExecuteReader(SqlCommand command, CommandBehavior behavior, SqlQueryData monitoringData, Boolean retryForDeadLock)
       at Microsoft.SharePoint.Utilities.SqlSession.ExecuteReader(SqlCommand command, Boolean retryForDeadLock)
       at Microsoft.SharePoint.Utilities.SqlSession.ExecuteReader(SqlCommand command)
       at Microsoft.SharePoint.Upgrade.SPDatabaseSequence.GetVersion(SPDatabase database, Guid id, Version defaultVersion, SqlSession session, SPDatabaseSequence sequence)
       at Microsoft.SharePoint.Upgrade.SPDatabaseSequence.GetVersion(Guid id, Version defaultVersion)
       at Microsoft.Office.Project.Server.Upgrade.ProjectDatabaseSequence.get_BuildVersion()
       at Microsoft.SharePoint.Upgrade.SPSequence.get_CanUpgrade()
       at Microsoft.SharePoint.Upgrade.SPUpgradeSession.CanUpgrade(Object o)
    [OWSTIMER] [SPUpgradeSession] [DEBUG] [3/28/2012 2:54:39 PM]: Cannot upgrade [ProjectDatabase Name=ProjectServer_Published].
    [OWSTIMER] [SPUpgradeSession] [DEBUG] [3/28/2012 2:54:39 PM]: Skip [ProjectDatabase Name=ProjectServer_Published] NeedsUpgrade.

    I've been trying to solve this issue for 2 days now with no luck. Any help much appreciated.

    Regards,
    George

    Friday, March 30, 2012 6:40 AM

Answers

All replies