none
Item-level targeting error 80070057 while adding Language

    Question

  • Hi,

    I'm having a strange error while I try to add a Language for Item-Level targeting.

    Error 80070057  : an item with the same key has already been added.

    This only happen when using GPMC on a Windows server 2012 or 2012 R2 (same with Win8.1)

    When using the GPMC on Windows server 2008r2 it works fine.

    we use the Central store, and it as the latest ADMX from Windows server 2012 r2 on it.

    It doesn't seem to be related to the target configuration. It happen with at least Internet Settings, Folder Options and power option.

    The error is displayed as soon as the New Item language is selected.

    After i hit ok, I can choose a language. BUT, the list of available language is missing a lot of languages.

    So I can'T configure it to work for IE11 settings I try to do.

    Any idea?


    Additional information : I can reproduce the problem in a separate environment.
    Wednesday, August 26, 2015 2:58 PM

All replies

  • I'm able to reproduce this in my own lab, and am able to to proceed after clicking the OK. Exactly the same behavior..

    I'm not able to find any info about this via search, probably bydesign?

    Thursday, August 27, 2015 8:37 AM
  • Have you installed any language pack on your server?
    Friday, August 28, 2015 10:51 AM
  • Hi, no language pack were installed on any servers.

    Same goes for 2008r2.

    All english

    Tuesday, September 08, 2015 6:07 PM
  • OK. It's odd, search doen't come anything related. Will try on my machine, probably use process monitor to see what exactly happened..
    Thursday, September 10, 2015 1:52 AM
  • Hi,

    I have exactly the same problem, have you found a solution?

    Koen

    Friday, April 08, 2016 10:15 AM
  • There are a few workarounds, one of which is to use WMI queries within the preference item-level targeting.

    See below for WMI queries for the OS Language being 1033 (en-us), and for the OS Language being 1036 (fr-fr)

    See https://msdn.microsoft.com/en-ca/goglobal/bb964664.aspx for a full list of locale ids

    Thursday, July 21, 2016 3:12 PM
  • I have the same issue with a 2012 r2 server and with Windows 10 1511 RSAT. It works only with 2008r2.

    I try to use item level targeting to specifiy home page depending on the language and we have the same error.

    Any help would be very appreciated

    Wednesday, August 31, 2016 1:33 PM