locked
Specify the destination for the backup package. RRS feed

  • Question

  • Hi,

    I am trying to get familiar with SP2010 and the steps of how to back up and restore site collections, content databases, etc.

    After selecting one of these components to back up, there is a field says 'specify the destination for the backup package.'

    At first, I would simply enter something like 'C:\user\mybackupfolder' and the Central Admin. would back up to the

    file 'mybackupfolder'. But there is an example just underneath the field requesting the destination for the backup

    package. The example is in UNC convention, and is something like //blah/blah/blah. When I tried to use the UNC

    convetion  I recieved an error message. I did something like //SP2010/folder33/backupstuff. Howcome this didn't

    work? And so my question is, how do I insert a UNC path when backing up components in SP?


    • Edited by Thankful33 Thursday, October 6, 2011 12:45 AM
    Thursday, October 6, 2011 12:43 AM

Answers

  • Here's a page on how to create a shared folder in Windows Server 2008: http://technet.microsoft.com/en-us/library/cc770880.aspx.

    You'll need to make sure that the account you're running the backup with has the right to write to that shared directory. (I'm assuming you're using PowerShell, if you're using the Central Admin site you need to grant write permissions to the SharePoint Timer Job service and the SQL Server Service account)

    John


    MCITP and MCTS: SharePoint, Virtualization, Project Server 2007
    My books on Amazon: The SharePoint 2010 Disaster Recovery Guide and The SharePoint 2007 Disaster Recovery Guide.
    My blog: My Central Admin.
    • Marked as answer by Thankful33 Thursday, October 6, 2011 6:55 PM
    Thursday, October 6, 2011 3:43 PM
  • Thank you John, but I figured it out. All I did was click right click on the file named 'backup' and then select properties, and click on the sharing tab up top, and then click on advanced sharing. Then Windows will just create a network share location for you in the unc convention that I wanted.

    Cheers!

    • Marked as answer by Thankful33 Thursday, October 6, 2011 6:55 PM
    Thursday, October 6, 2011 6:54 PM

All replies

  • There are two types of storage locations that you can provide as the storage location:

    • A local storage path, such as "C:\foo". The problem is that this option can only be used if you are running SharePoint's SQL Server database instance on the same server that SharePoint is running on.
    • A UNC (Universal Naming Convention) path to a shared storage location (which is formatted as \\<shared drive name>). This shared location can be created on the same server that you are using to run the backup process, or it can be on a remote server (as long as the account you're using to run the backup command has the appropriate rights in that shared folder).

    If you're not running SQL Server on the SharePoint server, then you have to use the UNC path. I'd say that you're probably formatting the UNC path for the storage location improperly, given the way you're listing it. Try replacing the forward slash (/) with a back slash (\) and see if that helps, UNC paths use the back slash (as opposed to local storage paths which use the forward slash, as do URLs).

    John


    MCITP and MCTS: SharePoint, Virtualization, Project Server 2007
    My books on Amazon: The SharePoint 2010 Disaster Recovery Guide and The SharePoint 2007 Disaster Recovery Guide.
    My blog: My Central Admin.
    Thursday, October 6, 2011 1:47 AM
  • Thanks for the reply. Ok- will you explain how to create a shared storage location on the same server that I'm using to run the backup process?

    I am using SQL server and SP2010 server on a virtual Windows Server 2008 R2 OS.




    • Edited by Thankful33 Thursday, October 6, 2011 3:40 PM
    Thursday, October 6, 2011 2:59 PM
  • Here's a page on how to create a shared folder in Windows Server 2008: http://technet.microsoft.com/en-us/library/cc770880.aspx.

    You'll need to make sure that the account you're running the backup with has the right to write to that shared directory. (I'm assuming you're using PowerShell, if you're using the Central Admin site you need to grant write permissions to the SharePoint Timer Job service and the SQL Server Service account)

    John


    MCITP and MCTS: SharePoint, Virtualization, Project Server 2007
    My books on Amazon: The SharePoint 2010 Disaster Recovery Guide and The SharePoint 2007 Disaster Recovery Guide.
    My blog: My Central Admin.
    • Marked as answer by Thankful33 Thursday, October 6, 2011 6:55 PM
    Thursday, October 6, 2011 3:43 PM
  • Thank you John, but I figured it out. All I did was click right click on the file named 'backup' and then select properties, and click on the sharing tab up top, and then click on advanced sharing. Then Windows will just create a network share location for you in the unc convention that I wanted.

    Cheers!

    • Marked as answer by Thankful33 Thursday, October 6, 2011 6:55 PM
    Thursday, October 6, 2011 6:54 PM