none
Disable SMB 1.0/CIFS File Sharing Support using SCCM TaskSequence

    Question

  • Hi Techies,

    I've tried to disable SMB using powershell scripts,It's works for me in Local Environment. But when I'm trying to run the same  Command line using SCCM TS.It doesn't work.

    Has anyone tried to do via TS?

    Please let me know the exact steps or command.

    Thanks!!

    Wednesday, February 21, 2018 7:59 PM

All replies

  • Hi JiteshKumar,

    I suggest you follow this guide to disable SMBv1 in your environment https://www.techwhisperer.ca/2017/03/04/disable-smb1-with-powershell-and-sccm/

    Regards

    Simon


    If you find that my post has answered your question, please mark it as the answer. If you find my post to be helpful in anyway, please click vote as helpful. Regards Simon Disclaimer: This posting is provided AS IS with no warranties or guarantees, and confers no rights.

    Wednesday, February 21, 2018 10:18 PM
  • What's the command-line (we can't provide technical troubleshooting without technical details)?

    Is the TS an OSD TS?


    Jason | https://home.configmgrftw.com | @jasonsandys

    Wednesday, February 21, 2018 11:12 PM
    Moderator
  • yes It's an OSD TS.
    Thursday, February 22, 2018 6:49 AM
  • You won't get help if you don't provide details at all. Please answer Jason's question first and add details if there is an error message.

    Torsten Meringer | http://www.mssccmfaq.de

    Thursday, February 22, 2018 6:58 AM
  • Can you check smsts.log and see what error message appears?

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, February 22, 2018 7:59 AM
    Moderator
  • Here's Command line which I used in SCCM TS,also used some others command line but didn't see any changes.

    Disable-WindowsOptionalFeature -Online -FeatureName SMB1Protocol

    I didn't get error message,TS is executing successfully but there's no changes in SMB Features. If there's any other command line which will disable SMB1.0/File Sharing through SCCM. Please let me know!!

    Sunday, February 25, 2018 1:43 PM
  • Please post your smsts.log on a file sharing service and link to it here.

    Also, where in the task sequence are you running the above command? Before or after the Setup Windows and ConfigMgr task?


    Jason | https://home.configmgrftw.com | @jasonsandys

    Monday, February 26, 2018 2:59 AM
    Moderator
  • Guys, Sorry for late response. I was able to successfully disable the SMB File Sharing with below CommandLine

    Disable-WindowsOptionalFeature -Online -FeatureName SMB1Protocol -norestart

    Earlier I was running the above steps directly through command line,with Powershell package it's working.

    Thanks Jason for support..!!

    Saturday, March 17, 2018 4:14 PM