locked
MSO Documents No Longer Opening in SP MOSS 2007 RRS feed

  • Question

  • Hello,


    I hope someone can help me figure this out.  We use SP MOSS 2007 for our SP services.  We have 2 types of users:


    1.  Those who have the Single Sign On (SSO) installed on their computer; once they sign on with SSO, they can access the site and its files;


    2.  Those (mainly off-site clients) who do NOT have the SSO installed on their computer; they login to the site using their credentials, then can access the site and its files


    We've been using this set-up for over a year now and have not had any issues with it until now.  Here is the issue:


    Up until we started having this problem, both types of users could go into a SP site.  They could both click on a document library, then click on a MSO file like Word or Excel.  The file would load in either read-only or edit, depending on which option the user chose after they clicked on the file.


    Keep in mind that both types of users as described above had no issue with doing it this way.


    Now, one of our clients (a user like #2 above) contacted me and said that when they login, they can navigate the site like always.  However, when they click on a Word or Excel file to open it, they are forced to login again in order to edit or read it.


    I first tested this by staying logged into SSO.  I went to the site library, clicked on a MSO file, and the file opened like it should.  I then did a second test by logging out of my SSO, logging in as the client using her credentials (no SSO), went to the library, clicked on a Word or Excel file, and sure enough I had to login again to access the file.  Meanwhile, in this same library was a PDF document.  I clicked on that and it opens fine, like you think it would.  In other words, this issue only happens when trying to open up a MSO file.


    So that is my issue.  I have absolutely no idea what the problem is so I'm hoping someone can advise me on what the problem is and recommend a solution.


    Thank you.

    Mike Walton

    Wednesday, March 28, 2012 5:37 PM

Answers

  • Hi Mike,

    You need to log in it use Administrator.

    Thanks,
    Lhan Han
    • Marked as answer by Deaf Guy 2 Tuesday, April 3, 2012 6:01 PM
    Monday, April 2, 2012 11:31 AM
    Moderator

All replies

  • Hi Mike,

    You need to configure that enable anonymous access for a web application:

    1. Go to Central Administration >> Application Management >> Authentication Providers.
        a、make sure to pick correct web application from the drop-down list at the top-right corner of the page.
        b、select the Membership Provider (most likely it will be "Default") and enable check "Enable anonymous access" checkbox.
        c、click OK to save the settings.
    2. The step above will usually enable anonymous access in IIS Manager, but just be sure:
        a、open IIS Manager
        b、right-click on your website and click on "Edit" under Authentication and Access Control
        c、make sure "Enable anonymous access" is checked
    3. Now we need to explicitly enable anonymous access on our website(s)
        a、browse to the website
        b、click Site Actions >> Site Settings >> People and Groups >> Site Permissions
        c、click on Settings >Anonymous Access and enable anonymous access for the site
    * Anonymous access will be also enabled on all sub sites that inherit security settings from the parent site.

    Here is a similar issue:
    http://sharepoint.stackexchange.com/questions/23920/office-software-remembers-logged-out-person-when-using-fba

    Thanks,
    Lhan Han


    Monday, April 2, 2012 8:30 AM
    Moderator
  • OK thank you for your reply.  When you say to go Central Administration, where is that located?  The reason why I am asking is because when I go to Site Actions > Site Settings, I do not see any link or button that says Central Administration.

    Thank you.


    Mike Walton

    Monday, April 2, 2012 10:42 AM
  • Hi Mike,

    It's a manage site:


    Thanks,
    Lhan Han
    Monday, April 2, 2012 11:12 AM
    Moderator
  • Hi Mike,

    It's a manage site:


    Thanks,
    Lhan Han
    Monday, April 2, 2012 11:12 AM
    Moderator
  • OK great - thank you for the snapshot.  This helps a lot.  Here is mine so it looks like I don't have access to central administration, right?


    Mike Walton


    • Edited by Deaf Guy 2 Monday, April 2, 2012 11:28 AM
    Monday, April 2, 2012 11:27 AM
  • Hi Mike,

    You need to log in it use Administrator.

    Thanks,
    Lhan Han
    • Marked as answer by Deaf Guy 2 Tuesday, April 3, 2012 6:01 PM
    Monday, April 2, 2012 11:31 AM
    Moderator
  • OK I will try that.  Thanks again.

    Mike Walton

    Monday, April 2, 2012 11:35 AM