none
Must change password before logging in the first time (Windows Server 2012 R2 Standard edition) RRS feed

  • Question

  • Im using windows 8.1 and I cannot conect to a server because it appears the message on the title.

    I have read some solutions to the same problem in some other windows versions, but they use tsconfig.msc to solve it, and tsconfig.msc is not present in win 8 so I hope you can help me with a proper solution.

    Thank you for your time

    Tuesday, December 10, 2013 10:06 PM

Answers

  • Hi,

    Glad you got it corrected.  This is a change with the new RD client--it should have presented you with a screen to allow you to change your password (as long as NLA is not required) as the previous versions did.

    In the future what you can do is add the following line to the .rdp file:

    enablecredsspsupport:i:0

    The above will present you with the screen that allows the password to be changed.  Please note it is preferred not to have the above line present during normal circumstances.  I recommend you use it if you have this password problem again and then take it out.

    Thanks.

    -TP

    • Proposed as answer by TP []MVP, Moderator Wednesday, December 11, 2013 2:33 PM
    • Marked as answer by eknas Wednesday, December 11, 2013 2:34 PM
    Wednesday, December 11, 2013 2:25 PM
    Moderator

All replies

  • Hi,

    If the server is part of a collection then please edit the properties of the collection using Server Manager -- RDS -- Collections -- <yourcollection> -- Tasks -- Edit Properties -- Security tab -- uncheck Allow connections only from computers running Remote Desktop with Network Level Authentication.

    If the server is not part of a collection then please go to System Properties -- Remote tab -- uncheck Allow connections only from computers running Remote Desktop with Network Level Authentication.

    Thanks.

    -TP

    Tuesday, December 10, 2013 10:39 PM
    Moderator
  • Hi,

    If the server is part of a collection then please edit the properties of the collection using Server Manager -- RDS -- Collections -- <yourcollection> -- Tasks -- Edit Properties -- Security tab -- uncheck Allow connections only from computers running Remote Desktop with Network Level Authentication.

    If the server is not part of a collection then please go to System Properties -- Remote tab -- uncheck Allow connections only from computers running Remote Desktop with Network Level Authentication.

    Thanks.

    -TP

    Hi,

    Im not sure what "being part of a collection" means.., so I have contacted my hosting server to be if that option is available. Whatever, I can tell you I have already unchecked Allow connections only from computres running Remote Desktop with Network Level Authentication at system properties..

    Thanks you.

    Tuesday, December 10, 2013 11:29 PM
  • Hi,

    Are you getting the prompt to change your password when you attempt to connect using Remote Desktop?  If not, what is the exact error message you are receiving?

    A collection is something you create when you have a RDS deployment.  If this is just a single server and you are logging on to administer it then chances are it is not part of a collection.

    -TP

    Wednesday, December 11, 2013 12:07 AM
    Moderator
  • Hi,

    As TP has already stated, Can you confirm that this is part of a RDS collection or is this a separate (single Workstation\Server).

    From the message stated in your title "Must change password before logging in the first time (Windows Server 2012 R2 Standard edition)"  Have you tired to login via the console and change the password, this usually happens when deploying from templates or Syspreping.

    More detail would be helpful.


    Help keep the forums tidy, if this has helped please mark it as an answer

    Wednesday, December 11, 2013 2:06 PM
  • Hi,

    Are you getting the prompt to change your password when you attempt to connect using Remote Desktop?  If not, what is the exact error message you are receiving?

    A collection is something you create when you have a RDS deployment.  If this is just a single server and you are logging on to administer it then chances are it is not part of a collection.

    -TP

    Hi,

    Yes, I get the message when I attempt to connect with Remote Desktop, and no, It is not a collection, it is just a single server and I am logging on to the admin account.

    Thank you for your answer but I already have solved the problem getting in touch with the hosting IT that have changed the password for me, but Im still curious..

    Wednesday, December 11, 2013 2:16 PM
  • Hi,

    As I said, the IT service have changed the password for me, but I still being curious.. Perhaps I am getting another server and it seems that this issue will happen again.. Also to get closed this question..

    Thanks you very much.

    Wednesday, December 11, 2013 2:19 PM
  • Hi,

    Glad you got it corrected.  This is a change with the new RD client--it should have presented you with a screen to allow you to change your password (as long as NLA is not required) as the previous versions did.

    In the future what you can do is add the following line to the .rdp file:

    enablecredsspsupport:i:0

    The above will present you with the screen that allows the password to be changed.  Please note it is preferred not to have the above line present during normal circumstances.  I recommend you use it if you have this password problem again and then take it out.

    Thanks.

    -TP

    • Proposed as answer by TP []MVP, Moderator Wednesday, December 11, 2013 2:33 PM
    • Marked as answer by eknas Wednesday, December 11, 2013 2:34 PM
    Wednesday, December 11, 2013 2:25 PM
    Moderator
  • Hi,

    Thank you very much, I think that is the correct way to do it!!

    I have just also been said that logging in from the Android remote desktop client makes you change the password for the first time! :D (Could be another solution)

    Thank you very much for your cooperation, you will be present in my prayers

    Wednesday, December 11, 2013 2:31 PM
  • enablecredsspsupport:i:0

    is not working, can not open rdp window at all

    • Edited by KD_Pas Tuesday, August 25, 2015 4:17 PM
    Tuesday, August 25, 2015 4:14 PM
  • working with option

    enablecredsspsupport:i:1

    in RDP file when trying to RDP from server 2012. But only when NOT logging for the first time.

    Thank you for the hint.


    • Edited by KD_Pas Tuesday, August 25, 2015 6:55 PM
    Tuesday, August 25, 2015 4:39 PM