none
Mail delivery delay on some users when a mail-enabled public folder is CC'd RRS feed

  • Question

  • We just migrated from Exchange 2007 to Exchange 2013 and we have a very strand issue that I can't quite put my finder on. Whenever a specific user is CC'd together with a mail enabled PF in the same email, a 2 minutes delay is introduced only for this user. Before I give you my troubleshooting steps, here are the different test scénarios I tried :

    external sender to PF with User1 and User2 CC'd = PF and User2 receive email instantly and User1 receives email 2 minutes later

    external sender to User1 = No delay

    external sender to User2 with PF CC'd = No delay

    external sender to User1 with PF CC'd = 2 minutes delay on User

    The message for User1 get's stuck in the submission queue for 2 minutes with the Error message : Message rerouted and delayed by store driver

    Here is a tracking a faulty message where the user was CC'd (User2 is set to forward email to externalcontact, you can ignore that) :


    Any help at this point would be greatly appreciated. 

    Tuesday, June 30, 2020 6:53 PM

All replies

  • What happens if the email is sent to PF only? Is delay noticed in this scenario.

    Logs are not clear, can you copy paste it here.

    Where are the user mailboxes and public folders homed? 

    Is it happening only when this mail enabled PF is CC'ed? 



    Thanks,
    Ashok M My blog
    ________________________________________________________________
    Please mark the reply as an answer if you find it is helpful :-)
    ________________________________________________________________

    Wednesday, July 1, 2020 7:39 AM
  • Delivery to PF with or without CC is instantaneous.

    Right click on the image and click on "Open in a new tab" get a clearer view of the attached picture (table is too wide to copy and paste here)

    The mailboxes and the PF Mailbox are on the Server 2013's only DB. (Same DB for both)

    Yes, only when PF is CC'd... Delivery to user is instant, delivery to PF instant as well, the issue is only present when both are CC'd on an email... Can't make any sense out of it... :(

    Thursday, July 2, 2020 8:03 PM
  • Delivery to PF with or without CC is instantaneous.

    Right click on the image and click on "Open in a new tab" get a clearer view of the attached picture (table is too wide to copy and paste here)

    The mailboxes and the PF Mailbox are on the Server 2013's only DB. (Same DB for both)

    Yes, only when PF is CC'd... Delivery to user is instant, delivery to PF instant as well, the issue is only present when both are CC'd on an email... Can't make any sense out of it... :(

    I'd look for rules or forwarding set on User1 and/or the PF itself ( Properties of the Public Folder in Outlook)that maybe routing the messages back and forth. (and make sure there are no transport rules doing anything funny to those messages as well)

    Mail public folder > properties > Folder Assistant…

    Thursday, July 2, 2020 8:46 PM
  • I have checked the logs and what i found is,

    EventID: ReSubmit

    SourceContext: ReRoutedbyStoreDriver

    Source: Queue

    So, can you try to repro the issue and get the below details,

    Which queue the email is stuck?

    status of the queue?

    Last error of the queue if any?


    Thanks,
    Ashok M My blog
    ________________________________________________________________
    Please mark the reply as an answer if you find it is helpful :-)
    ________________________________________________________________

    Friday, July 3, 2020 5:22 AM
  • Hi JordanTheb,

    Go to ADUC-contoso.com-Microsoft Exchange System and check if any entries about the PF exist, try to delete it and re-enable Mail for the PF with correct address, see if the issue been solved.

    Found this method in a similar thread:https://social.technet.microsoft.com/Forums/office/en-US/625aace9-3e36-48f6-86e8-d34de4a1395b/quotmessage-rerouted-and-delayed-by-store-driverquot-after-moving-public-folder-to-different?forum=exchangesvrdeploy

    Regards, 

    Eric Yin


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Friday, July 3, 2020 8:38 AM