locked
PosReady2009 Sysprep Regional Settings RRS feed

  • Question

  • Hi,

     

    I am having a bit of a nightmare with the regional settings during sysprep. I require UK English sttings but the resultant OS always reverts back to US English. I have the following settings defined relating to Regional Settings:

    [GuiUnattended]
           OEMSkipRegional=1

    [RegionalSettings]
        Language=00000809
        LanguageGroup=1
        SystemLocale=00000809
        UserLocale=00000809
        InputLocale=0809:00000809
        UserLocale_DefaultUser=00000809
        InputLocale_DefaultUser=0809:00000809

     

    The registry hive within the sysprep Wim image is already set to UK, for HKU\.Default but this gets reset to US during the Sysprep process. I have also tried the following, again without success

    [RegionalSettings]
        Language=00000809
        LanguageGroup=1

    Does PosReady use different codes?

    Thanks,

    Gary Harvey 

    Thursday, May 20, 2010 10:34 AM

Answers

  • Hi,

    Worked as expected against XP Pro...

    I ended up opening the source registry file and forcing the settings in HKU\.Default. This seems to have done the trick.

     

    Thanks for your help.

    • Marked as answer by xstaticx Thursday, June 3, 2010 4:14 PM
    Thursday, June 3, 2010 4:14 PM

All replies

  • Gary,

    This may be caused by a related issue with SYSPREP GUIRUNONCE incompatibilty with the File Based Write Filter & Registry Filter.  Please try to resolutions provided in the links below and report back your findings.

    http://technet.microsoft.com/en-us/library/ee406170.aspx#Q14

    http://social.technet.microsoft.com/Forums/en-US/posready/thread/b09d64c8-d933-4273-bb1d-8e7fbaf7b1a1

    Terry Warwick
    Microsoft

    Thursday, May 20, 2010 8:53 PM
  • Terry,

    I did have the GUIRunoce problem in the early stages of the build, so yes, that fix already in place.

    I did import the Sysprep image via MDT2010, but I don't think that has broken anything? Does PosReady use the same Lang. codes as XP?

    All other settings are correctly set including the TimeZone, Join Domain and Video settings so it is definately picking up the Sysprep.INF file. I have 1000 Pos Terminals in the inital pilot phase of this project so I need to get it right.

    As a last resort, I am thinking about pushing the international keys into the registry via GUIRunonce, not very elegant but might give me a way forward...

     

    Thanks,

    Gary 

    Friday, May 21, 2010 7:12 AM
  • Gary,

    POSReady 2009 is based on XP sources, so the codes are identical.  Can you confirm that the sysprep.inf you are using has the desired behavior on the English version of Windows XP?

    Terry Warwick
    Microsoft

    Friday, May 21, 2010 6:23 PM
  • Hi,

    Worked as expected against XP Pro...

    I ended up opening the source registry file and forcing the settings in HKU\.Default. This seems to have done the trick.

     

    Thanks for your help.

    • Marked as answer by xstaticx Thursday, June 3, 2010 4:14 PM
    Thursday, June 3, 2010 4:14 PM