locked
Creating a user friendly url is not working RRS feed

  • Question

  • Hi,

     

    I have MOSS (Enterprise), IIS 7, SQL 2005 and Windows Server 2008 all running on a single test server.

    I have made a new web app and a site in it that has this URL: http://win-zlobfrdzld5

    I want to access this same site using this URL: http://bob

     

    So I changed Alternate Access mappings, edited the local host file and set the bindings (host headers) in IIS 7 - did an IISRESET and try my bob URL...

    I am presented with a logon prompt and when I add any credentials - service account - local admin - you name it I get a 401.1 IIS error!

     

    WHY? I have followed numerous blogs on setting a nice URL and checked and rechecked - it's all ok - BUT when i have done all the configuration work and i test then i am asked to login and i can not and then i get the 401.1 error!

     

    Is this some quirk of IIS 7? I never saw this on IIS 6

     

    Anyone?

     

    Thanks!

     

     

     

     

     

     

     

    Wednesday, December 1, 2010 4:01 PM

Answers

  • Hi xyz2012,

     

    The 401.1 authentication error may be caused by the loop back check issue when accessing SharePoint site locally.

     

    Please refer to KB896861 (http://support.microsoft.com/kb/896861) to workaround the issue.

    I quoted the method 2 in the KB for your information:

     

    To disable the loopback check. follow these steps:

    1. Click Start, click Run, type regedit, and then click OK.
    2. In Registry Editor, locate and then click the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

    1. Right-click Lsa, point to New, and then click DWORD Value.
    2. Type DisableLoopbackCheck, and then press ENTER.
    3. Right-click DisableLoopbackCheck, and then click Modify.
    4. In the Value data box, type 1, and then click OK.
    5. Quit Registry Editor, and then restart your computer.

     

    Hope it can help you.

    Xue-Mei Chang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Xue-Mei Chang
    Thursday, December 2, 2010 2:20 AM
    Moderator

All replies

  • Did u try to browse the URL from IIS itself ?

     


    Regards, Pratik Vyas | SharePoint Consultant |
    Wednesday, December 1, 2010 4:55 PM
  • Hi xyz2012,

     

    The 401.1 authentication error may be caused by the loop back check issue when accessing SharePoint site locally.

     

    Please refer to KB896861 (http://support.microsoft.com/kb/896861) to workaround the issue.

    I quoted the method 2 in the KB for your information:

     

    To disable the loopback check. follow these steps:

    1. Click Start, click Run, type regedit, and then click OK.
    2. In Registry Editor, locate and then click the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

    1. Right-click Lsa, point to New, and then click DWORD Value.
    2. Type DisableLoopbackCheck, and then press ENTER.
    3. Right-click DisableLoopbackCheck, and then click Modify.
    4. In the Value data box, type 1, and then click OK.
    5. Quit Registry Editor, and then restart your computer.

     

    Hope it can help you.

    Xue-Mei Chang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Xue-Mei Chang
    Thursday, December 2, 2010 2:20 AM
    Moderator