locked
Issue setting up PXE Enabled Distribution point for SCCM 2012. RRS feed

  • Question

  • I'm trying to set up SCCM 2012 in my Lab Enviroment in order to plan for implmentation to production.

    I have installed and Configure one Primary site which has a working DP role width PXE /WDS.
    And i am able to successfully do and OS Deployment.

    I want to setup an additional Distribution point with PXE, to simulate a branch Office.

    Installation of the second Distribution point looks to be succesfull, but i'm not able to boot on PXE.

    It allways gives me the error messeage "The Windows Boot Configuration Data file does not contain a vaild OS entry
    The same error messeage is given before i distributed the boot images (both x86 and x64)

    So my thougts are that he WDS dosn't find the bootable images somehow.

    I can see that the images are added to the RemoteInstall\SMSImages directory, but i also see the following in smsdpprov.log

    [83C][Mon 04/23/2012 15:43:26]:Conent 'PS100004.7' for package 'PS100004' has been added to content library successfully
    [83C][Mon 04/23/2012 15:43:26]:Expanding \\?\E:\SCCMContentLib\FileLib\4ABE\4ABEBA3BB557A810CBCC8148BC70FE01349142EB1BCF1C1154216B77E3E22495 from package PS100004
    [83C][Mon 04/23/2012 15:43:26]:Finding Wimgapi.Dll
    [83C][Mon 04/23/2012 15:43:26]:MsiEnumRelatedProducts failed
    [83C][Mon 04/23/2012 15:43:26]:FindProduct failed; 0x80070103
    [83C][Mon 04/23/2012 15:43:26]:MsiEnumRelatedProducts failed
    [83C][Mon 04/23/2012 15:43:26]:FindProduct failed; 0x80070103
    [83C][Mon 04/23/2012 15:43:26]:Found C:\Windows\system32\wimgapi.dll
    [83C][Mon 04/23/2012 15:43:26]:Expanding PS100004 to E:\RemoteInstall\SMSImages
    [83C][Mon 04/23/2012 15:44:48]:Registry key creation successfull
    [83C][Mon 04/23/2012 15:44:48]:Registry key creation successfull
    [83C][Mon 04/23/2012 15:44:49]:Registry key creation successfull
    [83C][Mon 04/23/2012 15:45:23]:Conent 'PS100001.5' for package 'PS100001' has been added to content library successfully
    [83C][Mon 04/23/2012 15:45:23]:Expanding \\?\E:\SCCMContentLib\FileLib\5EFD\5EFD89A7C52739DC815393C586861AFB6664FD4F28726758D6A151722D160031 from package PS100001
    [83C][Mon 04/23/2012 15:45:23]:Finding Wimgapi.Dll
    [83C][Mon 04/23/2012 15:45:23]:MsiEnumRelatedProducts failed
    [83C][Mon 04/23/2012 15:45:23]:FindProduct failed; 0x80070103
    [83C][Mon 04/23/2012 15:45:23]:MsiEnumRelatedProducts failed
    [83C][Mon 04/23/2012 15:45:23]:FindProduct failed; 0x80070103
    [83C][Mon 04/23/2012 15:45:23]:Found C:\Windows\system32\wimgapi.dll
    [83C][Mon 04/23/2012 15:45:23]:Expanding PS100001 to E:\RemoteInstall\SMSImages

    Server is a clean installed Windows 2008 R2, only added to domain, added the primary SCCM server account as local Admin, added WDS Role and configured RemoteFolder before adding DP role from the SCCM Console. (So SCCM has installed and Configured IIS)

    Tuesday, April 24, 2012 10:13 AM

Answers

  • Looks like i have found the answer at least i have got it to work.

    Once i install .Net Framework 3.5.1 Feature on the server, i was able to boot succesfully into SCCM Task Sequence Wizard.
    I also was successfull installing the the PXE DP role from the console succesfully without having to install WDS first.

    So i guess that .Net Framework 3.5.1 is required for PXE DP role on Windows 2008 R2. (but i can't see that mentioned anywhere here http://technet.microsoft.com/en-us/library/c1e93ef9-761f-4f60-8372-df9bf5009be0#BKMK_SiteSystemRolePrereqs)
    • Marked as answer by Kenneth82 Tuesday, April 24, 2012 12:19 PM
    Tuesday, April 24, 2012 12:19 PM

All replies

  • Does the logfile end at that point? The important part will be a later stage.
    Keep in mind that you don't have to install or configure WDS manually. ConfigMgr will automatically take care of that. Have you also verified that the WDS service is runing?

    Torsten Meringer | http://www.mssccmfaq.de

    Tuesday, April 24, 2012 10:33 AM
  • Yes, the logfile ends at that point.

    Yes i have verified that the WDS service are running.
    THe computer finds the server and the error is displayed after i have been prompted for F12 (since it's an optional Deployment)

    I tried without install and configure WDS manually first, but then WDS will never start afterwards. I don't remember the error code now. I can start from scratch again and to that approach and get that error code, but i guess that might be another issue.

    Tuesday, April 24, 2012 10:40 AM
  • Looks like i have found the answer at least i have got it to work.

    Once i install .Net Framework 3.5.1 Feature on the server, i was able to boot succesfully into SCCM Task Sequence Wizard.
    I also was successfull installing the the PXE DP role from the console succesfully without having to install WDS first.

    So i guess that .Net Framework 3.5.1 is required for PXE DP role on Windows 2008 R2. (but i can't see that mentioned anywhere here http://technet.microsoft.com/en-us/library/c1e93ef9-761f-4f60-8372-df9bf5009be0#BKMK_SiteSystemRolePrereqs)
    • Marked as answer by Kenneth82 Tuesday, April 24, 2012 12:19 PM
    Tuesday, April 24, 2012 12:19 PM
  • Thank you so very much Kenneth82.  I've been scouring various forums, uninstallaing/reinstalling PXE, DP, WDS, SCCM altogether and this was the solution.
    Tuesday, December 17, 2013 5:44 PM
  • .Net 3.5 isn't listed as a requirement as a DP, but it is as a site system, which is required for a DP. 
    Thursday, April 10, 2014 5:25 PM