locked
WMC/WMP12/Video problems on Windows 7 64 after upgrade from Vista 64 RRS feed

  • Question

  • Hello,

    For information, I run an Acer Aspire M7720-8W7S Intel Core i7 920 4GB with a Matrox Quad m9140 graphics card and 4 IIyama 24in screens. Everything was working fine on Vista 64.
    I have upgraded my Vista 64 to Windows 7 64 smoothly and everything seems to be working pretty well except the following video problems:

    1. Opening Windows Media Center gives me a black screen on the main application screen - music is on, application is running but can't see a thing. Need to terminate the application with Task Manager.
    2. Windows Media Player 12 : Sound but No video on WMV and MP4, No DVD
    3. RealPlayer : DVD says windows media player can't read DVD's because of screen resolution - WMV sound only - plays MP4 ok - Realvideo ok - VideoFlash ok
    4. MediaPlayer Classic 64 : Plays WMV, MP4, Real and VideoFlash OK but not DVD's - Error message in all : DX9 AllocatorPresenter failed
    5. VLC Media player : No video, any format, sound on some
    6. PQ DVD to Ipod : DVD sound only, WMV ok
    7. Yasa DVD to MP4 : DVD reads ok
    8. Internet embedded videos don't show (embedded WMP only, other proprietary formats work ok)
    9. Matrox : Screens are recognised/organised by Windows 7, Matrox application OK for preferences, but no device control (example: not possible to extend 1 logical on the 4 screens). Windows 7 identifies the 4 screens in only one - i.e. numbers the screens 1,2,3 and 4 on the same main screen.

    Codecs seem OK, Flash reinstalled.

    Any bright idea ?

    Thanks

    Airgee
    • Moved by Ronnie VernonMVP Tuesday, October 27, 2009 3:39 AM Focus (From:Windows 7 Installation, Setup, and Deployment)
    Monday, October 26, 2009 9:50 PM

Answers

  • Hello,

    Thanks for your suggestions but they hardly helped.

    Re-installed the BIOS and drivers for the Matrox Graphic card : slight improvement in multiple displays control with new version of Matrox control software.

    Downloaded and installed K-lite codec pack

    The only progress is that I can watch DVD's with the Media Player that came with K-Lite.

    Still can't use Windows Media Center.
    Windows Media Player cannot show any video file or DVD
    Can't get internet explorer or Firefox WMP plugin to show anything (the plugin is there, connecting to media, than stands "Ready" but shows no video...

    Too strange

    I am reinstalling Windows 7, since system refuses any earlier version of WMP.
    Will let U know if improvement.

    In the meantime, if you find anything else, feel free to share !!

    Thanks Guys
    Thursday, October 29, 2009 8:18 PM

All replies

  • Hi Airgee,

    Have you tried doing a clean install on a spare machine using the upgrade disc you received to see if you are able to reproduce these video problems that you are facing? If you do some research, you will be able to find how to do it, but I cannot post that information here sorry.. Hope this helps.. Mods, if this is inappropriate, do let me know, thanks.
    Tuesday, October 27, 2009 12:53 AM
  • Hi,

     

    According to the problem description, this issue can be caused by one of the following factors.

     

    1.    The BIOS and display card driver is not up to date.

    2.    The necessary Codec is not installed.

     

    At this point, I suggest you contact Acer Support for the BIOS update and display card driver update for Windows 7.

     

    Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    I also suggest you try to install the K-Lite Codec Pack to check the issue.

     

    Note: The third-party product discussed here is manufactured by a company that is independent of Microsoft. We make no warranty, implied or otherwise, regarding this product's performance or reliability.

     

    Good luck!

     


    Arthur Li - MSFT
    Tuesday, October 27, 2009 8:49 AM
  • Hello,

    Thanks for your suggestions but they hardly helped.

    Re-installed the BIOS and drivers for the Matrox Graphic card : slight improvement in multiple displays control with new version of Matrox control software.

    Downloaded and installed K-lite codec pack

    The only progress is that I can watch DVD's with the Media Player that came with K-Lite.

    Still can't use Windows Media Center.
    Windows Media Player cannot show any video file or DVD
    Can't get internet explorer or Firefox WMP plugin to show anything (the plugin is there, connecting to media, than stands "Ready" but shows no video...

    Too strange

    I am reinstalling Windows 7, since system refuses any earlier version of WMP.
    Will let U know if improvement.

    In the meantime, if you find anything else, feel free to share !!

    Thanks Guys
    Thursday, October 29, 2009 8:18 PM