none
Windows cant verify the publisher of this driver software window appears but doesnt tell me what driver is causing the issue RRS feed

  • Question

  • Hi,

    I keep getting a Windows Security window that comes up saying "Windows can't verify the publisher of this driver software."  with an option to Not install or allow it to install.  There are no helpful details telling me what driver is causing this error.

    The computer is a brand new Dell Precision 7530 with Office 365 and Solidworks installed.  The window usually comes up within the first 3-5 mins of starting the computer.  I've looked through the event viewer but can't figure out what is causing the pop-up. 

    Does any one know how to investigate this?  I don't want to prevent a driver from running if it is important for the computer or some other software to function.

    Thank you in advance! 

    Tuesday, April 16, 2019 4:50 PM

All replies

  • Hi Kram13,

    Technically, on the Windows Security pop-up you're getting, there should be a small arrow in the bottom left corner, with "See details". When clicked on, it'll show you additional details about the warning such as the driver's name, its publisher, etc. Can you check if you have that option and if so, click on it? It should give you the information you're looking for.

    Thank you,

    Yoan

    Friday, April 19, 2019 1:16 PM
  • Hi Yoan,

    Thank you for replying.  Yes I clicked on the "See details" but unfortunately there were not any helpful details.

    Do you know of any other way to figure out what driver or other software is causing the pop-up?

    Thank you,

    Mark

    Friday, April 19, 2019 5:02 PM
  • Can you provide a screenshot of what you see when you click on the "See details" option? Ideally, a screenshot of the whole pop-up message.

    Also, have you tried to look in the Event Viewer (most likely under the System logs) if you can see any event related to that warning? It might hold more information.

    Friday, April 19, 2019 5:50 PM
  • I can't seem to upload pictures technet is saying I need to verify my account in order to upload pictures.  However I already verified my account.  I'm trying to figure out whats wrong and I'll upload the picture.

    I tried looking through the event viewer but couldn't find any useful alerts related to a windows security alert.  The closest thing I found is a Event 10016, DistributedCOM error below:

    Log Name:      System
    Source:        Microsoft-Windows-DistributedCOM
    Date:          4/15/2019 4:47:45 PM
    Event ID:      10016
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          SYSTEM
    Computer:      
    Description:
    The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID 
    Windows.SecurityCenter.WscBrokerManager
     and APPID 
    Unavailable
     to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.
    Friday, April 19, 2019 6:37 PM
  • If you post the link, but change "https" to "hxxps", it'll let you post it (this is what I do).

    That event doesn't seems related to the Windows Security alert you're getting. Have you noticed if you started getting that message after installing SolidWorks? Or was it already installed (and therefore, you had that message since day 1) when you received the computer?

    Are there any other third-party programs installed? Except the ones from Dell?

    Friday, April 19, 2019 6:51 PM
  • SolidWorks was already installed and therefore, had that message since day 1 when I received the computer?

    MS office, Adobe Acrobat Pro and Slack were installed but nothing else at the time.

    Friday, April 19, 2019 7:53 PM
  • hxxxs://social.technet.microsoft.com/Forums/getfile/1430154
    Friday, April 19, 2019 7:56 PM
  • My guess is that it's a driver from your SolidWorks program. When that error message is showing up, can you take a look in the Task Manager and see if you have any msiexec.exe, setup.exe, or "install-like" processes running? If you do, add the "Command line" column in the view, and see how that process is being launched exactly.

    The "Command line" column can be added by right-clicking on any columns under the "Details" tab in the Task Manager, clicking on "Select columns" and checking the "Command line" box.

    Another way you could investigate is to disable SolidWorks services and startup programs on startup, and see if you still receive that error message. If you don't, then it means that it is indeed the culprit.

    Friday, April 19, 2019 8:06 PM
  • Unfortunately I went ahead and allowed the driver to be installed yesterday because I was annoyed with it and couldn't find any answers online. So I took my chances and allowed it.  So now I can't really do what you're suggesting.  I should have been more patient :).

    It does sound like it could have been Solidworks that is causing this.  However it was running just fine without me accepting the install of this unsigned driver. 

    It is rather odd that it was giving this error.  I've had many brand new systems with Solidworks and not had this issue.

    Thank you for your help!

    Friday, April 19, 2019 11:37 PM
  • No problem Kram13, you're welcome! Sorry that we weren't able to get down to the bottom of the issue though.
    Saturday, April 20, 2019 3:47 PM
  • I have a similar system and setup...Dell Precision 7520, with SW2018 installed.  Have never had any issues like this unknown driver warning until late last week or beginning of this week.  (I've had this computer since 5/2017 and have always had a version of SW installed on it). 

    Upon investigating it today, it appears like a driver for Dell SupportAssist is the culprit.  For whatever reason, it is saying it is unsigned, when it actually is.  Since I use supportassist for very rare occasions, I just opted to uninstall it for the time.  I will report back if this doesn't fix my driver install warnings.

    Thursday, April 25, 2019 1:40 PM
  • I also have a DELL Precision (3620) and I have exactly the same problem, since about mid april too. I can not figure out what make this alert and how to fix it. If I close the alter windows, it come again few minutes later.

    Friday, May 3, 2019 4:45 PM
  • Hi Akdrwz,

    I think SW_DELL_USER is correct.  It seems that Dell SupportAssist is the issue since the last update.  I allowed the driver to install and everything is working fine.  If you don't use Dell SupportAssist then you can uninstall it.

    Cheers!

    Wednesday, May 8, 2019 3:04 AM
  • Hello everyone!

    I recently purchased windows defender antivirus after reading review from online website showbox.fun attaching the link at end of this post. I purchased the premium plan Windows defender. I tried to install windows defender on my Laptop today but saying KEY Invalid. Cant I use same licsense key on two devices?
    Tuesday, May 14, 2019 8:14 PM
  • Hi Stevenfun,

    You don't have to buy Windows Defender, as it's builtin in all Windows version (it only starts to be a real Antivirus starting in Windows 8 though). So whoever sold you that key most likely scammed you, and I highly suggest you to get a refund and report him for fraud/scam.

    Thank you,

    Yoan

    Wednesday, May 15, 2019 2:43 PM