locked
How to disable AD FS Device Registration on ADFS 4.0? RRS feed

  • Question

  • I am trying to use a custom port for HTTPS on ADFS 4.0 Server but getting error below when i try to change the port.

    There is no AD FS Device Registration service on the Server. Tried the Disable-AdfsDeviceRegistration, nothing happens.

    Tried disabling it from the AD FS Management console, but getting the same error when i try to change port.

    I have reinstalled twice that did not help, i have ran out of options and need help.

    Thanks 

    Hannel


    • Edited by Hannel Hazeley Wednesday, June 14, 2017 4:15 PM correction
    Sunday, June 11, 2017 7:34 AM

Answers

  • Oh!! Forgot to update thread. 

    Got a work around in another avenue but there is a downside. Changing HTTPS port means you cannot used Device Registration.

    • Disable AAD connect device write-back if enabled
    • Using ADSIEdit, can safely delete the entire  CN=Device Registration Configuration,CN=Services,CN=Configuration,DC=domain,DC=com (where domain.com is the forest name) tree of objects
    • Set ADFS HTTPS custom port 
    • You might need to fix the url paths using “netsh http add urlacl”
    • Restart ADFS Services




    Monday, July 10, 2017 4:37 PM

All replies

  • Same problem here, surprised no one has responded yet. The Disable cmdlet is deprecated, with no documentation on what the replacement is. Come on Microsoft, if you mark something obsolete, give us a workaround.

    It's all 1's and 0's in the end.

    Monday, July 10, 2017 6:08 AM
  • Oh!! Forgot to update thread. 

    Got a work around in another avenue but there is a downside. Changing HTTPS port means you cannot used Device Registration.

    • Disable AAD connect device write-back if enabled
    • Using ADSIEdit, can safely delete the entire  CN=Device Registration Configuration,CN=Services,CN=Configuration,DC=domain,DC=com (where domain.com is the forest name) tree of objects
    • Set ADFS HTTPS custom port 
    • You might need to fix the url paths using “netsh http add urlacl”
    • Restart ADFS Services




    Monday, July 10, 2017 4:37 PM