none
DNS server not resolving website's IP correct RRS feed

  • Question

  • I run a small company with a server and multiple client computers. When trying to reach my companies website I get an error message saying there was a DNS error. However, when I use a computer outside of the companies domain I am able to reach the website fine. I ran the nslookup command for google.com on my server and reached this result;

    C:\Users\Administrator.ELIT-SERVER>nslookup www.google.com Server: router.asus.com Address: 192.168.0.1

    Non-authoritative answer: Name: www.google.com.ELITLC.COM Address: 202.71.99.194

    I know this is incorrect because I only get this when I use a computer within the domain. Also, just in case, here's what nslookup returns for my website:

    C:\Users\Administrator.ELIT-SERVER>nslookup www.elitlc.com Server: router.asus.com Address: 192.168.0.1

    Non-authoritative answer: Name: www.elitlc.com.ELITLC.COM Address: 202.71.99.194

    Could this have anything to do with why I can't reach my companies website? Also, why do I get different answers on computers outside of the domain? Thanks in advance.

    Monday, June 5, 2017 4:18 AM

All replies

  • Hi Mubarak Abdirahman,

    Firstly, clear DNS cache on both DNS server and clients. 

    Please delete the cache of your DNS server using dnscmd /clearcache command.

    Please use the command of "ipconfig /flushdns" and "ipconfig /registerdns" to clear your DNS clients.

    Run the command of "nslookup/set d2" to view more details.

    Would you please post the result of running ipconfig/all at the command prompt on the computer to let us know the machine’s configuration?

    Best Regards,

    Candy




    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Tuesday, June 6, 2017 3:24 AM
  • Hi Candy, thank you for your help so far. After running the aforementioned commands, I have received this result: 

    C:\Users\Teacher1>ipconfig /all
    Windows IP Configuration
       Host Name . . . . . . . . . . . . : TEACHERS-PC-1
       Primary Dns Suffix  . . . . . . . : ELITLC.COM
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : ELITLC.COM
    Ethernet adapter Local Area Connection:
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Realtek RTL8168C(P)/8111C(P) Family PCI-E
     Gigabit Ethernet NIC (NDIS 6.20)
       Physical Address. . . . . . . . . : 00-1F-D0-CD-A2-A7
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 192.168.0.170(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 192.168.0.1
       DNS Servers . . . . . . . . . . . : 192.168.0.11
                                          192.168.0.1
       NetBIOS over Tcpip. . . . . . . . : Enabled
    Tunnel adapter Teredo Tunneling Pseudo-Interface:
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
    Tunnel adapter isatap.{8EEDDF39-27C0-4932-B861-4DEC5D7E509B}:
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No

       Autoconfiguration Enabled . . . . : Yes

    I still cannot access my website from my client computers, even after clearing the dns cache. Any suggestions?

    Friday, June 9, 2017 2:56 AM
  • Hi Mubarak Abdirahman,

    Would you please post the result of running "Nslookup/set d2" at the command prompt on the computer?

    Best Regards,

    Candy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, June 15, 2017 7:36 AM
  • Hi Mubarak Abdirahman

    Just want to confirm the current situations.

    Please feel free to let us know if you need further assistance.

    Best Regards,

    Candy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, June 22, 2017 8:47 AM