locked
Downloading updates from WSUS server takes ages RRS feed

  • Question

  • Hi, 

    I've approved v1903 update to be installed on rest of our workstations, since pilot went well.
    However,  computers are struggling to download updates from WSUS server. 

    It takes hours to download even the smaller updates. WSUS server is showing network traffic of 50kbps, which mostly is due my RDP connection to it. The speed randomly spikes to 50-100Mbps, but falls back to near zero in couple of seconds.

    Currently there are 8 clients trying to download updates  (I'm told that single wsus server should be able to server this many clients). 

    The server is virtual 2012r2 with latest patches installed. 2vCPU, 8Gb Ram, OS and Database disks are on SSD-disks. 
    CPU Usage is less than 5% and memory usage 25%. The server has 10Gb nic connected to our lan. Clients has 1Gb network connection. 

    I have rebooted the server couple of time, with no luck. 

    After reboot, I'll get following errors in application log:

    The Reporting Web Service is not working.

    The API Remoting Web Service is not working.

    The Server Synchronization Web Service is not working.

    The Client Web Service is not working.

    The SimpleAuth Web Service is not working.

    The DSS Authentication Web Service is not working.

    The WSUS content directory is not accessible.
    System.Net.WebException: The remote server returned an error: (503) Server Unavailable.
       at System.Net.HttpWebRequest.GetResponse()
       at Microsoft.UpdateServices.Internal.HealthMonitoring.HmtWebServices.CheckContentDirWebAccess(EventLoggingType type, HealthEventLogger logger)

    Exactly after 50minutes of previous error messages I get status messages on the eventlog:

    Self-update is working.

    The Reporting Web Service is working correctly.

    The Server Synchronization Web Service is working correctly.

    The Client Web Service is working correctly.

    The SimpleAuth Web Service is working correctly.

    The DSS Authentication Web Service is working correctly.

    The WSUS content directory is accessible.

    And exactly 10minutes after those informational messages, I get the same error messages again.

    Any idea how to start troubleshooting this?

    Apart from ms-updates, there has not been changes lately on the server. Problem may or may not relate wider approvement of win10 v1903 update.

    Monday, November 25, 2019 10:23 AM

All replies

  • Clients are receiving download error:

    Status: Download error - 0x80d02002

    When I try to connect to http://my-wsus-server.mydomain.local:8530/ I get an error 

    Service Unavailable


    HTTP Error 503. The service is unavailable.


    • Edited by Kari Hyvönen Monday, November 25, 2019 11:09 AM more detailed info
    Monday, November 25, 2019 10:32 AM
  • This seemed to be an issue with IIS's connection limit.
    It's still not fast, but now clients can atleast succesfully download the update.

    Monday, November 25, 2019 2:00 PM
  • Hi,
      

    Based on the situation you mentioned, it is recommended to try the following steps to fix it:
      

    1. Check the status of the application pool running the WSUS service.
      (1)  On your WSUS Server, launch the IIS Manager.
      (2)  Click 'Application Pools' is in the Connections list.
      (3)  Right-click 'WsusPool' and select ' Start ' to restart the WSUSPool.
       
    2. Lower memory limits can also cause a situation.
      (1)  On your WSUS Server, launch the IIS Manager.
      (2)  Click 'Application Pools' is in the Connections list.
      (3)  Right-click 'WsusPool' and select 'Advanced Settings…'
      (4)  Increase the WsusPool 'Private Memory limit' x4 times, or set to 0 (unlimited).
      (5)  Change 'Queue Length' from the default 1,000 to 25,000.
      (6)  Save the configuration.
         

    If the above is not suitable for your situation, please let me know.
     

    Regards,
    Yic

    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, November 26, 2019 2:32 AM
  • Hi,
     

    Any update is welcome here.
    If the issue is resolved, share your solution or find the helpful response "Mark as Answer" to help other community members find the answer.
     

    Thank you for your cooperation, as always.
     

    Regards,
    Yic

    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, November 29, 2019 2:06 AM