locked
Application status in Software Center "installing" for hours RRS feed

  • Question

  • Hello,

    I have sequenced SPSS, application installs on the client and works but... in the Software Center remains status "installing" for hours.

    Once the status changes to installed, no errors in aapenforce.log.

     CAppV5XHandler::InstallApp() completed successfully.

    I have tried many times, App-v 5 and App-v 5 SP2. The same problem so it is application doing somenthing apparently.

    How to troubleshoot this?

    Where to look ?

    Thanks in advance,

    Hanna

    Thursday, March 27, 2014 4:11 PM

All replies

  • What does the application log say? If you don't have one, create one (msiexec ../L*v log file.log).
    Thursday, March 27, 2014 8:59 PM
  • When I run msiexec on the sequencer I do generate the log file but on the installation on the sequencer runs perfect. Also the log file contains no errors.

    The problem is, when I install appv from the Software Center, which in fact is a PS command  "Mount-AppvClientPackage", I do not issue any msiexec command at this time and I cannot generate the msi log file.

    So, I wonder in which logfile can I see what is going on in the meantime...

    In this example it took one hour...while application itself was installed within a minute and you could just open it and use it. See the logfile..

    <![LOG[    Executing Command line: "C:\\Windows\\System32\\WindowsPowerShell\\v1.0\\powershell.exe" -ExecutionPolicy Bypass import-module 'C:\Program Files\Microsoft Application Virtualization\Client\AppvClient\AppvClient.psd1';  Mount-AppvClientPackage -PackageID bc99e8bc-1e5a-4284-831d-a91ae1cfff79 -VersionID 2fcb6862-bebc-4539-8565-fe0b8dc61748 with system context]LOG]!><time="14:42:00.956-60" date="03-27-2014" component="AppEnforce" context="" type="1" thread="4804" file="appexcnlib.cpp:345">
    <![LOG[    Process 3032 terminated with exitcode: 0]LOG]!><time="15:40:10.634-60" date="03-27-2014" component="AppEnforce" context="" type="1" thread="4804" file="appexcnlib.cpp:431">


    • Edited by Hana_hanna Friday, March 28, 2014 8:07 AM
    Friday, March 28, 2014 8:06 AM
  • You could try to execute the Mount-AppvClientPackage command yourself, does this takes as long as with SCCM?

    Mount from a network share, put your .appv file preferably on a network share to test the network speed.

    If that goes fast, put your .appv file on the same share where the SCCM DP is hosted.


    Friday, March 28, 2014 10:08 AM
  • The application was configured to download and execute locally.

    I have mounted it from the PS command and it takes as long as from the Software Center.

    I have tried -verbose and -debug options but it will not display more information.

    Appv file is 1 GB, is it normal that it takes so long? On the ather hand, I can just use the application after a couple of minutes while deployd from Software Center despite it is still "installing"...

    Any ideas ?

    Greetings,

    Hanna

    Monday, March 31, 2014 11:55 AM
  • Hello,

    It depends on the package. Since this roughly the same time regardless if you add it manually, or through ConfigMgr - the time relates to App-V.

    Have you applied the latest hotfix for App-V 5?

    http://support.microsoft.com/kb/2934349


    Nicke Källén | The Knack| Twitter: @Znackattack

    Wednesday, April 2, 2014 7:02 PM
  • Hello,

    I have just tried App-v 5 no service pack. The same.

    Well on a physical machine (mounted via PS)  it takes about 25  minutes but still is it normal for 1 GB package ?

    Hanna

    Thursday, April 3, 2014 2:54 PM
  • Hello,

    That depends on the package (and amount of files, and a few other stuff).

    I would say that App-V 5.0 SP2 with the above hotfix should be faster than RTM, but I have no metrics to support that and Microsoft hasn't made any targeted fixes for it.


    Nicke Källén | The Knack| Twitter: @Znackattack

    Thursday, April 3, 2014 3:58 PM
  • Hello,

    Also, try the even later hotfix;

    http://blogs.msdn.com/b/sgern/archive/2014/04/03/10513798.aspx


    Nicke Källén | The Knack| Twitter: @Znackattack

    Thursday, April 3, 2014 7:25 PM
  • Hi Nicke,

    I have tried to run SPSS from Shared Content Store. Works perfectly ! but.... not form the Software Center....keeps installing.....

    Any idea if this should work ?

    Thanks a lot,

    Hanna

    Friday, April 4, 2014 11:48 AM
  • Hello,

    If you are using Shared Content Store is there any reason to perform a Download and Execute operation instead of just telling it to stream from DP?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Saturday, April 5, 2014 8:57 AM
  • When I try to stream it works in 50% cases. The same application will stream 5 times and then 5 times it will report an error.

    See this:

    http://social.technet.microsoft.com/Forums/sqlserver/en-US/279059ff-f7b5-42e6-b555-bb04a15c8ace/appv-apps-intermittantly-fail-to-install-via-sccm?forum=configmanagerapps

    So this is another problem. I see that shared content works the best. I can make a ps script to run the application from SCS and put it in Software Center. It is a pitty that I cannot deploy it like app-v application.

    Monday, April 7, 2014 8:50 AM