locked
Enable-PSRemoting Not Working - Access Denied RRS feed

  • Question

  • I'm attempting to enable PS Remoting via Group policy settings https://www.techrepublic.com/article/how-to-enable-powershell-remoting-via-group-policy/ I have the steps in the document accounted for yet I'm still getting Access Denied when trying to enter-pssession. 

    PS C:\WINDOWS\system32> Enter-PSSession -ComputerName "COMPUTERNAME"
    Enter-PSSession : Connecting to remote server COMPUTERNAME failed with the following error message : Access is 
    denied. For more information, see the about_Remote_Troubleshooting Help topic.
    At line:1 char:1
    + Enter-PSSession -ComputerName "COMPUTERNAME"
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidArgument: (COMPUTERNAME:String) [Enter-PSSession], PSRemotingTransportExcepti 
       on
        + FullyQualifiedErrorId : CreateRemoteRunspaceFailed

    When I go to enable-psremoting on the machine it looks as if something wasn't accounted for in the GPO 

    Do you want to continue?
    [Y] Yes  [A] Yes to All  [N] No  [L] No to All  [S] Suspend  [?] Help (default is "Y"): a
    WinRM is already set up to receive requests on this computer.
    WinRM is already set up for remote management on this computer.

    Confirm
    Are you sure you want to perform this action?
    Performing the operation "Set-PSSessionConfiguration" on target "Name: microsoft.powershell SDDL:
    O:NSG:BAD:P(A;;GA;;;BA)(A;;GA;;;RM)S:P(AU;FA;GA;;;WD)(AU;SA;GXGW;;;WD). This lets selected users remotely run Windows
    PowerShell commands on this computer.".
    [Y] Yes  [A] Yes to All  [N] No  [L] No to All  [S] Suspend  [?] Help (default is "Y"): a

    Not sure what I'm missing here - I'd appreciate an assist! 

    Monday, August 6, 2018 4:17 PM

All replies

  • You have net set GP correctly.  By default only admins can use remoting. 

    The error says the remote computer does not allow your account to connect remotely.   It does not say that remoting is not enabled.


    \_(ツ)_/

    Monday, August 6, 2018 4:21 PM
  • Hi,

    Thanks for your question.

    There are two things you need to do when using powershell for remoteness: 1. Run powershell as an administrator. 2. Enable remoting mode on a remote computer.

    I agree with Mr. Jrv that you have configured gpo to enable remoting mode, and the error report indicates that you are denied access to your account. Please try to use the administrator account again for remote.

    You can also refer to the following Microsoft link:

    https://docs.microsoft.com/en-us/powershell/module/microsoft.powershell.core/about/about_remote_troubleshooting?view=powershell-6

    Best Regards,

    Lee


    Just do it.

    Tuesday, August 7, 2018 1:52 AM