locked
Edge Transport to Hub Transport

    Question

  • Hey guys - I am having problems with email flowing from the Edge Transport server to the Hub Transport server. I am able to telnet to port 25 on all servers (both directions). The queue on the Edge servers says "500 5.5.1 Unreconized command". I can't for the life of me figure out why. The EdgeSync is working well.....

     

    Thanks for the help!

     

    Jeremy

    Friday, April 27, 2007 5:13 PM

Answers

  • Hi Jeremy,

     

    Take a look if there is any error in the application log. Also, make sure that there is minimum of 4GB free space available in the drive where the queues are. There is one issue related with it stopping mail flow between the hub and edge server. The Queue DB and logs are stored must have 4GB or more free space otherwise the server will apply back pressure and start slowing or stop the flow of messages!

     

    VRodrigues

    Monday, April 30, 2007 5:08 AM
  • There is nothing listed in the Application log on either server. Both servers have 70+ GB of HD space free. Anyother ideas?

     

    Thanks!

    Tuesday, May 1, 2007 8:59 PM
  •  

     

    I'm having the same problem. Did you discover the cause and if so what is the fix? Thanks, Ken

    Tuesday, May 15, 2007 2:51 PM
  • Yes - You need to add the X-AnonymousTLS and X-EXPs verbs to the ISA SMTP filter. Keep in mind that this should only be enabled for Edge to Hub transport communication only as we don't want to advertise these to the outside world or on the internet. They are only used for communication between internal Exchange servers.

     

    1. Open the Microsoft ISA 2006 Enterprise MMC.

    2. Expand Arrays and browse to respective Array -> Configuration -> Add-ins.

    3. Right click on SMTP Filter under Application Filters and click Properties.

    4. Click on SMTP Commands and then Add button.

    5. Enter the Command Name with it's Maximum Length in Bytes.

    6. Make sure that the "Enable SMTP Command" is checked.

    7. Click OK twice to exit.

    8. Apply the changes by clicking the Apply button on the top pane

     

    Hope this helps,

     

    Jeremy

    Tuesday, May 15, 2007 3:14 PM
  • What sizes to use for the length??

     

    Cheers

    Wednesday, May 16, 2007 8:37 PM
  • I started with 256 (figured that would cover it). I have not had time to check out the SMTP RFC to see what the usage guidelines are assuming this is in the RFC and not a Microsoft one off. I would guess its max would be 10-15 like STARTTLS. Ken
    Friday, May 18, 2007 12:16 AM

All replies

  • Hi Jeremy,

     

    Take a look if there is any error in the application log. Also, make sure that there is minimum of 4GB free space available in the drive where the queues are. There is one issue related with it stopping mail flow between the hub and edge server. The Queue DB and logs are stored must have 4GB or more free space otherwise the server will apply back pressure and start slowing or stop the flow of messages!

     

    VRodrigues

    Monday, April 30, 2007 5:08 AM
  • There is nothing listed in the Application log on either server. Both servers have 70+ GB of HD space free. Anyother ideas?

     

    Thanks!

    Tuesday, May 1, 2007 8:59 PM
  •  

     

    I'm having the same problem. Did you discover the cause and if so what is the fix? Thanks, Ken

    Tuesday, May 15, 2007 2:51 PM
  • Yes - You need to add the X-AnonymousTLS and X-EXPs verbs to the ISA SMTP filter. Keep in mind that this should only be enabled for Edge to Hub transport communication only as we don't want to advertise these to the outside world or on the internet. They are only used for communication between internal Exchange servers.

     

    1. Open the Microsoft ISA 2006 Enterprise MMC.

    2. Expand Arrays and browse to respective Array -> Configuration -> Add-ins.

    3. Right click on SMTP Filter under Application Filters and click Properties.

    4. Click on SMTP Commands and then Add button.

    5. Enter the Command Name with it's Maximum Length in Bytes.

    6. Make sure that the "Enable SMTP Command" is checked.

    7. Click OK twice to exit.

    8. Apply the changes by clicking the Apply button on the top pane

     

    Hope this helps,

     

    Jeremy

    Tuesday, May 15, 2007 3:14 PM
  • Thank you Jeremy! that did the tick... now to fix my TSL cert error.
    Tuesday, May 15, 2007 7:19 PM
  • What sizes to use for the length??

     

    Cheers

    Wednesday, May 16, 2007 8:37 PM
  • I started with 256 (figured that would cover it). I have not had time to check out the SMTP RFC to see what the usage guidelines are assuming this is in the RFC and not a Microsoft one off. I would guess its max would be 10-15 like STARTTLS. Ken
    Friday, May 18, 2007 12:16 AM