locked
SQL 2016 MP service pack compliance RRS feed

  • Question

  • Since upgrading SCOM to 2016 and importing the latest SQL 2016 MP (6.7.20.0) different SQL instances are reporting that their SQL Service Pack version is not OK. However, the SQL instances do have SP1 installed according to the version table (found here: https://support.microsoft.com/en-us/help/321185/how-to-determine-the-version,-edition-and-update-level-of-sql-server-and-its-components) since their version is 13.0.4411.0.

    Perhaps it's possible that the monitor also reports on CU's that are still available, but there's nothing in the description of the monitor that supports this. There's no override active; the effective value of the 'Minimal Service Pack level for SQL Server 2016' is 1.

    Maybe I'm missing something here? Any help would be appreciated.


    Friday, April 21, 2017 1:03 PM

Answers

  • Hello. This is not a problem with SQL 2016 MP. This is a problem with SQL 2016 update packages. They do not fix SQL Server 2016 SP level in registry (HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL13/MSRS13.InstanceName\Setup\SP). Fix this registry key manually and this monitor will not be alerted. Warning: you must retry this fix after every update installation before Microsoft does not fix it.

    • Proposed as answer by Yan Li_ Wednesday, April 26, 2017 5:43 AM
    • Marked as answer by E van Hulsel Friday, April 28, 2017 8:07 AM
    Tuesday, April 25, 2017 9:17 AM

All replies

  • Hi,

    The value here should be 1, refer to the link below

    http://mpwiki.viacode.com/default.aspx?g=posts&t=206316

    I hope this helps.


    If a post answers your question, please click "Mark As Answer" on that post and "Vote as Helpful You can also follow me on twitter @tadgata

    Saturday, April 22, 2017 8:17 AM
  • Hi Tadgata,

    I agree that it should be 1, and it is, but it seems somehow the monitor doesn't recognize the correct value. As I already stated the version of the SQL installation is 13.0.4411.0, which is SQL 2016 SP1 CU1. And as I read the monitor it says the SQL installation doesn't have SP1 installed.

    So thanks for your reply, but that link is not realy what I'm looking for.

    Monday, April 24, 2017 7:14 AM
  • Hello. This is not a problem with SQL 2016 MP. This is a problem with SQL 2016 update packages. They do not fix SQL Server 2016 SP level in registry (HKLM\Software\Microsoft\Microsoft SQL Server\MSSQL13/MSRS13.InstanceName\Setup\SP). Fix this registry key manually and this monitor will not be alerted. Warning: you must retry this fix after every update installation before Microsoft does not fix it.

    • Proposed as answer by Yan Li_ Wednesday, April 26, 2017 5:43 AM
    • Marked as answer by E van Hulsel Friday, April 28, 2017 8:07 AM
    Tuesday, April 25, 2017 9:17 AM
  • Hello,

    A warning or error alert will be raised if it does not match the required setting. Out of the box, the monitor is configured to alert when the service pack level is not 0. This can be changed using overrides as required.

    To workaround this issue, please try following ways:

    • Override the monitor to change the required value for this specific instance of SQL or all instances

    • Disable the monitor for this specific instance of SQL or all instances

    Regards,

    Yan Li


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Tadgata Wednesday, April 26, 2017 8:02 PM
    Wednesday, April 26, 2017 5:53 AM
  • Thank you for this, that registry setting was exactly what I was looking for. It is our policy not to disable monitors as first response to errors like these.

    For now we've adjusted the value of the registry setting from 0 to 1. Let's hope MS will adjust this in the next SP.

    Edit: I've found an article that states that this issue will be resolved in SQL 2016 SP2: https://blogs.msdn.microsoft.com/sqlreleaseservices/released-system-center-management-pack-for-sql-server-and-dashboards-6-7-20-0/
    Friday, April 28, 2017 8:07 AM
  • You can add an auto recovery script to the monitor.

    This should work:

    param([string]$Instance)
    $Version = (Get-ItemProperty "HKLM:\SOFTWARE\Microsoft\Microsoft SQL Server\$((Get-ItemProperty 'HKLM:\SOFTWARE\Microsoft\Microsoft SQL Server\Instance Names\SQL').$Instance)\Setup").Version
    if ($Version -match '13.1.4') {Set-ItemProperty -Path "HKLM:\SOFTWARE\Microsoft\Microsoft SQL Server\$((Get-ItemProperty 'HKLM:\SOFTWARE\Microsoft\Microsoft SQL Server\Instance Names\SQL').$Instance)\Setup" -Name 'SP' -Value 1}

    Tuesday, October 17, 2017 11:19 AM