locked
Problems sequencing an MMC snap in - Hummingbird Exceed 2006 RRS feed

  • Question

  • Apologies in advance for the long post...

    I've sequenced Hummingbird Exceed 2006 and am having problems with a couple of the shortcuts to MSC snap-ins.

    Sequence process:
    Win 7 x64 virtual machine
    App-V 4.6
    Installed MSI to Q:\<Asset dir> and set property DISABLEADVTSHORTCUTS=1 to enable working shortcuts post-sequence.
    During monitoring I launched all the shortcuts. Most work with the exception of two which are both MSC snap-ins for the MMC. When I try to lauch these I get:
    "Microsoft Managment Console: Unable to create new document"

    If I then stop monitoring, and run the two shortcuts for the MSC snap-ins the MMC window loads, but the following is displayed:
    "MMC could not create the snap-in"

    If I save the sequence and add the virtual app to an App-V client I get the error:
    "Microsoft Managment Console: Unable to create new document"

    Things I have tried:
    As per advice here: http://support.microsoft.com/kb/932137
    Update the OSD files to have the FILENAME="%CSIDL_SYSTEM%\MMC.EXE" and the PARAMETER="%SFT_MNT%\AssetDir\File.msc"

    This resulted in the error:
    "Microsoft Managment Console: MMC cannot open the file Q:\Asset.dir\Exceed\Xconfig.
    This may because the file does not exist, is not an MMC console, or was created by a later version of MMC. This may also be because you do not have sufficient access rights to the file"

    Note that the MSC file extension isn't shown in the path in the error above. i don't know if this is relevant.

    I've tried adding the LOCAL_INTERACTION_ALLOWED = TRUE tag to the OSD, but got the same error.

    I've tried installing the product on my Win 7 x64 VM (without the sequencer running) and the MSC snap-ins open without problems. This shows that when the sequencer is in monitoring mode it somehow breaks the registration of the MSC files. I found a couple of registry keys which appear to relate to one of the snap-ins. As a test I tried exporting them from the working install and importing them into the App-V client's normal registry. I get the previous error when I try to open that snap-in.

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\MMC\SnapIns\{96A53A4A-B6DF-4263-B88D-C3141FF4B3A3}

    HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{96A53A4A-B6DF-4263-B88D-C3141FF4B3A3}

    Does anyone have any idea how to get these working?

    Wednesday, August 18, 2010 2:15 PM

Answers

All replies

  • I've repeated this entire process using a Win 7 32 bit sequencer and and Win 7 32 bit App-V client and it works fine. The problem is we only have 64 bit clients...
    Wednesday, August 18, 2010 3:16 PM
  • Have you tried pointing the OSD to the 32-bit version of MMC.exe in %SystemRoot%\SYSWOW64\MMC.EXE?
    Wednesday, August 18, 2010 3:38 PM
    Moderator
  • Thanks for the suggestion - I just happened to try that a few minutes ago and saw the same error.
    Wednesday, August 18, 2010 3:40 PM
  • Does the issue occur when running the 32-bit captured sequence on a 64-bit client or are you keeping platforms the same (i.e. capture on 64-bit, run on 64-bit; capture on 32-bit, run on 32-bit)?

    Run Process Monitor in the virtual environment and see where the file not found issue is coming up: http://blogs.technet.com/b/appv/archive/2007/08/13/troubleshooting-softgrid-with-process-monitor.aspx
    Wednesday, August 18, 2010 3:48 PM
    Moderator
  • I've tried both the 32 bit and 64 bit captures on a 64 bit client and neither work.

    I've been trawling through some process mon traces in the background and have just spotted this:

    Command line:
    "C:\Windows\SysWOW64\MMC.EXE" Q:\<Assetdir>\Exceed\Xconfig Console.msc

    So I think the issue is that there's a space in the filename and no double quotes. I'm not too sure how to add quotes to the parameter in the OSD so I'm going to try removing the space as a test...

    • Edited by BenCook Thursday, August 19, 2010 8:18 AM
    Wednesday, August 18, 2010 4:07 PM
  • I just tried adding quotes in the form &quot; to get around the space in the filename. Now I'm back to the error:

    "Microsoft Managment Console: Unable to create new document"

    Is this progress?!

    Wednesday, August 18, 2010 4:11 PM
  •  

    More testing results...

    I've opened a command prompt in the bubble and have been playing with mmc.exe switches:

    http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/ntcmds.mspx?mfr=true

    If I run:
    "C:\Windows\SysWOW64\MMC.EXE" "Q:\<Assetdir>\Exceed\Xconfig Console.msc" /32
    I get the error:
    "Microsoft Managment Console: Unable to create new document"

    If I run:
    "C:\Windows\SysWOW64\MMC.EXE" "Q:\<Assetdir>\Exceed\Xconfig Console.msc" /64
    The MMC opens with the error:
    "MMC could not create the snap-in"

    At least this explains the different errors I've been seeing.

     

     


     

    • Edited by BenCook Thursday, August 19, 2010 8:17 AM
    Wednesday, August 18, 2010 4:32 PM
  • Can you rename or copy the .MSC file and remove the space? Does C:\Windows\System32\mmc.exe /32 behave differently? (I presume this just passes control to MMC.exe in \Windows\syswow62)
    Wednesday, August 18, 2010 6:19 PM
    Moderator
  • I tried copying Xconfig Console.msc to C:\temp and renamed it to test.msc. I then ran the following from a command window within the bubble. I get exactly the same results:

    mmc.exe c:\temp\test.msc /32
    Error: "Microsoft Managment Console: Unable to create new document"

    mmc.exe c:\temp\test.msc /64
    The MMC opens with the error: "MMC could not create the snap-in"

    Thursday, August 19, 2010 8:30 AM
  • I've just tried something else - I captured the install on a clean Win7 x64 machine using InstallRite. I then exported the entire captured registry to reg files, then added these onto my x64 App-V client where the MSC fails to launch. I did this because I wondered whether the sequencer was somehow missing some registration of the MSC.

    This resulted in slightly different behaviour: The MMC windows opens with the error "MMC could not create the snap-in" and underneath it it says "MMC could not create the snap-in. The snap-in might not have been installed correctly. Name: Xconfig Console. CLSID: {96A53A4A-B6DF-4263-B88D-C3141FF4B3A3}"

    Thursday, August 19, 2010 8:51 AM
  • Well I've run out of ideas on this so I think I'm going to have to resort to using MSI. It's a shame because all the other shortcuts (except a couple we don't need) work OK.
    Thursday, August 19, 2010 12:33 PM
  • Hello,

    See this article;

    http://msdn.microsoft.com/en-us/library/windows/desktop/aa815172(v=vs.85).aspx

    Try deleting the InProc32server / InProcHandler32 that are available in the virtual registry during monitoring- this will perhaps resolve the issue


    /Znack
    • Edited by znack Tuesday, November 22, 2011 8:59 AM
    • Proposed as answer by znack Tuesday, November 22, 2011 8:59 AM
    • Marked as answer by Aaron.ParkerModerator Friday, January 13, 2012 3:44 PM
    Tuesday, November 22, 2011 8:58 AM
  • Hi Znack,

    Thanks for coming back to me on this. Unfortunately this project has now completed and I've moved onto a new job, so I can't test this.

    Ben.

    Tuesday, November 22, 2011 9:07 AM