none
Trying to connect to Web Outlook App by external url and gets the router login

    Question

  • Hi,

    I have set all my internal URL's and external URL's to mail.company.se(/Ecp/Owa and so on).
    But when I try to connect to mail.company.se I end up in the login page to my router.
    I have opened ports 25 and 443 and put my Exchange server IP as the host of both.

    Anybody know a solution to this? 

    Thanks
    Wednesday, September 23, 2015 7:40 AM

All replies

  • Please try to disable remote login on your router.Default it is also on port 443 for secure login,these might come in conflict

    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Wednesday, September 23, 2015 7:43 AM
  • Thanks for quick answer.
    I disabled the 443 port forwarding I made earlier.
    I also disabled remote management but still I get reconnected to my router login page when I type in mail.company.se.
    Here is a picture from my router preferences:

    Wednesday, September 23, 2015 9:08 AM
  • Here is another printscreen from the router configuration.
    Incoming traffic (outgoing traffic is allow all)

    Wednesday, September 23, 2015 9:49 AM
  • Hi,

    in management type on your router, there is a drop down menu. What else can you choose there?

    when enter mail.domain.com/owa do you enter https infront?

    Seems like port 80 also on the list, so that might hit config of your router as well.

    Might be you need to reboot router.


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work


    • Edited by Off2work Wednesday, September 23, 2015 11:04 AM Edit
    Wednesday, September 23, 2015 11:04 AM
  • I can either choose "WatchGuard System Manager" or "VPN Manager"
    I do enter https:// infront but I also made a redirect so I don't need to typ https://.
    We have a temporary router which is really old/bad because our old one crashed so we reboot it all the time because of overload, tomorrow we will hopefully get the new one.

    Should I not allow 80 incoming and have server as host?
    Wednesday, September 23, 2015 11:42 AM
  • http://www.mustbegeek.com/configure-external-and-internal-url-in-exchange-2013/

    http://www.mustbegeek.com/configure-url-redirection-in-exchange-2013/

    I followed these two guides to setup my Internal & External URL's and also the redirection.
    Wednesday, September 23, 2015 11:49 AM
  • redirection from http to https is just nice to have, but if your router is set to listen to port 80 (for management), then you will have the issue you are having.

    I'm not familiar with that model, so not sure where to look to disable all management web interface.

    Or you should disable url redirection from this guide: http://www.mustbegeek.com/configure-url-redirection-in-exchange-2013/

    Did you try to reboot the router first after disabling https management on the router?


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Wednesday, September 23, 2015 12:58 PM
  • I did reboot the router and nothing changed.

    Should I disable the URL redirection? Could that be the problem?
    I'm trying to disable the remote management but I really can't find the option.
    Could it be any other problem aswell?

    Iam currently experiencing outlook connectivity problems, when I try to connect I get the error code 18 with the message "A problem with the proxy servers SSL Certificate. Not able to connect to the proxyserver mail.domain.se"
    Thursday, September 24, 2015 6:20 AM
  • Hi,

    For your question, please run below command to check the setting for Outlook Anywhere and Outlook provider:
    Get-OutlookAnywhere | FL Identity,*host*,*auth*,*SSL*
    Get-OutlookProvider | FL

    The value of CertPrincName in EXPR specifies the SSL certificate principal name required when connecting externally from the Exchange topology and using SSL.

    If this issue persists, please use ExRCA to test the connectivity between Outlook with Exchange server, for your reference: https://testconnectivity.microsoft.com/


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Allen Wang
    TechNet Community Support

    Thursday, September 24, 2015 9:36 AM
    Moderator
  • My CerPrincName is blank in EXPR and all other aswell.
    Thursday, September 24, 2015 10:48 AM