none
Cannot Grant Sync access to groups - Work Folders

    Question

  • On server 2016 essentials, after installing the Work Folders feature and attempting to create a sync share. During the sync share setup <g class="gr_ gr_138 gr-alert gr_gramm gr_inline_cards gr_run_anim Punctuation only-ins replaceWithoutSep" data-gr-id="138" id="138">wizard</g> I get to the "Sync Access" tab where it states "Grant Sync Access to Groups".  The Add button on that page of the wizard does absolutely nothing.  You click Add and nothing happens.  Already tried restarting and also added the file server resource manager role as well, still nothing.  Tried other ideas from this forum https://community.spiceworks.com/topic/2013227-solved-windows-server-2016-work-folders-sync-access-issue?page=1#entry-7300543

    Any ideas?

    Monday, October 16, 2017 11:32 PM

All replies

  • Hi ExpressTech Inc,

    Before creating sync shares,  Domain Admins user needs to create some security groups in Active Directory Domain Services (AD DS) for Work Folders 

    Do you follow the article to create the security groups and sync shares?

    https://docs.microsoft.com/en-us/windows-server/storage/work-folders/deploy-work-folders

    Best Regards,

    Mary


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, October 17, 2017 6:12 AM
    Moderator
  • I’m a PM for Work Folders. I’ll try to reproduce the issue.

    As a workaround, you can create the Sync Share via PowerShell:

    New-SyncShare-Name"Share01"-Path"K:\Share01"-User"ContosoEngGroup"

    For more details on the New-SyncShare cmdlet, please see the Work Folders cmdlet documentation: https://docs.microsoft.com/en-us/powershell/module/syncshare/new-syncshare?view=win10-ps

    Tuesday, October 17, 2017 5:27 PM
  • I am having the same problem on a Windows 2016 Domain Controller.  Were you able to reproduce the issue?

    Even the PowerShell isn't successful with this error: 

    New-SyncShare : (0x80070015) The device is not ready.
    At line:1 char:1
    + New-SyncShare -Name "workfolders" -Path "D:\Workfolders" -User "Work  ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (Msft_SyncShare:Root/Microsoft/.../Msft_SyncShare) [New-SyncShare], CimExc
       eption
        + FullyQualifiedErrorId : HRESULT 0x80070015,New-SyncShare

    OR

    PS C:\Users\Administrator.SERVER> New-SyncShare

    cmdlet New-SyncShare at command pipeline position 1
    Supply values for the following parameters:
    Name: Workfolders
    Path: D:\Workfolders
    User[0]: Work Folders Sync Share
    User[1]:
    New-SyncShare : (0x80070015) The device is not ready.
    At line:1 char:1
    + New-SyncShare
    + ~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (Msft_SyncShare:Root/Microsoft/.../Msft_SyncShare) [New-SyncShare], CimExc
       eption
        + FullyQualifiedErrorId : HRESULT 0x80070015,New-SyncShare

    I've rebooted the server after installing the Workfolders service and tried using an existing shared folder.

    Still stuck in the water here with workfolders ...


    • Edited by landoa12 Friday, October 27, 2017 10:00 AM
    Friday, October 27, 2017 9:58 AM
  • Check to see if the Work Folders service (SyncShareSvc) is running.

    If the service is not running and fails to start, I suspect another web site is using port 443. Use the steps documented in the following blog to change the port used by Work Folders: https://blogs.technet.microsoft.com/filecab/2013/10/15/windows-server-2012-r2-resolving-port-conflict-with-iis-websites-and-work-folders/

    If you continue to experience issues, please send me mail at jeffpatt at microsoft dot com.

    Friday, October 27, 2017 4:22 PM
  • I have the same, issue on Windows server 2016.

    • I have updated the following KBS post that and restarted by server

    KB890830 - Windows Malicious Software Removal Tool for Windows 8, 8.1, 10 and Windows Server 2012, 2012 R2, 2016 x64 Edition - October 2017 (KB890830)

    KB4041691 - 2017-10 Cumulative Update for Windows Server 2016 for x64-based Systems (KB4041691)

    • I have also tried installing the ADDS RSAT snap in, but that did not help either.
    • I have started the Server manager with admin rights as well.
    • Finally I had imported the sync share PowerShell Module and that did the trick. But the issue still exists.

    New-SyncShare -Name "WorkFolderSync" -Description "Syncs Work Folders of Users under Enterprise Group - WorkFolderGroup" -Path "C:\WorkFolder" -User "WorkFoldergroup" -RequireEncryption:$true -InheritParentFolderPermission:$true -RequirePasswordAutoLock:$true -PasswordAutolockExcludeDomain:$false -WhatIf

    • Another strange thing the "Whatif" switch doesn't seem to work with the "New-SyncShare" commandlet. It actually created the share in my environment.

    Monday, October 30, 2017 6:48 AM
  • Hi Rajarshi,

    How did you import the sync share PowerShell Module?  You said that did the trick, meaning you were able to create the sync share, except the "Whatif" didn't work?  

    I didn't have to import a sync share module to execute the New-SyncShare command, so the module is already present.

    I have not yet installed the updates that you mentioned.  Do you think they made a difference?


    Monday, October 30, 2017 9:46 AM
  • We’ve investigated this issue and the cause is due to a change in .NET Framework 4.7. This issue also impacts the DFS management console: https://support.microsoft.com/en-us/help/4049095/value-does-not-fall-within-the-expected-range-error-when-you-change

    The official fix for this issue is scheduled to release next year.

    To workaround this issue, perform one of the following options:

    ·         Option #1 - Use PowerShell to create a new sync share

    New-SyncShare -Name "Share01" -Path "K:\Share01" -User "ContosoEngGroup"

    ·         Option #2 - Uninstall .NET Framework 4.7

     

    ·         Option #3 - Open a support case and request a private fix for .NET Framework 4.7. You will not be charged for the support case since the issue is a bug.

    Tuesday, November 14, 2017 5:29 PM
  • Thanks for your feedback, Jeff.

    Option #1 finally worked for me.  I believe it was after restarting the server, though a restart was not required after installing the Work Folders feature.

    Wednesday, November 15, 2017 8:03 AM
  • One third of "next year" is already through, but the issue still exists. Any timeline on the update?
    Monday, May 7, 2018 11:26 AM
  • This issue was fixed in the February update rollup: https://support.microsoft.com/en-us/help/4077525

    Let me know if you're still encountering the issue after installing the Feb. (or later) update rollup.

    Thursday, May 17, 2018 4:48 PM