locked
When I close a program by clicking the X it remains in the taskbar instead of going back to the notifcation area as it did in XP. What can I do? RRS feed

  • Question

  • When I close a program by clicking the X it remains in the taskbar instead of going back to the notifcation area as it did in XP. In XP when I clicked the X on AIM for example it went to an icon over in the notifcation area. Now in 7, it stays as a full taskbar item taking up space. What can I do?
    James A+, Network+, MCP
    Sunday, January 24, 2010 5:47 PM

Answers

  • download AIM 7.2, it has an option to hide the buddy list (options > buddy list) when minimized
    • Marked as answer by jshoemaker21 Saturday, March 13, 2010 3:53 PM
    • Unmarked as answer by jshoemaker21 Saturday, March 13, 2010 3:53 PM
    • Marked as answer by jshoemaker21 Friday, January 7, 2011 3:34 PM
    Saturday, March 13, 2010 2:56 AM

All replies

  • Right-click it on the taskbar, and choose 'Unpin from Taskbar'.  If you pinned it there, it will always be available -- whether the program is running or not.  The engineers who designed it referred to this as 'one icon to rule them all', so your program is always in the same spot, ready for you whenever you are.




    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    Monday, January 25, 2010 2:41 AM
  • I'm not talking about a pinned program. I'm talking about a "normal" one that shows when its open to the left of the pinned programs..... If you see another post it may help you understand better http://social.technet.microsoft.com/Forums/en/w7itproappcompat/thread/75813c77-198d-42cd-b14b-84ba6c09a84b
    James A+, Network+, MCP
    Monday, January 25, 2010 4:13 AM
  • In Windows XP, I minimize the same program it goes into the notification area, I wan't the same thing to happen in 7. In 7 It stays on the taskbar to the left where UNpinned opened items are.
    James A+, Network+, MCP
    Monday, January 25, 2010 4:15 AM
  • I think you mean 'right'... unpinned opened items are on the right.

    But in any case, there's kind of an answer to that.  Some programs have options you have to set to have them minimize-to-tray or whatever, but I'm sure you know that and are talking about programs that don't have that or it's not working with Windows 7.

    I can't really offer a workaround, but I can explain that the intention of the Windows 7 taskbar was for 1 icon to show at all times, in the same spot, running or not, minimized or not.  They wanted that program's home to be there, and never move.  They wanted to discontinue the system tray entirely except for system notifications.

    The reason they stated was "why should I user have to guess which Outlook icon to click?  Why have 1 in the Quick Launch, another if it's running but-not-minimized, and a 3rd version for if it's running-and-minimized (but not closed)?"

    So while you might want your application to minimize to tray, the engineers tried to not allow it.  If you use small icons, it basically takes up the same amount of space, it just gets to have its own spot.  I'd say give it a try.

    - - - - - - - - - - - -

    Having said that... there's nothing that should prevent a program from minimizing itself to the tray.  Microsoft allows it to happen, as long as the program is not pinned (if it's pinned, it'll stay there forever and always).

    However, some programs were specifically designed to no longer minimize to the tray in Windows 7.  This wasn't Windows 7's decision, but the developers specifically.  For example, Windows Live Messenger detects if it is running on Windows 7, and if so, it will not put itself in the tray.

    Here's my computer right now.  A few special cases of what's going on...

    Outlook is pinned between my other email client and Google Chrome there.  But it's also running and minimized. Outlook is set to minimize-to-tray, which is why it doesn't have the glass on it.  The taskbar thinks Outlook closed itself, so it's only showing me the pinned shortcut.

    You can see Outlook is running in the notification area (which is horribly crowded thanks to the Office 2010 beta).

    Zune is running, and never been pinned.  It also removed itself as a running program (removed itself from the taskbar) when it showed itself as a minimized toolbar here.  Programs can minimize to tray... and programs that don't were specifically designed not to.


    So if you see this issue, unfortunately, it means it's not Windows 7's fault... you just have to ask whoever created the program.




    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    Monday, January 25, 2010 5:56 AM
  • Hello jshoemaker21,

    It would be really helpful if you mention the programs that are behaving like that. Try to run the program in compatibility mode with a previous version of Windows. To do that:
    1- Right click on the programs shortcut and select properties
    2- Go to the Compatibility tab
    3- Check "Run this program in Compatibiltiy mode for", select "Windows Vista" and click ok.
    4- Now try to run the program again using that shortcut.

    Thanks,
    Tarek
    Monday, January 25, 2010 6:13 PM
  • Tarek is correct. The program you are using should either not optimized or changed the style in Windows 7. It is the same as Windows Live Messenger (It will not back to notification area as the program you are using). The workaround is to run it in compatibility mode so it will work as in Windows XP.
    Tuesday, January 26, 2010 1:12 AM
  • I did in the first thread. AIM (AOL Instant Messeneger).... I want it to go to the notification area like it did in XP when clicking X... WIndows Live Messenger is also the same problem..... Is this how it is supposed to be in Win 7? It's a poor design since people are used to it going to the notifcation area and not taking up all that space in the main area of the Taskbar. So The fix is the same for this as it is Live Messenger?
    James A+, Network+, MCP
    Tuesday, January 26, 2010 4:42 PM
  • Some people do not like this behavior. You can right click on Windows Live Messenger, choose Properties. In Compatibility tab, check the box "Run this program in compatibility mode for" and select Windows XP or Windows Vista.

    It is a workaround which can help move Windows Live Messenger to Notification Area when it is minimized.
    Wednesday, January 27, 2010 2:29 AM
  • download AIM 7.2, it has an option to hide the buddy list (options > buddy list) when minimized
    • Marked as answer by jshoemaker21 Saturday, March 13, 2010 3:53 PM
    • Unmarked as answer by jshoemaker21 Saturday, March 13, 2010 3:53 PM
    • Marked as answer by jshoemaker21 Friday, January 7, 2011 3:34 PM
    Saturday, March 13, 2010 2:56 AM
  • Andrew,

    The above steps worked for Windows Live Messenger but not AIM. This will fix AIM. I must have just had t wait for them to come out with the new version. Thanks


    Also, Tarek, I have a post about XPS printers and a log file which a someone from MSFT wanted me to send them. I cannot reach the person though. Is there anyway you can take a look?


    Thanks
    James A+, Network+, MCP
    Saturday, March 13, 2010 3:53 PM
  • have you tried right-clicking the MSN messenger icon (such as a shortcut to it on your desktop), go to Properties > Compatibility > Run this program in compatibility mode for Windows Vista
    then exit and run it that way and it might minimize upon hitting the X
    Saturday, March 13, 2010 6:56 PM
  • Thanks Shaon.  Also, let me clarify that this is not an issue with Windows 7, it's an issue with Windows Live Messenger.  In other words, Messenger is autonomous: it gets to decide for itself whether it minimizes to the Notification Area.  Windows 7 does not control the behavior in any manner.

    Specifically, Messenger was programmed to detect the current OS, and change its own behavior automatically.  That's why you can change the behavior by "tricking it" into thinking that the current OS is Vista.

    My feedback to the Windows Live Programming team would be to set an option inside Messenger, much the same way Yahoo Messenger and other programs have for controlling where they go when you minimize them.




    (Although I personally like it to stay on the taskbar.  My Messenger is always the #2 icon, whether it's running or not, and whether it's minimized or not... always there, every time.  Plus I can press Win+2 to pop it open, something you can't do if it's not there).



    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    Saturday, March 13, 2010 9:35 PM
  • the solution is: open the "settings" under the menu. go to "buddy list", check the box "Hide the taskbar icon when i close the buddy list"

     

    pretty stupid that this is not checked by default. but there you go!

     

    schleprock

    Friday, January 7, 2011 2:46 PM
  • The default way makes more sense to normal people.  For example, why would you want to explain this to your mom...

    "Okay mom, to get to your buddy list, click this icon on the desktop.  Unless you've already opened it earlier that day, then it's in the taskbar.  Wait, if you closed it, now it's over by the clock.  Unless it's not, then go back to step one."

    - - - instead of - - -

    "Your buddy list is always available from this one spot.  It never moves or disappears, so you can use your computer with confidence."

     

    I think the default fits much butter, but at least you're provided the option to choose what works best for you.

     

     

     


    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    Friday, January 7, 2011 2:55 PM
  • I saw this long ago and am sorry I didn't put down an answer. When I had the issue the newer version with this option weren't yet released. I agree. I do not like how this is not default.

    Thanks

     


    James A+, Network+, MCP

    Friday, January 7, 2011 3:35 PM