none
PDF documents not displayed in IE9 RRS feed

  • Question

  • Hi

    My PDF files are not displayed in IE9 but it displays in IE8. What could be the issue. I browsed and also performed the recommended solutions like,

    1. The Edit->preferences->internet->Display PDF in browser Option

    2. $wa = Get-SPWebApplication = http://URLofWebApp

       $wa.AllowedInlineDownloadedMimeTypes.Add("application/pdf")

       $wa.Update()

    But the issue is still the same.

    Thanks.


    Monday, January 20, 2014 12:59 PM

Answers

  • Hi,

    I found the root cause of this issue. PDF files can be displayed in IE 32-bit but not in IE 64-bit. I was trying to view the PDF file in IE 64-bit and was not able to view it. But IE 32-bit displays the PDF file correctly.

    In my system there are two IE installed, IE 32-bit and 64-bit. Adobe PDF reader add-on is only compatible with 32-bit version and that is the reason you can see it under Manage Add-ons. But if you try to view the Adobe PDF reader add-on in IE 64-bit, you won't.

    Hope this helps.

    Tuesday, January 21, 2014 10:25 AM

All replies

  • check Tools>Manage Addons.

    and

    Internet Options>Security tab, click "reset all zones to default"

    Please include a link to any website you are having problems with your questions for us to investigate.

    Regards.


    Rob^_^

    Monday, January 20, 2014 11:46 PM
  • Hi,

    Open Internet Explorer, Tools > Manage Add-ons, under Add-on Types, select Toolbars And Extensions> All Add-ons>Adobe PDF Reader, make sure that it is enabled to open PDFs in the browser.

    Regards


    Yolanda
    TechNet Community Support

    Tuesday, January 21, 2014 7:01 AM
    Moderator
  • Hi,

    I set Internet Options>Security tab, click "reset all zones to default" but issue is still the same.

    I checked Tools > Manage Add-ons, select Toolbars And Extensions> All Add-ons>

    and found that I do not have Adobe PDF reader add-on.

    Please advice I can get this add-on?


    Tuesday, January 21, 2014 9:01 AM
  • Hi,

    Under the "shows", instead "All add-ons",click "Run without permissions", then find Adobe PDF Reader, enable it.

    Regards


    Yolanda
    TechNet Community Support

    Tuesday, January 21, 2014 9:59 AM
    Moderator
  • Hi,

    I found the root cause of this issue. PDF files can be displayed in IE 32-bit but not in IE 64-bit. I was trying to view the PDF file in IE 64-bit and was not able to view it. But IE 32-bit displays the PDF file correctly.

    In my system there are two IE installed, IE 32-bit and 64-bit. Adobe PDF reader add-on is only compatible with 32-bit version and that is the reason you can see it under Manage Add-ons. But if you try to view the Adobe PDF reader add-on in IE 64-bit, you won't.

    Hope this helps.

    Tuesday, January 21, 2014 10:25 AM
  • Hi Zakir,

    I think you are right. Here is a snippet from an Adobe Help article.

    "Acrobat and Reader are 32-bit applications on Windows. If you try to open a PDF in a 64-bit version of Internet Explorer, the PDF opens in stand-alone Acrobat or Reader, not in Internet Explorer.

    Note: Only Reader 10.1 or Acrobat 10.1 and later support Internet Explorer 9."

    http://helpx.adobe.com/acrobat/kb/cant-view-pdf-web.html#id_49586

    For more information and support, please contact Adobe. Thanks for your understanding.


    Judy Zhou
    TechNet Community Support


    Tuesday, January 28, 2014 3:17 AM
    Moderator
  • Hi Judy_Zhou,

    Thank you for the reference article. This will help other users to gain more insight.

    There is one concern, my points are not increasing when any one marks it as answer or votes as an answer. Could you please help me with that.

    Thanks.

    Tuesday, January 28, 2014 7:19 AM