none
Trying to have 'users & resources' set to 'users' only RRS feed

  • Question

  • Trying to have users & resources set to users only.  At the moment, they are both resources & users.

    We have tried to delete them as “resources & users” from PWA >. Server Settings > Delete... (that is the only option we seem to  have).  Inerestingly enough, instead of them getting deleted, they just become inactive resources and continue to remain as users. 

    Even tried in Office 365 > Admin > User > Delete.  Unfortunately it made no difference.  We can not delete or remove resource/users.  Is this a bug?

    Using Project On-Line.


    \Spiro Theopoulos, Montreal, QC (Canada)

    Wednesday, February 25, 2015 9:28 PM

Answers

All replies

  • Hello,

    I see what you mean, when looking at the users on the Manager Users page (Project permission mode), the users that are also resources and the check box ticked but greyed out. In Project Server 2013 on-prem, this checkbox is enabled and can be deselected to make a user / resource just a user. Is this what you are seeing?

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS | MVP | Downloads

    Wednesday, February 25, 2015 9:43 PM
    Moderator
  • Yes!


    \Spiro Theopoulos, Montreal, QC (Canada)

    Wednesday, February 25, 2015 9:54 PM
  • I have asked the question within the Microsoft team, I will let you know when I hear back.

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS | MVP | Downloads

    Wednesday, February 25, 2015 10:02 PM
    Moderator
  • Hello,

    Project Online is working as expected, it is recommended not to deselect this check box for on-prem:

    https://pwmather.wordpress.com/2015/02/26/projectserver-projectonline-users-and-resources-ppm-project/

    Once a user is a resource as well there is no way to stop remove just the "resource" part. If you don't want to be available to projects etc. then use the security model prevent access to them.

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS | MVP | Downloads

    Thursday, February 26, 2015 7:33 AM
    Moderator
  • Thanks for the quick blog post Paul!

    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    Thursday, February 26, 2015 8:03 AM
    Moderator
  • Hi Paul Part of my original question; was how can I "delete" resources/users? Because let's say I wanted to start over and recreate my user! It would seem that we have the ability to do so along with Projects, etc, from PWA > Server settings > Delete Enterprise objects. So why is it that when I try to delete it only sets my resource to "inactive" and the user is unaffected ?

    \Spiro Theopoulos, Montreal, QC (Canada)

    Thursday, February 26, 2015 10:01 AM
  • Hello, I have just deleted a user / resource from my test Project Online instance and it was removed (both Resource and User). Does everything process in the queue ok?

    If that user / resource has assignments, it wouldn't be recommended to delete them as the resource will become a local resource etc.

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS | MVP | Downloads

    Thursday, February 26, 2015 10:17 AM
    Moderator
  • Thanks very much Paul. Yes, I am aware it's not recommended. We are not in production yet so we are experimenting and trying to set up accordingly. In our instance, we currently have a situation where we can delete resources/ users.

    \Spiro Theopoulos, Montreal, QC (Canada)

    Thursday, February 26, 2015 10:23 AM
  • In addition to Paul's excellent answer, look if the resource is used in a resource plan. In this case it can be deleted. I follow Paul on his advice, you should be careful when deleting a user/resource since it will loose all resource information and actuals. I'd suggest to inactivate it (in case it is also a user).

    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    Thursday, February 26, 2015 10:25 AM
    Moderator
  • Agreed. It is recommended not to delete to safeguard actuals. However, as I noted we are in the process of setting up and doing so tests. Not in production yet so if we loose actuals, no problem at this stage. My dilemma at the moment is it does not delete the users we have set up through Office 365. Any ideas?

    \Spiro Theopoulos, Montreal, QC (Canada)

    Thursday, February 26, 2015 10:30 AM
  • Do you see the jobs process in the queue successfully when deleting? You should see the following successful jobs after deleting the user/resource:

    Reporting (Resource Sync)
    Synchronize Project Web App Permissions to Project Web App 
    Prepare Project Web App Permission Synchronization

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS | MVP | Downloads

    Thursday, February 26, 2015 10:35 AM
    Moderator
  • Hello,

    im currently facing the exact same issue, with no solution yet! :/

    did you find a workaround or so ??

    Thank You!

    Wednesday, July 8, 2015 10:26 PM