locked
IEEE 1394 Host Controller does not show in device manager RRS feed

  • Question

  • I have been trying to connect by Sony Handicam via firewire with no avail. It turns out that IEEE 1394 Host Controller is not even showing up in Device Manager?!? How can I install those drivers?

    Running Vista Ultimate SP1
    Sunday, April 26, 2009 4:29 AM

Answers

  • Hi Turbo,

    1. It seems like you do not have the IEEE 1394 Host Controller plugged in properly, otherwise Windows would be able to detect it (and show "Unknown Device").

    OR

    2. Windows installed the wrong driver, thus it is appearing in a different name thus you can't use it.

    What I would suggest is, download the IEEE 1394 Host Controller device from the manufacturer's website, and run the Setup file there. It should replace the wrongly installed driver.

    If you do not know what IEEE 1394 Host Controller you are using, kindly provide us the computer make and model.

    Hope this helps!
    Jabez Gan [MVP] - http://www.msblog.org Contributing Author for: (Sybex) MCTS: Windows Server 2008 Applications Infrastructure Configuration Study Guide: Exam 70-643
    • Marked as answer by Turbo-Pascal Tuesday, April 28, 2009 2:45 AM
    Sunday, April 26, 2009 7:36 AM

All replies

  • Hi Turbo,

    1. It seems like you do not have the IEEE 1394 Host Controller plugged in properly, otherwise Windows would be able to detect it (and show "Unknown Device").

    OR

    2. Windows installed the wrong driver, thus it is appearing in a different name thus you can't use it.

    What I would suggest is, download the IEEE 1394 Host Controller device from the manufacturer's website, and run the Setup file there. It should replace the wrongly installed driver.

    If you do not know what IEEE 1394 Host Controller you are using, kindly provide us the computer make and model.

    Hope this helps!
    Jabez Gan [MVP] - http://www.msblog.org Contributing Author for: (Sybex) MCTS: Windows Server 2008 Applications Infrastructure Configuration Study Guide: Exam 70-643
    • Marked as answer by Turbo-Pascal Tuesday, April 28, 2009 2:45 AM
    Sunday, April 26, 2009 7:36 AM
  • That is funny. My case has USB, firewire and audio connection on the front panel. The USB and audio ports are connected to my motherboard but not the firewire...
    Tuesday, April 28, 2009 2:47 AM