locked
W7 RTM and ad hoc network with iPhone RRS feed

  • Question

  • I know this has been posted before but I just wanna know if anyone figured out how to solve the 169.xxx.xxx.xxx-IP problem with the iPhone using ad hoc network from Windows 7 (RTM).
    To brush up the problem: When creating an ad hoc network the iPhone connects very well, I can see that in Sharing Center, but the iPhone gets a 169.xxx.xxx.xxx-IP which is not right. I've tried to put in a static IP instead but without luck. The submask is also wrong - 255.255.0.0 which should've been 255.255.255.0

    So anyone with a solution?

    Sunday, August 30, 2009 8:23 AM

All replies

  • You need a DHCP server to assign some other IP, and the APIA range ip that your iphone is getting,
    is right in the existing situation and configuration which you have set..
    Or if you can use Internet Connection Sharing with AD-HOC, this will setup
    a mini configure less dhcp server for you on the windows 7 machine and your iphone
    should get a ip mostly in the range of 192.168.0.x/24

    Hope that helps..
    Sunday, August 30, 2009 11:15 AM
  • Okay. I dont understand this. I cannot remember the IP but when I tried to connect a Vista client to the Ad Hoc-network a couple of months ago, it worked very well, except for the iPhone (same problem as now).
    I think youre right in the DHCP-thing and I did try to look for a field to enable saying 'Use this Ad Hoc server as DHCP for clients connection' but I wasnt able to find it.

    But can you try to go in details how your would solve my problem. Oh, and btw, in the W7 Ad Hoc guide I am already asked if I wanted to share the internet which i answered yes to. The problem still exists though.

    // peter

    nb: however I would like to redirect you to this http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/dc00f244-b397-40be-8286-b448249949f0 which is the excat same problem - just more detailed!

    Sunday, August 30, 2009 4:24 PM
  • Have you tried configuring the iPhone to use a static IP in the same range as what ICS hands out, ie. 192.168.0.25 for example? Check the Wi-Fi sections in Chapter 19 of the user guide...

    http://manuals.info.apple.com/en_US/iPhone_User_Guide.pdf

    ...or ask how to do that on the AT&T Apple forum...

     http://forums.wireless.att.com/cng/board?board.id=apple

    MS-MVP Windows Desktop Experience, "When all else fails, read the instructions"
    Sunday, August 30, 2009 5:24 PM
  • I have tried to configure the IP static. It doesnt help.
    My iPhone connects - well i get the V-sign next to the WiFi-network but the WiFi-symbol never shows up in the top of the screen and my iPhone is still using the 3G-network when i browse or whatever.
    Sunday, August 30, 2009 6:02 PM
  • That sounds like an iPhone issue to me. I would post to the AT&T or Apple iPhone forums for help.

    Good luck...
    MS-MVP Windows Desktop Experience, "When all else fails, read the instructions"
    • Marked as answer by Andy Song Monday, August 31, 2009 2:49 AM
    • Unmarked as answer by Meegon Thursday, September 3, 2009 8:06 AM
    Sunday, August 30, 2009 8:45 PM
  • I like your 'good luck'...
    Have your red the thread I link to? the same specific problem? (I just wonder if it is me who's not that good at explaining the problem)

    // peter

    Sunday, August 30, 2009 9:35 PM
  • Just a note: I dont think your answer is the right one. This is, in my oppinion a Microsoft issue and should be bugfixed by Microsoft.
    Thursday, September 3, 2009 8:07 AM
  • Hi All, I'm having WIndows 7/iphone ad hoc problems too in that I can get the iphone connected to the network (i use it to run a vnc), but it is an unstable connection so my vnc session is regularly disconnected. I beliefve that this is a Windows 7 bug because I never had this problem when running Vista so somewhere along the line something has changed. My iphone also won't connect if i use WPA2 security on the ad hoc network whereas again I had no problems in vista. Can anyone shed any light on this?
    Thanks.
    Thursday, September 3, 2009 12:54 PM
  • Count me as another person who had this working just fine with Vista x64. With Win7 Business x64 I'm not able to get a stable ad-hoc network connection between the iPhone and my laptop. Given that this worked fine with Vista, and nothing has changed on the iPhone since then, clearly a change in Windows 7 broke it. Conclusion: Microsoft definitely changed something in ad-hoc networking that contributes to this problem, so it seems to me that some MS input would be warranted. Apple may still be to blame, for example by not adhering to standards, but in the very least we're going to need help from MS to nail this down. To test this locally, try to use the documents-to-go sync app for transferring some MS Word files to documents-to-go on the iPhone over an ad-hoc network. This used to work, but doesn't anymore due to network issues (connection drops, timeouts). -Joe
    Lenovo X61 tablet, Core2Duo L7700 1.8GHz, 4Gb,Intel 965 integrated graphics, MultiTouch/MultiView screen (pen + resistive touch), Intel turbo memory (disabled..), UltraBase docking station.
    Thursday, September 3, 2009 5:26 PM
  • I wrote to Hui Shen who responsed to the an older post which brings up the same issue.
    He mailed to today to extract some logfiles. I dont know wether or not but I think it might be a good idea if we all report this problem and extract the logfiles and send it to Microsoft (in this case Hui Shen [huis@microsoft.com]). But of course I wont be blamed for encourage to spam him. But Im going to write him myself.
    Run from an elevated prompts and then look in %windir%\tracing\ - zip the files and mail it: -

    Netsh wlan set tra yes 
    netsh ras set tr * en
    Reproduce your problem - Click Diagnose if you can -
    netsh ras set tr * dis

    // peter
    PS: Seems like Hui Shen forgot to unload the trace starting with netsh wlan set tra yes. I dont know if its official but i closed the trace with netsh wlan set tra no and then a tracereport started to generate.

    • Proposed as answer by enggankur Saturday, February 12, 2011 2:29 PM
    Thursday, September 3, 2009 7:23 PM
  • download, install and use connectify....its esy

    http://www.connectify.me/

    Saturday, February 12, 2011 2:30 PM
  • I am just another one with the same problem. 

    https://discussions.apple.com/thread/3050977

    I found this thread very useful and I am hoping Apple or MS will address it eventually.

    Thursday, May 12, 2011 12:52 PM