locked
USB Controllers not working RRS feed

  • Question

  • The computer I am working on does not recognize USB devices.  Device Manager shows the following status (in properties) for every controller device in the USB Controllers section (The computer is running Windows Vista Home Edition):

    Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)Click 'Check for solutions' to send data about this device to Microsoft and to see if there is a solution available.

    I have tried to uninstall the devices (and drivers) and reinstall them...no luck.

    I have tried to remove (renamed actually in case it caused problems) the infcache.1 file in C:\windows\inf and then uninstalled/reinstalled the devices again...no luck.  The file was recreated with no apparent adverse affects.

    I have a limited time to try to get this fixed and am having trouble finding other solutions.

    Thanks for any help you can offer.

     

    Thursday, June 24, 2010 3:09 AM