none
Error applying MIM hotfix from 4.4.17949.0 to 4.5.286.0 RRS feed

  • Question

  • Hello, I have been able to successfully upgrade my MIM system to 4.4.17949.0 without issue.  The system is running fine under 4.4.17949.0.  I recently attempted to apply hotfix 4.5.286.0 and I am receiving the following fatal error during the upgrade of MIM Portal and Service.  If anyone has seen this before and knows a solution I would appreciate any insights.

    Calling custom action Microsoft.IdentityManagement.PasswordResetCAs!Microsoft.IdentityManagement.ManagedCustomActions.PasswordResetCustomActions.GetIISVersion

    Exception thrown by custom action:

    System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.MissingMethodException: Method not found: 'System.String System.String.Format(System.IFormatProvider, System.String, System.Object, System.Object)'.

      at Microsoft.IdentityManagement.ManagedCustomActions.PasswordResetCustomActions.GetIISVersion(Session session)

      --- End of inner exception stack trace ---

      at System.RuntimeMethodHandle.InvokeMethod(Object target, Object arguments, Signature sig, Boolean constructor)

      at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object parameters, Object arguments)

      at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object parameters, CultureInfo culture)

      at Microsoft.Deployment.WindowsInstaller.CustomActionProxy.InvokeCustomAction(Int32 sessionHandle, String entryPoint, IntPtr remotingDelegatePtr)

    CustomAction GetIISVersionFromRegistry returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

    Action ended 15:11:27: GetIISVersionFromRegistry. Return value 3.


    Monday, December 3, 2018 10:06 PM

All replies

  • Hi Scott, 

    Which version of .NET do you have installed on your server? I've seen that this error may come up without .NET Framework v4.6 installed. 

    Wednesday, December 5, 2018 2:07 AM
  • Ok good tip.  The portal machine is at 4.5.2 so that could certainly be the culprit.  I am teaching a training class on this system in the coming week so I will give it a try when it is through.  Thanks for your help!
    Friday, December 7, 2018 7:44 PM
  • Hi,

    I can confirm that this error can occur when MIM server is not updated to .Net Framework 4.6.x before upgrading MIM Portal to 4.5.286.

    Have a nice day.

    Friday, April 5, 2019 10:42 AM