locked
Unabled to Print or Open PDF's in Internet Explorer using Adobe DC virtualized. RRS feed

  • Question

  • Hi,

    We are facing an issue with Adobe Reader DC on our RDS platform. I have sequenced the app in appv 5.1 using the guide provided here:

    https://www.adobe.com/devnet-docs/acrobatetk/tools/AdminGuide/appvreaderDC.html#dc-system-requirements

    The app works OK however there are two major issues we have found. The first is that if you try to open a pdf from a website or an email in IE the operation fails with the error "There is a problem with Adobe Acrobat/Reader. If it is running, please exit and try again (15:3)"

    I have tried the suggestions provided by google, making sure enhanced protection mode is disabled in IE etc but to no avail.

    The second issue is that trying to print causes the adobe app to crash with no error. You can open the print menu but as soon as you send the document it will sit with the progress bar showing the document being sent but with no progress then the app becomes unresponsive and must be closed.

    We can print ok from other virtual apps and if we tell users to use google chrome as their default for pdfs we dont have any issues.

    Any advice from those more experienced with appv would be greatly appreciated.

    Thanks,

    Simon

    Wednesday, November 8, 2017 2:51 PM

All replies

  • My recipe includes the following, which seems to fix some permission issues that cause DC to crash.  My recollection was that this was to fix a crash shortly after launch, and then only on first launch.  But maybe it will help you also.

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\DC\ExitSection]
    "bLastExitNormal"=dword:00000001
    [HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\DC\Language]
    [HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\DC\Language\current]
    @="acrord32.dll"
    [HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\DC\Language\next]
    @="acrord32.dll"
    [HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\DC\Language\UseMUI]
    "bUseMUI"=dword:00000001
    [HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\DC\Originals]
    "bDisplayedSplash"=dword:00000001

    [HKEY_CURRENT_USER\Software\Adobe\CommonFiles\Usage\Reader DC]
    "Date"="2016-12-18T17:56:47Z"
    "OptIn"=dword:00000000


    Tim Mangan MVP for App-V and Citrix CTP Author of AppV books: "PowerShell with App-V 5 (5.1 Edition)", "The Client Book (4.x)" and "OSD Reference Book" (http://www.tmurgent.com/Books )

    Thursday, November 9, 2017 9:38 PM
    Moderator
  • Thanks for the input Tim,

    I tried adding the registry keys suggested but the problem persists. It only seems to crash when trying to print a document, the other functions of the package are fine.

    I can print fine from other virtual apps, it is only adobe that seems to have an issue. I have managed to get foxit reader to work ok but this isn't a viable replacement.

    Very frustrating.

    Simon

    Monday, November 13, 2017 1:08 PM
  • Hi Simon,

    How are you disabling the protected mode for Adobe Reader DC, are you using the registry keys as part of the customization tool and scripting the passthrough edit on use of the application for HKLM\Software\Policies\Adobe? Or applying the registry keys via GPO, dynamic configuration files for the App-V package?

    "There is a problem with Adobe Acrobat/Reader. If it is running, please exit and try again (15:3)" - For me I initially went with just deploying registry keys to disable protected mode with the dynamic configuration files. I also looked to enable COM integration to get embedded PDFs in IE working as well. 

    Hope it helps,

    Ollie

    Friday, January 12, 2018 4:40 PM