locked
Web part throws error "Requested registry access is not allowed" RRS feed

  • Question

  • I saw several posts with the same error but in a different context. I have custom webpart which deploys just fine but when I click on the xyz.webpart in the gallery that's when I get the error.

    This is an established MOSS 2007 with the service account having admin rights.

     


    EJM
    Wednesday, July 27, 2011 8:15 PM

Answers

  • Hi,

     

    As Vikas said, the error may occur when asp.net application tries to write new eventsource in the eventlog, so, for better find the reason, please provide more information about your custom webpart, maybe the code for it.

     

    Here is the KB article about “PRB:’Requested Registry Access Is not Allowed’ Error message when ASP.NET Application Tries to Write New EventSource in the EventLog”, for more information, please refer to:

    http://support.microsoft.com/kb/329291

     

    Thanks,

    Qiao Wei

    Monday, August 1, 2011 12:31 PM
    Moderator

All replies

  • Is your webpart writing in event log?
    vikas
    Thursday, July 28, 2011 10:30 AM
  • Hi,

    Have you checked the ULS logs under verbose mode? If not then do so to get maximum info.

    Thanks,

    Rahul Rashu

    Thursday, July 28, 2011 7:41 PM
  • Hi,

     

    As Vikas said, the error may occur when asp.net application tries to write new eventsource in the eventlog, so, for better find the reason, please provide more information about your custom webpart, maybe the code for it.

     

    Here is the KB article about “PRB:’Requested Registry Access Is not Allowed’ Error message when ASP.NET Application Tries to Write New EventSource in the EventLog”, for more information, please refer to:

    http://support.microsoft.com/kb/329291

     

    Thanks,

    Qiao Wei

    Monday, August 1, 2011 12:31 PM
    Moderator