none
IE11 - no certificate name mismatch warning RRS feed

  • Question

  • we have some non-production websites using (thawte) SSL certificates that were made for their production counterparts. the SSL certificates are not wildcards and do not have multiple SANs. so the website demo.mycompany.com is using a certificate for www.mycompany.com.

    so i expect a name mismatch warning, but for some reason IE 11 is not giving me one. even if I browse to the internal hostname or IP address of the IIS server hosting the website, I don't get an error about the name mismatch. this happens on a windows 7 machine and a windows 8.1 machine.

    no, thawte has never heard of "10.160.11.33". this concerns me a little bit. shouldn't it?


    • Edited by John_Curtiss Thursday, December 3, 2015 11:08 PM
    Thursday, December 3, 2015 11:07 PM

Answers

  • Hi John,

    check

    IE Options>Advanced tab - "Warn about certificate address mismatch"

    Regards.


    Rob^_^

    • Marked as answer by John_Curtiss Thursday, January 7, 2016 8:39 PM
    Saturday, December 5, 2015 2:00 AM

All replies

  • Hi John,

    check

    IE Options>Advanced tab - "Warn about certificate address mismatch"

    Regards.


    Rob^_^

    • Marked as answer by John_Curtiss Thursday, January 7, 2016 8:39 PM
    Saturday, December 5, 2015 2:00 AM
  • Hi John Curtiss,

    According to your scenario, I suggest to check the Certificates settings firstly.

    Tools->Internet Options->Content tab->Certificates and Tools->Internet Options->Advanced-> Warn about certificate address mismatch.

    The following web page may be helpful to your issue

    http://www.iis.net/learn/troubleshoot/security-issues/troubleshooting-ssl-related-issues-server-certificate

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, December 7, 2015 9:17 AM
    Moderator