Outlook 2010 advanced search not working


  • We use Outlook 2010 32bit on Win 7 64bit machines, we are on a 2008r2 doamin and our Exchange server is 2010.  I have a user who's advanced search is not working, regular search seems to work just fine.  I have rebuilt the indexes, removed Outlook from the indexes and added it back in.  Nothing that I have done has corrected the problem.  Has anybody had a problem with advanced search in Outlook 2010, if so what did you do to fix it?  The user has a very large mailbox, about 10GB.



    Shaun Owens
    Wednesday, May 18, 2011 5:42 PM

All replies

  • Hi,

    Try to Rebuild the index

    1. Click Start, in the Search box, type Indexing, and open Indexing Options under Control Panel.

    2. Click Advanced, click the Index Settings tab, and then click Rebuild.  If you are prompted for an administrator password or confirmation, type the password or provide confirmation.


    If it still not works, try to use following method. 

    Step 1: Check registry settings

    1. Click Start, in the Search box, type regedit and press Enter to open the registry editor.

    2. Locate the following registry subkeys:



    3. Please first back up the registry subkeys above. Then, check if the value data is set to 1. If it is, please change it to 0, or delete the registry subkey.

    For more information, you can also refer to the following article:  


    Hope that helps.

    Thursday, May 19, 2011 9:07 AM
  • Hi Jennifer,

    I don't see any of the keys that you show in the registry, what I do see is:HKEY_LOCAL_MACHINESoftware\Policies\Microsoft\Windows\ but no search.  There is a: HKEY_LOCAL_MACHINESoftware\Policies\Microsoft\Windows\Windows Search\ but none of the mentioned subkeys.  Can you be of additional help?    Shaun

    Shaun Owens
    Tuesday, May 24, 2011 2:50 PM
  • Hi,

    Try to run this command: C:\windows\system32\regedit32.exe

    Also try to enable windows search service.

    Thursday, May 26, 2011 8:58 AM
  • Hi Jennifer,

    I see the same thing when I run regedit vs regedt32, I don't see any of the registery keys that you mentioned.  We are running Win 7 64 bit and 32 bit office 2010.  Any suggestions?  I did verify that the windows search service is started.



    Shaun Owens
    Thursday, May 26, 2011 11:09 PM
  • We are having the same problem. Windows 7, Office 2010 32-bit. The regular search works on all the folders, but the Advanced Find only works on the INBOX. It will only work on all the folders if we change the option to "Any type of Outlook item." Please tell MS to fix this!!
    Tuesday, December 06, 2011 1:16 PM
  • I have a similar problem where Outlook shows in my indexing options but I can not access it to modify.

    All I get is the spinning wheel.

    I am running iCloud and that might be an issue.

    Saturday, January 07, 2012 3:26 PM
  • Hard to tell what your symptoms are from your post, but have you tried just waiting?  On my machine, when I open the advanced search window, enter a search and click "Find Now", it appears that nothing is happening.  The magnifying glass icon doesn't animate, the "Find Now" button doesn't dim, and the "Stop" button doesn't darken, all of which are supposed to happen while a search is in progress.  But I leave the window there for a while (why the searches take so long is another question -- X1 Search anyone?), eventually my results show up.  This problem is discussed in this post.  Hope that helps.  But I hope more that Microsoft fixes this annoying bug! 

    Wednesday, January 25, 2012 2:32 PM
  • Looks like MSFT may have finally fixed this!  I just did an advanced find in Outlook, and the magnifying glass is spinning, the "Stop" button is clickable... just like old times!  Running Outlook Professional Plus 2010 32-bit (14.0.6117.5001) SP1 MSO (14.0.6112.5000).
    Thursday, May 17, 2012 2:22 PM
  • Best solution is use your MS Office CD (if you have  Oulook only use that one) and in the setup use "repair" option.

    I tried all the possible options (rebuild, index, enable search/index in coontrol panel etc and nothing worked) and REPAIR option worked like charm. I have windows 7 64 bit, MS office professional 2010.

    Hope this will help..

    Wednesday, September 19, 2012 9:10 PM
  • The following simple steps worked for me:

    • In Outlook, go to File->Options and select Search in the list on the left.
    • Click the Indexing Options button on the right, then click the Modify button.
    • Uncheck Microsoft Outlook, click Ok, and then close the Indexing Options.
    • Restart Outlook.

    I have Outlook 2010 installed on both my personal laptop and my company laptop, and previously I found that the advanced search was either unreliable or did not work at all. But after following the steps above which
    remove Outlook from the indexing options, the advanced search works fine on both laptops. It may seem counter-intuitive to remove Outlook from the indexing options, but it seems that Outlook 2010 has built-in search capabilities, and so does not need separate indexing - refer to Microsoft Support Article ID 2385524.

    Don't waste time and effort rebuilding indexes, editing the registry, installing additional MS search tools or anything else suggested in other forum posts as a solution to this problem - I tried them all without success.
    Just follow the steps above!

    • Proposed as answer by Friday, March 15, 2013 7:54 PM
    Friday, March 15, 2013 7:52 PM
  • Yes as you said, I wasted much time on the ways searched in the internet, but only ur ways work, hepe more guys find this. Simple always much helps.
    Saturday, September 07, 2013 6:30 AM
  • Amazing, your note works like a charm! Thank you so much.

    And to be more precisse, don't wory as me in step "Uncheck Microsoft Outlook, click Ok, and then close the Indexing Options." to uncheck all the items. Then click ok and then redisplay this window with locations again. Woala, you will see previously missing Outlook item!

    Thank you, perfect, happily searching in Outlook again. :)

    Tuesday, August 05, 2014 11:34 AM
  • 2 Years later and this still works, i'm on Win7k SP1 x64 & Outlook 2013


    Friday, March 20, 2015 4:22 PM
  • This solved it for me as well. I realize this question was asked four years ago, and the answer was given two years ago, but could a moderator please step in and MARK THIS AS THE ANSWER?

    This is the first result from Google for the search "advanced find outlook 2010 not working". Obviously, the thread is still relevant. Please mark it as the answer.

    • Proposed as answer by CigarDoug Monday, November 21, 2016 12:31 PM
    Monday, May 04, 2015 12:14 PM
  • thank you to     your  proposal is very effective and it works ..... 
    Saturday, October 01, 2016 7:06 AM
  • Since no one is listening, I propose my own answer as the answer. Maybe someone will notice. Please make's answer the answer!
    Monday, November 21, 2016 12:32 PM
  • Works Perfect!!!


    Tuesday, March 28, 2017 7:47 PM
  • Greats job... save a lot of time.


    Thursday, December 21, 2017 9:54 AM