none
BGInfo says it is blocked

    Question

  • When trying to run BGInfo on my 2003 and 2008R2 servers, C:\Bginfo.exe bginfo.bgi /timer:0 (I only edited what items are displayed) as Administrator, I get the following error mesage(s)
    on 2008 R2 (Domain Controler)
     
    An error has occured while attempting to set the new desktop settings.
    Please ensure the current user has rights to change desktop settings.
    This program is blocked by group policy. For more information....
     
    or on 2003 32bit
     
    An error has occured while attempting to set the new desktop settings.
    Please ensure the current user has rights to change desktop settings.
    The operation completed successfully. (then the error about the file already exists)
    I have checked the local group policies on all the servers and there is nothing configured to block changing the background. I have checked the Domain Group Policies , likewise nothing is configured (or enabled for that matter)
     
    Is there something I am missing?
     
    Thanks
    Matt
     
     
    Tuesday, March 27, 2012 8:30 AM

All replies

  • Have BGinfo run as an administrator :)

    That should solve the problem.
    Wednesday, March 28, 2012 2:10 AM
  • I am logged in as the administrator, and I have tried running w/ elevated rights. Clap

    It is something w/ a standard 2003 & 2008 server instal. I have also installed the Desktop Experience feature in 2008 and that has not had any effect. There is a policy somewhere that I cannot find. Confused
     
    Thanks
    Matt
    Wednesday, March 28, 2012 5:10 AM
  • @Matt.Rupp,
     
    I hate to say it but your answer is in your post "This program is blocked by group policy" You have a Domain Policy somewhere that is blocking BGInfo.exe from running. You need to run RSoP to help track it down. -WS
     
     
    Wednesday, March 28, 2012 9:42 PM
  • I'm having the same issue, but not on every machine. I have a couple DC's and member servers in a mix of Server 2008 and 2008 R2. On both DC's, no problem. One member server no problem, another member server I get the same error about group policy. I have no policy restrictions, if I did I would not have been able to install it on the other servers. The only major difference about this server is that it runs Hyper-V. So I'm thinking that it has to be a local policy. I'm combing through it right now. If anyone knows where the local policy is I would appreciate a post to where it is. If I find it before a post back I'll post my findings here.
    -Earle
    Thursday, March 29, 2012 8:16 AM
  • Yes I do understand that the error message is stating that there is a Group Policy preventing BGinfo from changing the Desktop Background. and I have run an RSoP and there is nothing that I can find that would prevent it from changing the background. As stated in my orginal post, I have looked at the local PC policy and the Domain Policy, which there are no policies enforced on the domain anyway, and I can find nothing.
     
     
    Maybe I misstated my problem in the orginal post, BGInfo opens (during startup or manually) and collects its data and creates the background file in the location specified. But when it tries to change the background it is being blocked.
     
    Thanks
    Matt
    Thursday, March 29, 2012 9:46 AM
  • You didn't misstate your position. I was thinking that in my case that the problem is with the local policy. Your case may be different. How many servers/workstations are you trying to install this package on? Have you been successful in installing this on any machine in your environment?
    On the server I'm having problems with I can install it, but it fails to change the wallpaper like the problem you are having, getting probably the same error message. However I've been successful on installing this on other servers in the same domain. So that's why I was thinking it's a hard to find setting or policy on the local machine.
     
    I'll continue to search and post back if I find something. Maybe the solution will help others if applicable.
     
    -Earle
    Thursday, March 29, 2012 11:59 AM
  • I have somewhat the same domains and all runs well and we have lots of policies.
     
    Try these things:
     
    1) Move BGInfo to C:\Program Files\BGInfo. Microsoft likes software in Program Files, we found this out long ago. We always make sure software is there; this seems to avoid many errors.
    2) On W07 and W08R2 make sure UAC is off.
     
    If I think of something else I will post. -WS
    Saturday, March 31, 2012 12:02 AM
  • What do you currently have for your background, before BGInfo? Can you change it? What happens if you just run the .BGI file?
    Tuesday, April 3, 2012 4:35 AM
  • I have somewhat the same domains and all runs well and we have lots of policies.
     
    Try these things:
     
    1) Move BGInfo to C:\Program Files\BGInfo. Microsoft likes software in Program Files, we found this out long ago. We always make sure software is there; this seems to avoid many errors.
    2) On W07 and W08R2 make sure UAC is off.
     
    If I think of something else I will post. -WS


    This is interesting as I have put the BGinfo files in the root of C:\ with no problems at all. The only issue anyone would have is if the user had limited access to the location of BGinfo. I have found in the past that BGinfo is dependent on permissions.
    Tuesday, April 3, 2012 9:52 PM
  • I realise this is a very old thread, but since I've solved my problem thought I'd post.

    Are you using logmein to connect to the server? If so I had the same problem and have solved the issue

    Open Logmein preferences, and untick "Disable wallpaper and user interface effects on host computer". Restart the Logmein service.
    Thursday, November 22, 2012 6:45 AM
  • I realise this is a very old thread, but since I've solved my problem thought I'd post.

    Are you using logmein to connect to the server? If so I had the same problem and have solved the issue

    Open Logmein preferences, and untick "Disable wallpaper and user interface effects on host computer". Restart the Logmein service.
    It's 2019, and this answer is still relevant. Thank you!
    Monday, February 4, 2019 6:31 PM