locked
one mailbox with multiple email addresses RRS feed

  • Question

  • hello,

    i have exchange 2013 and i need to configure 2 email address for the same mailbox. for example, the current mailbox is 555@iico.net and want it to be someone@iico.net for the same mailbox, and make someone@iico.net is primary mail.

    Regards,

    Sunday, June 21, 2015 10:16 PM

Answers

  • Add the address in the E-mail Addresses tab and then set it to be the reply address.

    Or:

    Set-Mailbox -Identity 555@iico.net -EmailAddresses "SMTP:someone@iico.net","smtp:555@iico.net"


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."


    • Edited by Ed CrowleyMVP Monday, June 22, 2015 12:29 AM
    • Marked as answer by IICO2022 Tuesday, June 23, 2015 9:58 PM
    Monday, June 22, 2015 12:28 AM

All replies

  • hi,

    i have a user has mailbox 555@iico.org and that mailbox contains a lot of messages. The user wants to change that mailbox alias to someone@iico.org . Now how i can merge 555@iico.org with someone@iico.org, and when he sends mail to other users should shown someone@iico.org but at the same time he can receives emailson both mailboxes

    Regards,

    • Merged by Lynn-Li Tuesday, June 23, 2015 6:51 AM duplicated thread
    Sunday, June 21, 2015 9:50 PM
  • Add the address in the E-mail Addresses tab and then set it to be the reply address.

    Or:

    Set-Mailbox -Identity 555@iico.net -EmailAddresses "SMTP:someone@iico.net","smtp:555@iico.net"


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."


    • Edited by Ed CrowleyMVP Monday, June 22, 2015 12:29 AM
    • Marked as answer by IICO2022 Tuesday, June 23, 2015 9:58 PM
    Monday, June 22, 2015 12:28 AM
  • Answered your duplicate post in the Exchange Server 2010 forum.

    https://social.technet.microsoft.com/Forums/en-US/d0723137-fa54-4ef8-8d2d-4f93c34c05d4/one-mailbox-with-multiple-email-addresses?forum=exchange2010


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."


    Monday, June 22, 2015 12:30 AM
  • Hi,

    Just to add on to Ed, You have to include all email addresses for the mailbox when you use this command syntax. If you don't, the addresses specified in the command will overwrite the existing addresses.

    Run the following command in the Shell.

    Get-Mailbox <identity> | fl EmailAddresses 
    • Note all the existing email address before overwriting it.

    References:

    Add or remove email addresses for a mailbox

    https://technet.microsoft.com/en-us/library/bb123794(v=exchg.150).aspx


    Regards,

    Satyajit

    Please“Vote As Helpful” if you find my contribution useful or “MarkAs Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.



    Monday, June 22, 2015 7:29 AM
  • Hi,

    Just to add on to Ed, you have to include all email addresses for the mailbox when you use this command syntax. If you don't, the addresses specified in the command will overwrite the existing addresses.

    Run the following command in the Shell.

    Get-Mailbox <identity> | fl EmailAddresses 
    • Note all the existing email address before overwriting it.

    References:

    Add or remove email addresses for a mailbox

    https://technet.microsoft.com/en-us/library/bb123794(v=exchg.150).aspx


    Regards,

    Satyajit

    Please“Vote As Helpful” if you find my contribution useful or “MarkAs Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.



    Monday, June 22, 2015 7:30 AM
  • Yeah, there's actually a better way.

    Set-Mailbox -Identity 555@iico.net -EmailAddresses @{add="smtp:someone@iico.net"}
    Set-Mailbox -Identity 555@iico.net -PrimarySmtpAddress someone@iico.net


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    • Proposed as answer by Just Karl Monday, June 22, 2015 4:46 PM
    Monday, June 22, 2015 3:23 PM
  • Yeah, there's actually a better way.

    Set-Mailbox -Identity 555@iico.net -EmailAddresses @{add="smtp:someone@iico.net"}
    Set-Mailbox -Identity 555@iico.net -PrimarySmtpAddress someone@iico.net


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Tank you. Its working now but add disabled email address policy with second command:

    Set-Mailbox -Identity 555@iico.net -PrimarySmtpAddress someone@iico.net  -EmailAddressPolicyEnabled $fase

    - Is there is any way when i send email from 555@iico.net appears  to the recipient as someone@iico.net


    Monday, June 22, 2015 8:27 PM
  • Outlook and Exchange send from the primary SMTP address, so that's what should happen.  If you want mail to look it comes from both addresses based on a choice, you can look at this add-on:

    http://www.ivasoft.biz/choosefrom2007.shtml


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."


    Monday, June 22, 2015 9:17 PM
  • But after run Set-Mailbox -Identity 555@iico.net -PrimarySmtpAddress someone@iico.net  -EmailAddressPolicyEnabled $fase,  someone@iico.net email address became the primary SMTP address, so should be primary email for outgoing messages. But when i tested its not.
    Monday, June 22, 2015 9:44 PM
  • Using MAPI or OWA?  Or are you using POP or IMAP?

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Monday, June 22, 2015 9:59 PM
  • Enter:

    Get-Mailbox -Identity 555.iico.net | FL EmailAddresses

    What address shows up with the capitalized SMTP:?


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Monday, June 22, 2015 10:01 PM
  • Thank you, its working now
    Tuesday, June 23, 2015 9:21 PM
  • You're welcome, happy to have helped.  Please feel free to mark my posts as answers and/or helpful.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Tuesday, June 23, 2015 9:48 PM