none
Project Plan resources not syncing up to Sharepoint RRS feed

  • Question

  • My organization uses AD to manage resources and our usernames are formatted in a particular way (eg, Smith, John [FM]). When creating our project plans on MS Project, we tend to abbreviate these names with just using the resource's field name (eg, John).

    I also tried typing out the resource name in the project plan as the same way it appears in AD (eg, Smith, John [FM]) but it won't allow me to add special characters such as "[,]".

    Has anybody here figured out a way to get around these issues? Without finding a workaround or fix, we wouldnt be able to leverage Project Server's resource management capabilities, which is critical.

    Thanks in advance.

    Tuesday, October 6, 2015 10:57 PM

Answers

  • Hi,

    sorry for dealy - due to time zone ....

    Seems that you are using Project Server in a different than the designed way. When I understand correctly, you are saving your project as a file to the project site. The idea of Project Server is to save and publish on Project Server directly, eg to take advantage of Enterprise Resource Pool. Not sure, if that is on purpose, or just how you figured out what you can do?

    How to save projects on Project Server (not on project site): Do you have created a profile to connect with Project Server? File - Info - Manage Accounts. Add an account, and take care, that you use exact spelling of PWA URL, just remove /Default.aspx.

    Define it as Default account, if you mainly work with projects on Project Server. I suggest to enable "Choose an account", so you can decide afetr starting project, if you want to work with files only (profile Computer) or with Project Server (the account you are currently creating)

    After craeting this account, you need to restart Project. It will ask you for the profile, just choose the new one.

    When you use File - Open - Project Web App - Browse, you can open all projects from server, you are allowed to open. If there are no projects listed, click on "Show me the list of all projects". Or just open your existiing project whereever it is saved.

    When yor project is open, you can build your team on tab Resource - Add Resources - Build Team from Enterprise. Select all resources from left, who shall work on your project and move them with "Add" to the right. Close dialog. afterwards, you will be able to just select them in Resource column, or - preferable - with Assign Resource dialog (in tab Resource).

    After modifying your project, you can either save or publish it. When saving, only editors of the plan can see your changes. Commonly, you want to publish, which makes this information available in PWA at "Projects".

    Does that help or just raising additional questions. Just let me know, if you need some more help, we can also take this offline.

    Regards
    Barbara


    To increase the value of this forum, please mark the replies that helped to solve your issue as answer. If you find answers to questions from other forum participants to be helpful, please mark them as helpful. Your participation will help others to find an appropriate solution faster. Thanks for your support!

    • Marked as answer by thumpersd Thursday, October 8, 2015 4:57 PM
    Thursday, October 8, 2015 4:15 AM
    Moderator

All replies

  • Hi,

    I am not able to reproduce your issue. I created the same account in AD and added him using Resource Synchronisation.

    In this way, special characters are changed according to regional settings. So it looks like this in Resource Center in my case:

    After adding this resource in clinet to my project using Resource - Add Resource - Build Team from Enterprise, I can assign tasks.

    What am I doing different than you?

    Regards
    Barbara


    To increase the value of this forum, please mark the replies that helped to solve your issue as answer. If you find answers to questions from other forum participants to be helpful, please mark them as helpful. Your participation will help others to find an appropriate solution faster. Thanks for your support!

    Wednesday, October 7, 2015 5:49 AM
    Moderator
  • So it looks like you're trying to define local resources in your project plan?

    And you're correct "," is not allowed - and thats final - no fix.

    Local resources will not help you use the Project Servers resource management capabillities - for that you need to define Enterprise Resources in PWA - Resource Center.

    A workaround to use the field name you could make a custom field on the resources called "field name" if you want that to appear in the Gantt or so.

    Best Regards | Power2plan | https://www.power2plan.com

    Wednesday, October 7, 2015 8:10 AM
  • Barbara,

    Thanks for the response. I am able to use {} just fine but not []. This is fine, because our resources can be named using those allowable brackets.

    I'm not able to create new AD resources since I'm not a systems admin here so I will have to use existing resources.

    As you can see from the screenshot below, 'Prasad; S {HDS}' is listed as a resource under the PWA and is pulled from AD. When I create a brand new project site, then create brand new MS Project plan and assign this resource to a task, I get the error shown in the 2nd screenshot.


    As you can see, I have a task assigned to the resource in MS Project and it's spelled correctly:

    John,

    No, I'm using enterprise resources from AD. I'm typing the resource name out in MS Project exactly the way it's spelled in AD.

    Wednesday, October 7, 2015 5:13 PM
  • Hi,

    you are writimg about typing the name (in error screenshot, it seems that the last letter is missing). Moreover, the message indicates, that you want to sync with SharePoint, not Project Server. Just to clarify: You are using Project Server and you save and publish your project to PWA?

    Have you tried to add the resource to project team (in browser or client using "Build team). Have you tried to assign the resource by using Assign Resource dialog in client? Does that also fail?

    Regards
    Barbara


    To increase the value of this forum, please mark the replies that helped to solve your issue as answer. If you find answers to questions from other forum participants to be helpful, please mark them as helpful. Your participation will help others to find an appropriate solution faster. Thanks for your support!

    Wednesday, October 7, 2015 6:38 PM
    Moderator
  • Barbara,

    I appreciate your quick response.

    If you look at the third screenshot, the last character is not missing. When I try to sync, I see the 2nd screenshot (sorry for not making it in order). It removes that closing bracket, and you can see it added to the end of "...server".

    I'm syncing it to a Project Server project site, not Sharepoint. The sync work though, with the exception of the resource name errors.

    I'm not sure how to "build" a team either. I'm able to to assign resources via the browser though but Im having problems using the 'Open with Project' functionality as it doesnt think I have Project Pro '13 installed on my computer. That's another issue that I'll have to look into.

    Am I supposed to type out the resource name in my project plan the exact same way it's formatted in AD (which Ive been doing)? Or is MS Project supposed to be integrated with AD so that when I begin to type a resource name, a drop down with available/suggested resource names is displayed underneath, like how it is in SharePoint/Project Server?

    I've also confirmed that 'Resource Names' is mapped to 'Assigned To'.

    Wednesday, October 7, 2015 8:41 PM
  • Hi,

    sorry for dealy - due to time zone ....

    Seems that you are using Project Server in a different than the designed way. When I understand correctly, you are saving your project as a file to the project site. The idea of Project Server is to save and publish on Project Server directly, eg to take advantage of Enterprise Resource Pool. Not sure, if that is on purpose, or just how you figured out what you can do?

    How to save projects on Project Server (not on project site): Do you have created a profile to connect with Project Server? File - Info - Manage Accounts. Add an account, and take care, that you use exact spelling of PWA URL, just remove /Default.aspx.

    Define it as Default account, if you mainly work with projects on Project Server. I suggest to enable "Choose an account", so you can decide afetr starting project, if you want to work with files only (profile Computer) or with Project Server (the account you are currently creating)

    After craeting this account, you need to restart Project. It will ask you for the profile, just choose the new one.

    When you use File - Open - Project Web App - Browse, you can open all projects from server, you are allowed to open. If there are no projects listed, click on "Show me the list of all projects". Or just open your existiing project whereever it is saved.

    When yor project is open, you can build your team on tab Resource - Add Resources - Build Team from Enterprise. Select all resources from left, who shall work on your project and move them with "Add" to the right. Close dialog. afterwards, you will be able to just select them in Resource column, or - preferable - with Assign Resource dialog (in tab Resource).

    After modifying your project, you can either save or publish it. When saving, only editors of the plan can see your changes. Commonly, you want to publish, which makes this information available in PWA at "Projects".

    Does that help or just raising additional questions. Just let me know, if you need some more help, we can also take this offline.

    Regards
    Barbara


    To increase the value of this forum, please mark the replies that helped to solve your issue as answer. If you find answers to questions from other forum participants to be helpful, please mark them as helpful. Your participation will help others to find an appropriate solution faster. Thanks for your support!

    • Marked as answer by thumpersd Thursday, October 8, 2015 4:57 PM
    Thursday, October 8, 2015 4:15 AM
    Moderator
  • Thanks again, Barbara. I acknowledge your response in my other thread as well. I will follow the process you suggested and will contact you should I have any issues or concerns.
    Thursday, October 8, 2015 4:57 PM