none
mmc.exe crashes at .NET Framework "clr.dll" file with code c0000005

    Question

  • Mose MMC snap-ins based on .NET 100% crashes in clr.dll with code c0000005: Hyper-V, Event Viewer, Task Scheduler.....

    Snap-ins not based on .NET are all OK: Computer Management, Device Manager, Disk Management....

    This machine is a Mac mini running Windows Server 2012 R2.

    This problem begins several days before....I really don't know how to resolve it.


    黄俊伟(wbpluto) MSN: hjw@live.cn Blogs: http://blog.wbpluto.com http://blogs.itecn.net/blogs/wbpluto



    Saturday, November 02, 2013 4:19 PM

All replies

  • Have you run windows update?  There are a number of .Net 4.0 fixes in them.

    What version of clr.dll is on that machine?

    http://blogs.msdn.com/b/dougste/archive/2011/09/30/version-history-of-the-clr-4-0.aspx


    Possible HotFix:  http://support.microsoft.com/kb/2640103
    • Edited by Tom1212 Saturday, November 02, 2013 4:55 PM
    Saturday, November 02, 2013 4:47 PM
  • Hi,

    Anything update?

    If you need further assistance, please feel free to let us know.

    If you have solved this issue, I would appreciate it if you can share the troubleshooting steps with us since it could be greatly helpful to anyone who has similar needs.

    Best regards,

    Susie

    Tuesday, November 05, 2013 9:51 AM
    Moderator
  • Thanks. Your link is published in 2011, .NET version 4.0.30319.526, but I'm running Windows Server 2012 R2 which is released in 2013!

    I don't think I can install this hotfix in WS2012 R2.


    黄俊伟(wbpluto) MSN: hjw@live.cn Blogs: http://blog.wbpluto.com http://blogs.itecn.net/blogs/wbpluto

    Tuesday, November 05, 2013 5:33 PM
  • Hi Moderator. Not resolved.

    黄俊伟(wbpluto) MSN: hjw@live.cn Blogs: http://blog.wbpluto.com http://blogs.itecn.net/blogs/wbpluto

    Tuesday, November 05, 2013 5:33 PM
  • Hi,

    Thanks for your feedback.

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Thank you for your understanding and support.

    Best regards,

    Susie

    Wednesday, November 06, 2013 8:42 AM
    Moderator
  • Hi,

    Would you please perform the following steps to see if the issue can be resolved?

    1. Reinstall .NET Framework feature.

    2. Run the following command with an elevated command prompt.

    • DISM.exe /Online /Cleanup-image /Scanhealth
    • DISM.exe /Online /Cleanup-image /Restorehealth
    Thursday, November 07, 2013 1:29 PM
  • Thanks, I did this, this file is OK, but the problem still as before.

    黄俊伟(wbpluto) MSN: hjw@live.cn Blogs: http://blog.wbpluto.com http://blogs.itecn.net/blogs/wbpluto


    • Edited by 黄俊伟MVP Saturday, November 09, 2013 5:24 PM
    Saturday, November 09, 2013 5:23 PM
  • Hi,

    Could you pleae disable all third-party applications and services, then reboot the server and see if the issue can be resolved?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, November 12, 2013 1:56 PM
  • Hi,

    Any updates?
    If you have solved this issue, I would be appreciate it if you can share your troubleshooting steps with us.

    If you need further assistance, please feel free to let us know.

    Best regards,

    Susie

    • Proposed as answer by coventrypete Monday, February 15, 2016 2:14 PM
    • Unproposed as answer by coventrypete Monday, February 15, 2016 2:14 PM
    Monday, November 18, 2013 7:25 AM
    Moderator
  • Hi, first ever post so if wrong just say.  We had same issue with Remote Desktop gateway server (2012 r2) when trying to add new CAP or RAP policies - mmc.exe just exits with eventlog eventid 1000.  Our solution was to uninstall .Net framework 4.6.1 and then it worked ok (it was an installed package from a windows update). Hope this helps someone.  I have no way of getting this information to Microsoft - please pass it on if the fix works if you can.
    Monday, February 15, 2016 2:18 PM
  • Same problem here. MMC carshed on RD Gateway Server when you edit settings or trying to add a CAP or RAP Policy.

    The Solution to uninstall .NET Framework 4.6.1 - KB3102467 solved this error for me.


    • Edited by Azazel79 Friday, March 11, 2016 1:30 PM
    Friday, March 11, 2016 1:30 PM

  • Hello,

    Same problem (when trying to add a Policy on a RD Gateway), same solution (uninstall .NET Framework 4.6.1 - KB3102467) !

    Thanks a lot to coventrypete and  Azazel79 for the solution !
    Tuesday, March 22, 2016 5:23 PM