SharePoint 2013 Popularity Trends Empty


  • Hi All,<o:p></o:p>

    I have configured SharePoint 2013 on two tier farm (WEB/APP + SQL). Search and UHDC service application has been configured and associated with web app. Site collection Popularity Trends reports not showing any usage data, usage report is empty. I have checked/tried<o:p></o:p>

    1) SQL authentication for logging database<o:p></o:p>

    2) Checked WSS_WPG and WSS_Admin_WPG permission on log folder.<o:p></o:p>

    During debugging I noticed that Search analytic reporting database, AnalyticsItemData table only have records for Event Type = 4. No records for Event Type = 1. For testing purpose I changed event type 4 to 1 for site collection which started showing data in usage reports.<o:p></o:p>

    It seems like usage data is not getting saved into DB.<o:p></o:p>

    All search components are active and all jobs are running successfully.<o:p></o:p>

    Can anyone please suggest any direction?<o:p></o:p>

    Thanks in advance for help.<o:p></o:p>

    Wednesday, March 13, 2013 9:48 PM

All replies

  • Hi

    Did you manage to resolve this issue, I am having the same problem with Usage stats coming up empty...

    Thursday, May 16, 2013 1:40 AM
  • Any luck here.  Same issue.  I even have a ticket open with MSFT and not moving very fast...

    Wednesday, May 29, 2013 8:18 PM
  • Any luck here.  Same issue.  I even have a ticket open with MSFT and not moving very fast...

    Wednesday, May 29, 2013 8:19 PM
  • Hi

    Did you find any solutions to this ?

    I am having the same problem, and having absolutely no luck finding any solutions for this. I get 0 on "Recent" and "Ever" when I click "Most popular items" button in the ribbon in a document Library or pages Library. Also the "Usage" report under "Popularity Trends" is empty.

    I have run out of ideas on how to fix this. Our solution has been in Production for more than six months now.

    Please advice.

    Tuesday, June 18, 2013 11:55 AM
  • We have the same issue on our SharePoint 2013 Popularity Trends report. The usage data worked well until May. It stops getting new data then.

    We do have up-to-date data in Logging Database, dbo.RequestUsagePartitionX tables, but somehow the data do not appear in the Excel report. Anyone have a suggestion on what could go wrong?

    Thanks in advance.

    Tuesday, June 18, 2013 9:11 PM
  • Kreedo. Did you get any answer from Microsoft ?

    Wednesday, June 19, 2013 8:45 AM
  • Ping


    anybody here ? 

    Wednesday, June 19, 2013 6:19 PM
  • ????????????????????????????????????????????????????????????????????????????????
    Monday, June 24, 2013 12:42 PM
  • Having the same issue as well =(


    Thursday, July 11, 2013 3:13 PM
  • Same problem here. Anyone?
    Tuesday, July 30, 2013 7:40 PM
  • Exact the same issue here. Did somebody find a solution by now?
    Wednesday, August 21, 2013 5:55 AM
  • Same issue here.
    It worked perfect until - i guess - we changed from http:// to https://. Since then we have only 0 in the populary pages or list-reports. The only report who is working is the "Usage" report below "Site Administration".

    Monday, September 09, 2013 8:50 AM
  • Did any one got solution. same issue for us :)


    Thursday, October 31, 2013 11:58 PM
  • Running into the same issue as the person from 9/9/13 --

    Worked fine prior to migrating http to https://

    6 Server farm 100% server 2012, sharepoint 2013 CU October 

    Wednesday, November 06, 2013 9:35 PM
  • Same issue. 
    Thursday, November 07, 2013 2:07 AM
  • Same here.... Please help!
    Friday, November 22, 2013 2:41 PM
  • The following steps may help you.

    1) Enabling Usage Report in SharePoint Central Administration
    You have to enable usage data collection and timer job in SharePoint Central Administration.
    Look at the following post.

    2) Configuring Usage Definition
    In order to get Popularity Trends Report, you have to add recievers and configure "EnableReceivers" settings.
    Look at the following post.

    • Proposed as answer by Kris_sp2013 Tuesday, August 05, 2014 8:21 PM
    • Unproposed as answer by Kris_sp2013 Sunday, September 14, 2014 9:52 AM
    Wednesday, February 19, 2014 3:02 AM
  • I ran into similar situation before.  It was working for awhile and all of the sudden it stopped.  I noticed there wasn't anything logged to the Usage database and the log folder in the 15 Hive (default location) has a very old modified date.  The timer jobs and event handlers were all in place.  

    What ended up fixing my problem is to change to file log location from 15 Hive to somewhere else, say /_log folder.  After that I can see logs starts populating in the file system and also in the database.
    • Proposed as answer by Gus.C Monday, June 15, 2015 11:40 PM
    • Unproposed as answer by Gus.C Tuesday, June 16, 2015 6:01 PM
    • Proposed as answer by Phil Quick Tuesday, December 06, 2016 2:19 PM
    Monday, June 15, 2015 3:54 PM
  • Hi,

    In SP2013 analytics is part of the Search Service so first you need to check if your search is working as expected. If search is working then you need to check for any other issues. One of them may be as it was already stated:

    Robi MCT Kompas Xnet d.o.o. Ljubljana | blog: | website:
    Please vote if you find reply useful or mark it as answer.
    Thank you

    • Proposed as answer by AhCheng Wednesday, July 15, 2015 2:09 AM
    Tuesday, June 16, 2015 3:53 AM
  • Hi Robi,

    I tried your method and the data is appearing now.



    Monday, July 20, 2015 8:42 AM
  • We have the same issue, but for us it turned out someone had rebooted our Web Server #2 (while I was on holiday!) and failed to check the SPTimerV4 (SharePoint Timer Service) had not restarted.
    Friday, November 11, 2016 11:52 AM
  • This solution worked for me
    Tuesday, December 06, 2016 2:19 PM
  • Check permissions for shared analytics folder.

    Computer management -> Shares -> Analytics *** -> Security tab
    WSS_WPG must have full control.

    In my case -WSS_WPG doesn't have full control. I granted permissions and then recreated Usage and Health application service.

    To recreate Usage and Health application service:

    1)Remove it in Central Administration -> Application services
    2) Central Administration -> Monitoring -> Configure Health and Analytics

    In my case i've created new db for analytics.

    Hope it will be helpful.

    Friday, April 06, 2018 5:40 AM