locked
App-V Deployment Kit Fails to Install RRS feed

  • Question

  • I was trying to deploy Office 2010 to my deskto when I ran across a problem. I had been using the Beta version of the deployment kit so I uninstalled it to use the RTM version. Except that when it gets to a certain point in the installation it stops installing and undoes all the changes. I have copied the location of the error from the MSI logs. Has anyone experienced something like this?

    MSI (s) (78:60) [15:43:11:029]: Executing op: RegOpenKey(Root=-2147483646,Key=Software\Microsoft\OfficeSoftwareProtectionPlatform,,BinaryType=1,,)
    MSI (s) (78:60) [15:43:11:029]: Executing op: RegAddValue(Name=UserOperations,Value=#0,)
    MSI (s) (78:60) [15:43:11:030]: Executing op: ActionStart(Name=CAInstallLicenses,,)
    MSI (s) (78:60) [15:43:11:041]: Executing op: CustomActionSchedule(Action=CAInstallLicenses,ActionType=11265,Source=BinaryData,Target=**********,CustomActionData=**********)
    MSI (s) (78:60) [15:43:11:043]: Creating MSIHANDLE (1051) of type 790536 for thread 4960
    MSI (s) (78:6C) [15:43:11:043]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI5F38.tmp, Entrypoint: CAInstallLicenses
    MSI (s) (78!6C) [15:43:11:049]: Creating MSIHANDLE (1052) of type 790531 for thread 2156
    CAInstallLicenses:  OMSICA : Initializing CustomAction CAInstallLicenses
    MSI (s) (78!6C) [15:43:11:049]: Closing MSIHANDLE (1052) of type 790531 for thread 2156
    MSI (s) (78!6C) [15:43:13:151]: Creating MSIHANDLE (1053) of type 790531 for thread 2156
    CAInstallLicenses:  Populating the Token Store
    MSI (s) (78!6C) [15:43:13:151]: Closing MSIHANDLE (1053) of type 790531 for thread 2156
    MSI (s) (78!6C) [15:43:13:151]: Creating MSIHANDLE (1054) of type 790531 for thread 2156
    CAInstallLicenses:  Installing license: sl.RAC.GENERIC.PRIVATE
    MSI (s) (78!6C) [15:43:13:152]: Closing MSIHANDLE (1054) of type 790531 for thread 2156
    MSI (s) (78!6C) [15:43:13:157]: Creating MSIHANDLE (1055) of type 790531 for thread 2156
    CAInstallLicenses:  Error: Failed to open Token Store HResult: 0x80070424.
    MSI (s) (78!6C) [15:43:13:157]: Closing MSIHANDLE (1055) of type 790531 for thread 2156
    MSI (s) (78!6C) [15:43:13:157]: Creating MSIHANDLE (1056) of type 790531 for thread 2156
    CAInstallLicenses: 
    MSI (s) (78!6C) [15:43:13:157]: Closing MSIHANDLE (1056) of type 790531 for thread 2156
    CustomAction CAInstallLicenses returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
    MSI (s) (78:6C) [15:43:13:158]: Closing MSIHANDLE (1051) of type 790536 for thread 4960
    Action ended 15:43:13: InstallFinalize. Return value 3.
    MSI (s) (78:60) [15:43:13:163]: User policy value 'DisableRollback' is 0
    MSI (s) (78:60) [15:43:13:163]: Machine policy value 'DisableRollback' is 0

    Friday, May 28, 2010 5:39 PM

Answers

  • Hello,

    You cannot install it in a single-sequence. You need to install as per the prescriptive guidance;

    1. Licensing flag

    2. Optional properties

    The prescriptive guidance is available here; http://support.microsoft.com/kb/983462


    /Znack
    • Proposed as answer by znack Monday, March 7, 2011 10:54 PM
    • Marked as answer by Aaron.ParkerModerator Tuesday, July 12, 2011 1:39 PM
    Monday, March 7, 2011 8:56 PM

All replies

  • Hello,

    are you using the correct bits? (32 v 64)

     

    /Znack

    Friday, May 28, 2010 8:49 PM
  • I have a 64 bit system so I can install both the 32 bit and 64 bit. The Beta Version I had been using was 32 bit and the new RTM version I am trying to install is also 32bit.
    Tuesday, June 1, 2010 6:36 PM
  • Hello,

    For a 64-bit operating system the app-v deployment kit should be the 64-bits. For a 32-bit operating system the app-v deployment kit should be 32-bit.

    /Znack
    Tuesday, June 1, 2010 7:10 PM
  • Znack,

    I still receive this very same error even when installing 64-bit bits on a 64-bit OS. 

    Does anyone have any other suggestions?

    Brian S.

    Monday, March 7, 2011 4:51 PM
  • Hello,

    Verify that no other deployment kits (beta, bits etc) are installed. 
    /Znack
    Monday, March 7, 2011 4:58 PM
  • None.  Brand New Windows 7 Enterprise x64 with App-V 4.6 x64 installed.
    Monday, March 7, 2011 5:07 PM
  • Hello,

    I am assuming you don't have the right bits then....
    /Znack
    Monday, March 7, 2011 5:09 PM
  • I have the right bits.  I can assure you of that.  Downloaded them fresh.  However, there may be pre-requisites that I don't have.  Does anyone have a list of what's needed on a Office Virt machine above the 4.6 client requirements.
    Monday, March 7, 2011 5:52 PM
  • So here's some more information...

    So if I run a really simple installation command it works.  Something like this...

    msiexec /i %~dp0x64\OffVirt.msi PROPLUS=1 /l*v %windir%\logs\OffVirtProxy.log

    If I run a more complex command to setup the proxies it fails with the above error message.  The more complex command is something like this:

    msiexec /i %~dp0x64\OffVirt.msi PROPLUS=1 ADDDEFAULT=Click2runOneNoteProxy,Click2runOutlookProxies,Click2runWDSProxy,Click2runOWSSuppProxies PACKAGEGUID={MYGUID} PACKAGEVERSION=14.0.4755.1000 OUTLOOKNAME="Microsoft Outlook 2010" ONENOTENAME="Microsoft OneNote 2010" MAPISERVER="Proxy Microsoft Virtual Office Simple Mapi Proxy Server" VIRTUALSEARCHHOST="Proxy Search MAPI Protocol Handler Host" MLCFG32CPL="Proxy Mail Control Panel" OWSSUPPServer="Proxy Microsoft SharePoint Client Support Manager" /l*v %windir%\logs\OffVirtProxy.log

    I need the more complex integration of the proxies, not just the licensing, so why does the command that works on x86 with x86 bits not work on x64 with x64 bits?  The documentation clearly states that the bits are based on OS bit-level not the Office bit-level.

     

    Monday, March 7, 2011 7:38 PM
  • Hello,

    You cannot install it in a single-sequence. You need to install as per the prescriptive guidance;

    1. Licensing flag

    2. Optional properties

    The prescriptive guidance is available here; http://support.microsoft.com/kb/983462


    /Znack
    • Proposed as answer by znack Monday, March 7, 2011 10:54 PM
    • Marked as answer by Aaron.ParkerModerator Tuesday, July 12, 2011 1:39 PM
    Monday, March 7, 2011 8:56 PM